Suse 11.0 Linux<=> Windows Problem

Hi:

I mostly set up Samba.etc by following:

TweakHound

In any event,so far,here 's situation:

  1. When I click :
  • My Computer>Network Folders>Samba Shares - remote:/smb-network

gives me blank screen

Konqueror>smb://winbox - works perfectly _as they say in German “Wunderbar!”

So…I can connect Linux> Windows

my problem is: I can’t connect Windows >Linux
(I just reinstalled XP Home(for other reasons) and even on a fresh install,it still doesn’t work!

Any ideas?

Thanks
Richard

Lots of Samba stuff here:
Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3, 11.0, 11.1

On Mon April 13 2009 08:56 pm, itpro007ca wrote:

>
> Hi:
>
> I mostly set up Samba.etc by following:
>
> ‘TweakHound’ (http://www.tweakhound.com)
>
> In any event,so far,here 's situation:
>
> 1) When I click :
>
> * My Computer>Network Folders>Samba Shares - remote:/smb-network
>
> gives me blank screen
>
> Konqueror>smb://winbox - works perfectly _as they say in German
> “Wunderbar!”
>
> So…I can connect Linux> Windows
>
> my problem is: I can’t connect Windows >Linux
> (I just reinstalled XP Home(for other reasons) and even on a fresh
> install,it still doesn’t work!
>
> Any ideas?
>
>
> Thanks
> Richard
>
>

On Mon April 13 2009 09:16 pm, caf4926 wrote:

>
> Lots of Samba stuff here:
> ‘Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3,
> 11.0, 11.1’ (http://www.swerdna.net.au/linux.html)
>
itpro007ca;
You should be sure to read the HowTo(s) on swerdna’s site as given you by
caf4926. The most common errors in setting up Samba sharing are solved
with:

  1. Setting the Firewall, details are on swerdna’s site. You need to be sure
    these ports are open. TCP: 135,139,445; UDP: 137,138. Be sure not to block
    broadcasts. While testing you might want to disable the firewall until you
    are sure the rest is working.
  2. Make sure that both smbd and nmbd are both running. To check run:

ps -A | grep [s,n]mbd

  1. Make sure to add Samba users:

su
smbpasswd -a <username>

The <username> must be a valid Linux user, although the password can be
different from the log on pass word.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

richard@linux-u719:~> ps -A | grep [s,n]mbd
2344 ? 00:00:00 nmbd
3221 ? 00:00:00 smbd
3254 ? 00:00:00 smbd
richard@linux-u719:~>

This the result I get using the command you gave.

->su
smbpasswd -a richard

Done!

On Tue April 14 2009 02:46 pm, itpro007ca wrote:

>
> richard@linux-u719:~> ps -A | grep [s,n]mbd
> 2344 ? 00:00:00 nmbd
> 3221 ? 00:00:00 smbd
> 3254 ? 00:00:00 smbd
> richard@linux-u719:~>

This is good. They’re both running.
>
> This the result I get using the command you gave.
>
> ->su
> smbpasswd -a richard
>
> Done!
>
itpro007ca;

Does this help? What happens when you try to browse your workgroup from
Windows? If you have read Swerdna’s HowTos and are still having problems,
please post the contents of: /etc/samba/smb.conf. You can use place holders
for any critical/sensitive information in the config file.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Still trying to debug this.

I’m also reading the Samba Tutorial page posted above to see if I can find the error,or errors.

So far,trying to connect to my linux samba server from on the Linux PC yielded the following error:

An error occurred while loading smb://linux-u719/richard:
Internal Error
Please send a full bug report at http://bugs.kde.org
Unknown error condition in stat: No data available

Here’s my smb.conf file:

Samba config file created using SWAT

from UNKNOWN ()

Date: 2009/04/14 16:05:00

[global]
workgroup = MSHOME
map to guest = Bad User
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \%L\profiles.msprofile
logon drive = P:
logon home = \%L%U.9xprofile
os level = 2
local master = No
domain master = No
usershare allow guests = Yes
usershare max shares = 100
hosts allow = 192.168.0.0/255.255.255.0
cups options = raw
netbios name = LINUX-U719

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes
browseable = No

[profiles]
comment = Network Profiles Service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = Yes

[print$]
comment = Printer Drivers

My network = 192.168.1.100 to whatever(.101 for the linux PC)…

should generic be:

hosts allow: 192.168.0.0/net mask or 192.168.1.0

My Firewall on the Windows PC see s it as 192.168.0.0 so I guess that’s ok?

I forgot to add that I disabled Suse 11.0’s firewall and the Sunbelt Personal Firewall on the windows xp home machine,but still no network,so it looks like the error is elsewhere.

I went to Tweakhound and redid the Suse 10.3 Smab bit to check for errors,but so far no go…it maybe the file shares are wrong?

Basically,I just share my home directory,although it’d be nice to browse the whole tree from the Windows box.

An update:

So far,following Swerda’s tutorial,here are the changes I’ve made(as opposed to Tweak Hound):

local master = yes
os level = 33

Tweakhound says: no,02

also :

in Swerda’s doc:

↑↑↑↑Opening the Firewall for Samba

had no “broadcasts allow” so had to do steps 1-3

Previously,a computer search for “linux-719” on the Xp box found the Samba server,listed groups,homes,printers,etc but was denied access.

Network Places couldn’t browse beyond mshomes

Now,using Network Places I can bring up all the above,BUT I get a :

“\linux-u719\homes is not accessable…network path was not found.”

So…almost there!

from konqueror,if I try :

smb://linux-u719 - "timeout out on server -linux-u719
smb://linux-u719/richard -An error occurred while loading smb://linux-u719/richard:
The file or folder smb://linux-u719/richard does not exist.

So…

is the above because somewhere I haven’t made ie: the homes directory “browsable?”

Is that not what the “browsable= yes/no” line the smb.conf global shares refers to?

Thanks
for everybody’s help -so far.Almost there…

1 question: netbios name for Samba server -is that any name,the name of the linux PC,the Windows PC,or what?

“\linux-u719\homes is not accessable…network path was not found.”

You access the homes share with \linux-u719\username
It expects you to use your Linux username. Then you will be asked to supply the credentials you put into the samba user database for your username.

That will get you access to your whole home file tree.

Don’t make the share to be browsable = yes, or you’ll reveal all the users to each other and the world (or something like that).

Try this too: hosts allow = 192.168.0.

And I’d turn off [groups] in Yast → samba server because it doesn’t make sense if you have no directory /home/groups.

And maybe make a choice between [homes] and [users] because each is very similar to the other except for some visibility and security aspects which are described here: The Suse/openSUSE Default Shares

Thanks

I did as you suggested and disabled groups and users in Yast>>>Samba Server

Should there be an “x” for “allow users to share their directories?”

Netbios name - is that my linux pc’s name,the samba server name(can be anything?)?

Thanks for all help -so far.It’s getting there…slowly. lol

On Tue April 14 2009 05:26 pm, itpro007ca wrote:

>
> Still trying to debug this.
>
> I’m also reading the Samba Tutorial page posted above to see if I can
> find the error,or errors.
>
> So far,trying to connect to my linux samba server from on the Linux PC
> yielded the following error:
>
> An error occurred while loading smb://linux-u719/richard:
> Internal Error
> Please send a full bug report at http://bugs.kde.org
> Unknown error condition in stat: No data available
>
> Here’s my smb.conf file:
>
> # Samba config file created using SWAT
> # from UNKNOWN ()
> # Date: 2009/04/14 16:05:00
>
> [global]
> workgroup = MSHOME
> map to guest = Bad User
> printcap name = cups
> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
> -s /bin/false %m$
> logon path = \%L\profiles.msprofile
> logon drive = P:
> logon home = \%L%U.9xprofile
> os level = 2
> local master = No
> domain master = No
> usershare allow guests = Yes
> usershare max shares = 100
> hosts allow = 192.168.0.0/255.255.255.0
> cups options = raw
> netbios name = LINUX-U719
>
> [homes]
> comment = Home Directories
> valid users = %S, %D%w%S
> read only = No
> inherit acls = Yes
> browseable = No
>
> [profiles]
> comment = Network Profiles Service
> path = %H
> read only = No
> create mask = 0600
> directory mask = 0700
> store dos attributes = Yes
>
> [users]
> comment = All users
> path = /home
> read only = No
> inherit acls = Yes
> veto files = /aquota.user/groups/shares/
>
> [groups]
> comment = All groups
> path = /home/groups
> read only = No
> inherit acls = Yes
>
> [printers]
> comment = All Printers
> path = /var/tmp
> create mask = 0600
> printable = Yes
> browseable = Yes
>
> [print$]
> comment = Printer Drivers
>
> My network = 192.168.1.100 to whatever(.101 for the linux PC)…

> should generic be:
>
> hosts allow: 192.168.0.0/net mask or 192.168.1.0
>
> My Firewall on the Windows PC see s it as 192.168.0.0 so I guess that’s
> ok?
>
itpro007ca;

> My network = 192.168.1.100 to whatever(.101 for the linux PC)…

192.168.1* and 192.168.0.* are different subnets. Make everything 192.168.0
or 192.168.1 do not mix and match. Maybe this was a typo?

Try a simple /etc/samba/smb.conf such as the following:


workgroup = MSHOME
netbios name = LINUX-U719
# The above is not needed unless it differs from your host name.
map to guest = Bad User
name resolve order = bcast host lmhosts
username map = /etc/samba/smbusers
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
os level = 65
preferred master = Yes
host msdfs = No
usershare allow guests = Yes
usershare owner only = False


I believe Swerdna has something similar on his site. I understood you could
not connect FROM Windows.

So…I can connect Linux> Windows

my problem is: I can’t connect Windows >Linux

What happens when you try to connect from Windows?


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On Tue April 14 2009 10:36 pm, PV wrote:

> On Tue April 14 2009 05:26 pm, itpro007ca wrote:
>
>>
>> Still trying to debug this.
>>
>> I’m also reading the Samba Tutorial page posted above to see if I can
>> find the error,or errors.
>>
>> So far,trying to connect to my linux samba server from on the Linux PC
>> yielded the following error:
>>
>> An error occurred while loading smb://linux-u719/richard:
>> Internal Error
>> Please send a full bug report at http://bugs.kde.org
>> Unknown error condition in stat: No data available
>>
>> Here’s my smb.conf file:
>>
>> # Samba config file created using SWAT
>> # from UNKNOWN ()
>> # Date: 2009/04/14 16:05:00
>>
>> [global]
>> workgroup = MSHOME
>> map to guest = Bad User
>> printcap name = cups
>> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
>> -s /bin/false %m$
>> logon path = \%L\profiles.msprofile
>> logon drive = P:
>> logon home = \%L%U.9xprofile
>> os level = 2
>> local master = No
>> domain master = No
>> usershare allow guests = Yes
>> usershare max shares = 100
>> hosts allow = 192.168.0.0/255.255.255.0
>> cups options = raw
>> netbios name = LINUX-U719
>>
>> [homes]
>> comment = Home Directories
>> valid users = %S, %D%w%S
>> read only = No
>> inherit acls = Yes
>> browseable = No
>>
>> [profiles]
>> comment = Network Profiles Service
>> path = %H
>> read only = No
>> create mask = 0600
>> directory mask = 0700
>> store dos attributes = Yes
>>
>> [users]
>> comment = All users
>> path = /home
>> read only = No
>> inherit acls = Yes
>> veto files = /aquota.user/groups/shares/
>>
>> [groups]
>> comment = All groups
>> path = /home/groups
>> read only = No
>> inherit acls = Yes
>>
>> [printers]
>> comment = All Printers
>> path = /var/tmp
>> create mask = 0600
>> printable = Yes
>> browseable = Yes
>>
>> [print$]
>> comment = Printer Drivers
>>
>> My network = 192.168.1.100 to whatever(.101 for the linux PC)…
>
>> should generic be:
>>
>> hosts allow: 192.168.0.0/net mask or 192.168.1.0
>>
>> My Firewall on the Windows PC see s it as 192.168.0.0 so I guess that’s
>> ok?
>>
> itpro007ca;
>

>> My network = 192.168.1.100 to whatever(.101 for the linux PC)…
>

> 192.168.1* and 192.168.0.* are different subnets. Make everything 192.168.0
> or 192.168.1 do not mix and match. Maybe this was a typo?
>
> Try a simple /etc/samba/smb.conf such as the following:
This is for the [global] section, keep the [printers] and [homes] shares.
>


>         workgroup = MSHOME
>         netbios name = LINUX-U719
> # The above is not needed unless it differs from your host name.
>         map to guest = Bad User
>         name resolve order = bcast host lmhosts
>         username map = /etc/samba/smbusers
>         printing = cups
>         printcap name = cups
>         printcap cache time = 750
>         cups options = raw
>         os level = 65
>         preferred master = Yes
>         host msdfs = No
>         usershare allow guests = Yes
>         usershare owner only = False
>
> 

> I believe Swerdna has something similar on his site. I understood you could
> not connect FROM Windows.
>

> So…I can connect Linux> Windows
>
> my problem is: I can’t connect Windows >Linux
>

>
> What happens when you try to connect from Windows?
>


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

I’m getting in the way here – over to you guys.

OK,to the person who mentioned the subnets:

Here’s my setup:

1 x Suse Linux 11.0 Pc - 192.168.1.101
1x Win XP Home PC - 192.168.1.100

Linksys BEFSR41 4 port Router → DHCP–>Internet
->Pcs -static(DHCP off)

Will make suggested changes,then post smb.conf for further checking

Don’t do that,you already got me this far!

btw: I had a look at your website -great site!

Question: What’s difference between OS=2,33 and 65?

#2: Local master,preferred master? “que(spanish for “huh!?”)?” What’s the difference?

Update:

After fouling thins up,by changing the subnet in ea. step of Swerda’s tutorial and ending up again not getting past “Mshomes” in Windows,I checked it firewall,noticed it had the hoem network as: 192.168.1.0 and changed it accordingly on the Linux machine,as well setting Linux as "preferred Master=yes,local master=yes,os=65

I don’t really know what those mean,but they sound like the stuff I took in Windows Server Admin in my Network Administration course days.

So…now:

Linux:

My computer>Network Folders>remote:/smb-network -“could not connect…”

Konqueror>smb://winbox - yes

Windows>Network Places>…Mshomes>directories>

Double-clicking “Homes” get an error message -still

*maybe my permissions aren’t right?

In SWAT>Global Settings> should “Hosts Lookup” be on?

Thanks,to the Internet/Linux Brain(Matrix),it’s almost there.

btw:

my resolve order(saw it somewhere) is set to:

lmhosts…bcast

how do I change it to suggested?

Any other suggestions?

Thanks for the compliment

The Local Master Browser has the job of collating IP -vs- NetBIOS name pairs and serving these to the workstations on the local LAN. A number of things including os level contribute to winning elections for LMB. The higher the os level, the more likely the machine is to win. 2 means probably won’t win. 33 will beat win98/me, win2000 and xp, 64 will beat obviously beat 33. So I keep that in mind when I’m thinking what to do around a LAN.

All Local Masters participate in elections but they don’t get beat up about it if they don’t win. Preferred Masters keep on calling elections if they haven’t won already. So you only have one preferred master on a subnet or else they’ll always be squabbling.

Should there be an “x” for “allow users to share their directories?”
That’s a very misleading statement on part of devs. It’s really for so-called usershares which are created in Gnome’s Nautilus browser. Pity they don’t label it so. You can check it or not check it. It won’t affect the shares defined in the file smb.conf.

Thanks for the explanation.

Next question: In your tutorial,you have netbios name as “acerxp”
or the “full computer name” of your windows pc,which your tutorial also states is the name of the Samba network.

On mine,clicking Yast>…Samba Server and also Swat>…localhost:901…shows it as “linux…”

Somebody mentioned that if you don’t specify it,or leave it blank,it’ll be the same as your Linux host name?

I have a few other questions,but I’ll leave them for now

This is all probably too confusing for you now. I recommend that you make your smb.conf like this:

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2008-08-27

This is a Local Master Browser and the Preferred Master

[global]
workgroup = MSHOME
netbios name = LINUX-U719
name resolve order = bcast host lmhosts wins
server string =
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
use client driver = yes
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
usershare allow guests = Yes
usershare max shares = 100
usershare owner only = False

   [homes]                
   comment = Home Directories
   valid users = %S, %D%w%S  
   browseable = No           
   read only = No            
   inherit acls = Yes        

Share disabled by YaST

[profiles]

comment = Network Profiles Service

path = %H

read only = No

store dos attributes = Yes

create mask = 0600

directory mask = 0700

Share disabled by YaST

[users]

comment = All users

path = /home

read only = No

inherit acls = Yes

veto files = /aquota.user/groups/shares/

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0700
guest ok = yes
browseable = No

Share disabled by YaST

[print$]

comment = Printer Drivers

path = /var/lib/samba/drivers

write list = @ntadmin root

force group = ntadmin

create mask = 0664

directory mask = 0775

That should allow you to browse from windows using \servername\yourname and supplying your credentials when asked. I’d stop using swat because it strips out all the commented (#) structure.

You can experiment with turning shares on and off in Yast Samba Server between [homes] [users] [profiles]

Back up your existing smb.conf with:

sudo cp /etc/samba/smb.conf /etc/samba/smb.conf.backup

Then open the file for editing with htis command for Gnome users:

gnomesu gedit /etc/samba/smb.conf

or this command for KDE user:

kdesu kwrite /etc/samba/smb.conf

and use copy/paste to change the contents over to the suggested template above.

Turn off the firewalls until you’ve got this going. Leave the allowed hosts out until it’s going. Then introduce those 1 at a time.
bBTW the line is (I think)

hosts allow = 192.168.1.