SUSE 11.0 Letdown

I had installed 10.3 on my Toshiba Laptop, it work almost to good,
Yesterday i loaded 11.0, holly cow, big letdown, nothing works, the system locks up, the downloads fail, the software repositories fail, the video player fails, in-fact all my multi-media has failed.

Sooooo, what are the fixes, can i down grade back to 10.3???

Thanks you for your time.

You can’t downgrade, at least not reliably. You’ll have to re-install if you want 10.3.

On the other hand, you could post some more specifics about the actual issues you are having, as well as mention whether you did an upgrade (which would account for some of the issues you have if not done correctly) or a clean install. The community here is willing to help if you ask… :wink:


Sorry to hear you are having such issues… There’s always some thing to fix or tweak with a new install, but you’ve got a whole load.

Maybe we can sort things as openSUSE 11 should be just as smooth as 10.3.

Curious, what filesystem type did you use (ext3/reiser) & which DE (KDE/GNOME/Other) do you use?


Thank you for your response.

All the URL links in the software repositories failed, so i did an edit on each URL, if the URL was FTP i changed it to HTTP which fails, but when you then edit the same line and change back to FTP the interface loads, i did this with every URL, i now have that working, that fix also intergrated the GPG keys which failed eariler.

The MPEG player i had problems down loading software, the downloads failed not just on the MPlayer but all downloads in the software management, however i when ran “svn checkout svn:// mplayer” from root i was able to download and install MPLayer.

System lockup, happens at any time, example login to this forum the system did a spazze, the laptop went in to high gear and locked up, no way out other than hard reboot.

The upgrade from 10.2 to 10.3 was smooth, the upgrade from 10.3 to 11.0
crikee!! i am a bit supprised at the amount of time required to fix or read multiple forums tips just to get the system back on-line.

Anyway no worries, i am working the problems.


If possible a reinstall might not be a bad idea. There are many issues you describe that, in my opinion, should not have been there…
In upgrading, did you really upgrade or do a new install?
There are many changes in openSUSE 11.0 and if your system is coming from 10.2 > 10.3 to 11.0… that could be causing you some trouble too. But if you did a fresh install this of course does not apply.

I though I might add this link : ubuntu user… horrified by first login FREEZE - openSUSE Forums
It could give some information on why your system is freezing… see post #16 for more detail on this.

Hope that helps & wishing you luck,


Thank you for your response.

Yes this an upgrade not a new install.

I have 4 other computers all running 10.3, all will be upgrades to 11.0. This is a big concern, new installs would not be possible at this point.

Example of one or the errors

Download (curl) error for ‘’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘


A few thoughts on the error:

-Are you sure dns is working correctly? And is maybe a proxy set in YaST?
-When you ping on the machine, does the name get resolved alright?

DNS is resolving
I can ping “” no problem.


did you also check YaST > Proxy ?
If you are not using a proxy server this should not be enabled.

YaST tools will use these settings, that’s the only thing I can think of why it’s not working but your ping is.

Other than that, could you post the output of ’ zypper lr ’ ?
You need to be root & it will give us a glimpse at the repositories that are setup on your system.

On 2008-07-03, mtfelix <> wrote:

> I had installed 10.3 on my Toshiba Laptop, it work almost to good,
> Yesterday i loaded 11.0, holly cow, big letdown, nothing works, the
> system locks up, the downloads fail, the software repositories fail,
> the video player fails, in-fact all my multi-media has failed.

Your message doesn’t provide much usefull information, does it ?

From you reaction, you eighter have a very, very recent machine.
… or you’re using openSUSE 11 with KDE 4.

KDE 4 is not very good yet. If you don’t have to much time invested, just
reinstall openSUSE 11 with KDE 3.5.9.

It works great for me, it installed flawlessly on several machines, amongst
which 3 laptops.

The sand remembers once there was beach and sunshine
but chip is warm too
– haiku from Effector Online, Volume 1, Number 6

Good news… i have the wireless interface working,
now that alone is worth its weight in expensive compressed

List as requested.

| Alias

 | Name                                             | Enabled | Refresh

1 | 20080701-221142_1
| 20080701-221142 | Yes | Yes
2 | openSUSE-retail_11.0
| openSUSE-retail 11.0 | Yes | No
3 | Index of /repositories/server:/database/openSUSE_11.0
| openSUSE BuildService - Database | Yes | Yes
4 | NVIDIA_Repository
| NVIDIA Repository | Yes | Yes
5 | openSUSE_BuildService_-KDE4:Factory:Desktop
| openSUSE BuildService - KDE4:Factory:Desktop | Yes | Yes
6 | openSUSE_BuildService
| openSUSE BuildService - Mail Server | Yes | Yes
7 | Index of /repositories/drivers:/wlan/SUSE_Linux_Factory
| openSUSE BuildService - Drivers for Wireless LAN | Yes | Yes
8 | Packman_Repository_1
| Packman Repository | Yes | Yes
9 | VideoLan_Repository_1
| VideoLan Repository | Yes | Yes
10 | Main Repository (OSS)
| Main Repository (OSS) | Yes | Yes
11 | repo-debug
| openSUSE-11.0-Debug | Yes | No
12 | repo-oss
| openSUSE-11.0-Oss | Yes | No
13 | 20080701-221054_1 | 20080701-221054 | Yes | Yes
14 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
15 | 1.0/ | openSUSE BuildService - | Yes | Yes
16 | openSUSE_BuildService
-_KDE:Community | openSUSE BuildService - KDE:Community | Yes | Yes
17 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
18 | | ATI Repository | Yes | Yes
19 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
20 | Index of /distribution/11.0/repo/debug | Main Repository (DEBUG) | Yes | Yes


Ahhh… progress , that is good! :slight_smile:

You have quite a list there…
It could be an option to use YaST > Software Repositories to clear them all out except;

These are the default repositories for openSUSE 11.0

save/apply the listing & reopen YaST > Software Repositories > select ADD > Community Repositories and add the repositories you would like to have.

That should give you back a clean list.

Your opening remarks to my original comments appears to be condescending!!

what is “eighter”?

If you actually followed the thread you will see that the 11.0 software has some problems some of which i have fixed other issues remain outstanding.

The data i have supplied up to this point has been in general terms, you do not know my internetworking background just as i do not know yours, if more complex in-depth documentaion is required, such as which controlling processe are running and which ones are being killed and why, and what certain operation values are failing, where is the documentation that required when posting a query one should write a complete techincal outline complete with an analysis.

Thank you for your response,

Yes it was quite a list.

Thanks for your help, so far i have spent the day fixing issues, i have develope more problem, a few minutes ago the laptop’s CPU’s (i have dual core) both ran up to 90% a reboot from the terminal was the only course
i did ps -ef|more for which processes were running but that command ran the processors up to 100%, i may just do a full install rather than the upgrade.

I will let you know

Thanks again

A full (clean) install does seem best to do. Maybe go for a dual boot so you can switch between old and new if needed.

Again wishing you luck!

Instead of doing a clean install, you CAN delete every auxilliary repository. Leave the standard OpenSuSE install and update intact and give in a shell as root the following commands:

zypper ref
zypper dup

The first refreshes the rpm database against the remaining stock repositories
The second re-installs all the bits from the stock in order to get you back to stock install.

That command sequence would also be nice to use when upgrading to the next openSUSE version. Probably a good idea to get the system to a pristine state first so only officially supported packages are involved in the upgrade.


Well _ have to say I am a little upset re 11.0. I hope its just v x.0 blues.
Summary: I have been an FC user for many years, but installed 10.2 on a T23 6 months ago. I liked the distro - so I thought I would migrate my FC nodes to Suse. Figured I would start with 11.0 Wohhhh - not a great idea.

Situation: I had three FC nodes all running OK - 2 were FC3 and one was Sus 10.2.

I installed 11.0 on one of the FC3 nodes- so now I had 1 x Sus 11.0, 1 x Suse 10.2 and 1 x FC 3.

I then find 11.0 wont ping local nodes, it wont ftp local nodes. (yes - I have ftp server daemons installed and running - pure-ftdp would start, vsftpd would not start - return value of 7)
After many hours I now have the following situation:
thebe is node my new Suse 11.0 node
neptune is node my old Sus 10.2 node
metis is node 192.168.35 my old FC3 node.

neptune can ping thebe but carnt ftp to thebe
thebe can ping and ftp to metis
thebe can ping neptune
neptune can ftp to metis

It seems to me there is something wrong with the vsftpd on Suse 11.0. I had even more problems to start with - unable to ping at all - this was fixed by turning IPv6 off on thebe.

Anyone else found similar letdowns with 11?

Otherwise - it looks a nice distro and may well have me leaving FC for good.

11.0 has been a huge letdown for me too. I have been using SuSE since 8.x for email gateway scanning servers, and have never had problems like i’ve had with 11. Like the OP, I get errors on all of the repositories (I only have the built-in’s, this was a clean install). It keeps saying that it can’t resolve, but I can resolve it fine. The system locks up when i try to configure NTP and i can’t even set the time manually. I hit apply and nothing happens. I also keep getting a random popup that it was unable to download a list of updates, which i’m sure is because of the repo issues. I disabled AppArmor since VNC and SSH don’t even work with it enabled, and even now VNC still doesn’t work half of the time (i just get a gray screen with “X” cursor). I tried out the FC9 live cd on my laptop the other day and was pretty impressed, so i may just start migrating my servers to that instead.

I haven’t had any bad experiences here myself… but I’ve read the main reason people are having problems with the repositories is that a new mirror select and redirect mechanism does not always set things correctly or ends up putting you on a too heavily loaded mirror.
You should be able to fix this by setting your own (fast) repository using YaST > Software Repositories. Check the mirror listing for a good server near you.

For me openSUSE 11.0 has been a very smooth ride & mostly a big improvement over 10.3 (and I already really like 10.3).

Which DE did you install btw? Hope you sticked with KDE 3.5.9 or GNOME and not KDE 4.0?

Good luck,