Suse 11.0 .....hangs when shutting down and nothing happens

To whom it may concern

after installing Suse11.0 on my workstation … I select shutdown to turn off my computer …

Everytime is select shutdown … Suse 11.0 hangs with this message on the screen

The system will be halted immediately
Master Resources Control: runLevel 0 has been

cursor keeps blinking and nothing is Happening … and machine is not shutting down …

could be an acpi issue, not all manufacturers stick to the same standards. Or it could be an older p.c. you installed to ? try adding


to your boot options,see if that helps


No its not an older machine I install Suse 11.0 into …Its an IBM Pentium 4 HT (Intel) …2007 machine …

Step by Steph (has a Newbie)
How do you add acpi=Force into boot option …

when you boot up the p.c. you will see a menu giving you a choice,e.g.:



where it says boot, type “acpi=force” no capitalisation & no quotemarks, then press enter.


> How do you add acpi=Force into boot option …

  • open a terminal
  • type su - [don’t leave off the trailing -], then press enter
  • type root password when prompted…you will NOT see the letters as you
  • then, carefully type:

cp /boot/grub/menu.lst /boot/grub/menu.lst.BAK1

  • and hit enter…the above will make a backup copy of an important file
    that you are about to change by using YaST…

  • then type exit, hit enter to log out as root, and exit and hit enter
    again to close the terminal

then follow
YaST > (Root password) > System > Boot Loader > Edit > CAREFULLY type


[NOT acpi=Force, NOT Acpi=force, NOT acip=force]
following whatever is already on the line labeled as “Optional Kernel
Command Line Parameter”

change NOTHING else…
then, click “OK” and then “Finish” then close the still open YaST
Control Center window when before shutdown.

shutdown all open programs…

then, close down your computer to a power off state THIS WAY (write it
down, because you won’t see this then)…

at the blinking cursor (you mentioned in your first note) that you get
to after trying a normal shutdown,

  • type su - (as before, and enter root password when prompted)

  • then type telinit 1 and press enter

  • after a few moments of activity all should stop and at the next promt

  • type shutdown -h now

and hit enter…your computer should powerdown…if not, just hit the
power switch as everything has been stopped…

then restart your computer and see if you can shutdown normally with the
acpi=force inserted…if you can’t come back and complain :slight_smile:

DenverD (Linux Counter 282315)
A Texan in Denmark

I am seeing similar problems, with the only difference being “The system will be halted immediately” is the last message I see. The system does not power down on its own.

When I attempt to reboot I get the same results, except the last message is “Please stand by while rebooting the system…”

Additional information:

  • This is an upgrade from openSUSE 10.3 to openSUSE 11.0
  • The system uses LILO
  • The system uses the KDE3 desktop
  • Windows XP is able to power down the system
  • openSUSE 10.3 was able to power down the system
  • openSUSE 10.3 did not have “acpi=force” as a kernel parameter
  • Adding the kernel parameter “acpi=force” does not resolve the issue

I tried the suggestion of “telinit 1” and “shutdown -h now”. The results were the same.

Any suggestions would be appreciated.


Additional information that may be relevant: When I attempted to create a backup using “tar -czf” the system powered itself off, apparently due to overheating. (The system is a notebook computer.) A similar shutdown occurred during the reiserfs “not clean” recovery during the next boot. I had to hold the machine up off of the table in order to boot successfully.

Again this was not an issue with openSUSE 10.3.


> the reiserfs

search these fora for the terms reiserfs reiser and you will find
LOTS and LOTS of problems about using that file system on v 11.0, it is
best (i think) to replace it…

BUT, that may not fix the shutdown problem…which i’m sorry to say,
since you have apparently done everything i know, i can’t help more…

i suspect there is a bug…too many folks are having the problem…

DenverD (Linux Counter 282315)
A Texan in Denmark

> to overheating.

i hit Send too soon…sorry…

well, you have to solve that problem…it is a hardware problem…

if you have had the laptop a while it may have some built up crud, cat
hair, dust balls or whatever blocking the needed airflow…or, the heat
sink may not be well bonded to the cpu still…or, the fan may have
died…(i have a friend living in NYC tell me a couple of weeks ago that
his less than year old Lenovo/IBM stopped working…and, it was the fan
had failed!)

OR, perhaps it is a software problem…in that the powersaving stuff has
done something out of whack…is it a dual boot, can you really LOAD up
the cpu in another OS and check the heat??

DenverD (Linux Counter 282315)
A Texan in Denmark