Suse 11.0 doesn't detect USB stick anymore.

I’ve just tried plugging in a USB memory stick, which I’m sure I’ve done plenty of times before, but it doesn’t seem to detect it. When I do a ‘dmesg’ I get this:

usb 3-4: new high speed USB device using ehci_hcd and address 10
usb 3-4: configuration #1 chosen from 1 choice
usb 3-4: New USB device found, idVendor=13fe, idProduct=1d00
usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 3-4: Product: DataTraveler 2.0
usb 3-4: Manufacturer: Kingston
usb 3-4: SerialNumber: 5B7A1100DD9E

So it’s seeing it to a certain extent.

But when I do a ‘sudo /sbin/fdisk -l’ all it shows are my /dev/sda partitions, and nothing else.

I’ve also having a fail with a USB HD (Freecom Tough Drive) which doesn’t want to be detected properly either. However, it has never been recognised under Suse, whereas I’m sure my USB stick always used to.

Any ideas? Thanks!

Just to clarify, both the memory stick and HD mount fine under Ubuntu on different machines, so they are fine.

If you are certain this memory stick used to work in this PC with this 11.0 version of openSUSE, have you restarted your PC to 11.0 since it stopped working ? Did you try pluggin it in to a different USB port? And when you state it works fine under Ubuntu on different PCs, have you tried it with a different OS on this same PC/hardware? I assume also that your tests on a different PC are based on using the memory stick AFTER it stopped working in 11.0 ?

Yes, it used to work as I regularly used to use it on this Suse 11.0 PC. I’ve tried it on all the USB sockets too. I haven’t got another linux installation on this PC to try out, I suppose I could try a Ubuntu live-CD to test that.

The memory stick was tried on the Ubuntu PC after it stopped working on the Suse one, and worked fine.

IMHO that is a good test. Boot to a Unbuntu live-CD and test.

Also, if you have an openSUSE live-CD, do the same.