SuSE 11.0 / Dell D610: cannot change resolution to 1400x1050

Hi all,

I have installed openSUSE 11.0 on my Dell Latitude D610 but I cannot change to a resolution higher than 1024x768
I can set the resolution in YAST/Sax2 to 1400x1050 but it always falls back to 1024x768 when I try to activate it.

Hardware: Dell Latitude D610 with Intel Mobile 915GM/GMS/910GML (rev 03) grafic card. The LCD display has a max resolution of 1400x1050.

Here are some information which if found in the FAQs to check. Everything seems to be fine

>glxinfo | grep render
direct rendering : Yes
OpenGL renderer String: Mesa DRI Intel(R) 915GM 20061017 x86/MMX/SSE2

>915resolution -l
Chipset: 915GM
Mode 3c : 1400x1050, 8 bits/pixel
Mode 4d : 1400x1050, 16 bits/pixel
Mode 5c : 1400x1050, 32 bits/pixel
(shortend output)

/etc/sysconfig/videobios:
VIDEOBIOS_PATCH=“yes”
VIDEOBIOS_PARAMETERS=“3c 1400 1050”

>chkconfig boot.videobios
boot.videobios on

Also manually using 915resoution and restarting X11 does not help.

Any idea what I am doing wrong? Any hints how to change to 1400x1050?

Helmut

Have you been to Yast – Hardware – Monitor

try to set in there?

Hi

It seems this is part of yast is quite raw.
Mine doesnt work at all, it shows stuff having nothing with reality.

I may suppose you dont have proper support of your video card installed.

In my case, after installing ati drivers i got my 1280x1024 automatically, while yast still indicates 1024x768, however things work and i dont care.

Note it says MESA (software rendering) in your case, that could mean as well you didnt have your video configured properly.

You might get able to have your screen resolution once you accomplish with proper drivers installation.

Yes, I have tried to set the resolution with Yast – Hardware – Monitor

I cannot find a driver for this chipset. I tried the downloads from DRI and Intel (which contains the DRI source). But I cannot compile/make the binaries.

And I have not found a rpm in SUSE and other repos.

In Yast select
LCD—>
then your res and ref rate

—> LCD is to 1400x1050@60Hz

And it’s not working??

Post: /etc/X11/xorg.conf

In the meantime I digged into the xorg log files and found the following information:
(II) I810(0): Display Info: LFP (local flat panel): attached: TRUE, present: TRUE, size: (1024,768)
and later down in the log file
(II) I810(0): Monitor[0]: Using hsync range of 30.00-90.00 kHz
(II) I810(0): Monitor[0]: Using vrefresh range of 50.00-60.00 Hz
(II) I810(0): Not using mode “1400x1050” (no mode of this name)

I fear my display in only capable 1024x768 and not 1400x1050 as expected :frowning:
It seems as if the D610 is/was available with two different display types. I was not aware of this - sorry.
Than the behavior of suse and the driver makes sense …
Thx for your hints so far

Is there an easy way to find out which display type I have and if the display is only capable of 1024x768?
(I have no handouts or other tech docs since it is a used device)

Hey man!
You didnt read what I wrote above, did you?

Now you are about to believe stupid machine. And what if once it tells you: user is invalid, please insert new user and press any key when ready?

Its just an error. You need to set up video drivers and things shall start work for you.

I had things the same way exactly. And it doesnt matter what yast says.

I couldnt find a proper driver. Except the mentions DRI/MESA driver. Also on the intel pages I can only find the dri source. Do you have a hint where i can find the right driver?

here is my xorg.conf

/…/

SaX generated X11 config file

Created on: 2008-11-05T10:58:25+0100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “extmod”
Load “type1”
Load “glx”
Load “freetype”
Load “dbe”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “de”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
Option “XkbVariant” “nodeadkeys”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[1]”
Option “AccelFactor” “0.10”
Option “BottomEdge” “300”
Option “Buttons” “5”
Option “CircScrollDelta” “0.1”
Option “CircScrollTrigger” “2”
Option “CircularScrolling” “1”
Option “Device” “/dev/input/mice”
Option “EdgeMotionMaxSpeed” “15”
Option “EdgeMotionMinSpeed” “15”
Option “Emulate3Buttons” “on”
Option “EmulateMidButtonTime” “75”
Option “FingerHigh” “40”
Option “FingerLow” “30”
Option “HorizScrollDelta” “30”
Option “InputFashion” “Mouse”
Option “LeftEdge” “100”
Option “MaxSpeed” “0.90”
Option “MaxTapMove” “100”
Option “MinSpeed” “0.15”
Option “Name” “ALPS;Touchpad”
Option “Protocol” “auto-dev”
Option “RightEdge” “1100”
Option “SHMConfig” “on”
Option “SendCoreEvents” “on”
Option “TapButton1” “1”
Option “TapButton2” “3”
Option “TapButton3” “2”
Option “TopEdge” “50”
Option “UpDownScrolling” “1”
Option “Vendor” “Sysp”
Option “VertScrollDelta” “25”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[3]”
Option “AccelFactor” “0.10”
Option “BottomEdge” “300”
Option “Buttons” “5”
Option “CircScrollDelta” “0.1”
Option “CircScrollTrigger” “2”
Option “CircularScrolling” “1”
Option “Device” “/dev/input/mice”
Option “EdgeMotionMaxSpeed” “15”
Option “EdgeMotionMinSpeed” “15”
Option “Emulate3Buttons” “on”
Option “EmulateMidButtonTime” “75”
Option “FingerHigh” “40”
Option “FingerLow” “30”
Option “HorizScrollDelta” “30”
Option “InputFashion” “Mouse”
Option “LeftEdge” “100”
Option “MaxSpeed” “0.90”
Option “MaxTapMove” “100”
Option “MinSpeed” “0.15”
Option “Name” “ALPS;Touchpad”
Option “Protocol” “auto-dev”
Option “RightEdge” “1100”
Option “SHMConfig” “on”
Option “SendCoreEvents” “on”
Option “TapButton1” “1”
Option “TapButton2” “3”
Option “TapButton3” “2”
Option “TopEdge” “50”
Option “UpDownScrolling” “1”
Option “Vendor” “Sysp”
Option “VertScrollDelta” “25”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[5]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 287 215
HorizSync 30-90
Identifier “Monitor[0]”
ModelName “1400X1050@60HZ”
Option “DPMS”
Option “PreferredMode” “1400x1050”
VendorName “–> LCD”
VertRefresh 50-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 16
SubSection “Display”
Depth 15
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “915 GM”
BusID “PCI:0:2:0”
Driver “i810”
Identifier “Device[0]”
Option “monitor-LVDS” “Monitor[0]”
Screen 0
VendorName “Intel”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[5]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
Option “Composite” “on”
EndSection

Hi

have you been to
Mobile Intel® 915GM/GMS, 910GML Express Chipset Family Intel(R) Graphics - Linux* [RPM]

i’ve googled 62900 for “intel mobile 915gm linux” so guess you might be able to find it somewhere

Thx for the link. I have googled with similar words but always found source tars which did not compile on my systeme.

I installed the driver in runlevel 1 but it came up with errors:

ERROR: AGPGART module did not compile
ERROR: AGPGART module did not compile - AGP module turned off in kernel ??
ERROR: Kernel modules did not compile
cp: cannot stat drm/i915.ko': No such file or directory Failed to install file /lib/modules/2.6.25.5-1.1-pae/kernel/drivers/char/drm/i915.ko cp: cannot stat agpgart-2.0/intel-agp.ko’: No such file or directory
Failed to install file /lib/modules/2.6.25.5-1.1-pae/kernel/drivers/char/agp/intel-agp.ko
The installation of one or more files failed
You will need to reboot for the changes to take effect,
as we were unable to unload the current kernel modules.

Any idea? How to turn on/off AGP module in kernel?
agpgart module is loaded (lsmod / modinfo agpgart)

I’m sorry but im definitely lacking knowledge to help you at this point, and i had my own experiences with ati, not intel.

Hope somebody else helps.

But wasnt the link i gave you an rpm package you could have installed automatically?

Any idea? How to turn on/off AGP module in kernel?

Edit /boot/grub/menu.lst

default boot section
add this argument to the boot line
agp=off

Hi Helmut,

In the xorg.conf the old i810 driver is being used. Could be that is causing the issue. Other than that the set modes and all look ok to me.

Make a backup of you current xorg.conf and manually configure the Intel driver by replacing the “i810” with “intel” and reboot. That might be enough to get the correct resolution.

If manually adjusting the xorg.conf does not work, boot into runlevel 3 (init 3 as boot option) and run sax2:


sax2 -r -m 0=intel

Hope that helps,
Wj

Hi all,

@iloveyourtasteincats
Yes it was a rpm but it seems as if it tries to compile something. I have the kernel sources and other devel packages installed. But the installation of this rpm fails with errors

@caf4926
agp=off does not help to change the res with YAST. And I also get the errors when installing the dri-i915 driver rpm (mentioned by iloveyourtasteincats)

@Magic31
after changing the driver to “intel” the xserver tries to load the module i915 but it fails with “FATAL: Module i915 not found” (also modprobe i915 fails)

@all
I had a look at /lib/modules/2.6.25.5-1.1-pae/kernel/drivers/char/drm and found the file old.i915.ko.old-<timestamp> where <timestamp> is the date/time of installation of the dri-i915 rpm package. It seems as if the failed installation had moved the driver. But simply changing the name back to i915.ko does not help. startx still comes with the error “FATAL: Module i915 not found”
Any idea to roll back the failed rpm installation?