SUSE 11.0 Cyrus Imap login error since upgrade


I’ve upgraded to SUSE 11.0 and now since doing so, I can only access my imap (Cyrus) folders using “Use Secure Authentication”

If I don’t check this box, Thunderbird says, “You cannot log into x.x.x.x because the server has disabled logins”.

My problem is my phone doesn’t allow this mode. I need Cyrus back the way it was.

I’ve tried saying, “SASL_MECH_AUTH: PLAIN” and this doesn’t work nor does, “PLAIN LOGIN” as I saw in another thread (in /etc/imapd.conf).

When making changes, I’ve restarted Postfix, Saslauthd and Cyrus.

Thank you for whoever can help me!

Isn’t there someone out there who has this same problem?

I’ve upgraded my friends system and he is in the same boat needing to you Thunderbird in the “Use Secure Authentication” mode.

Problem is Outlook and mobile phones don’t support this usa mode.

Thank you

I did a little more searching and playing around and I fixed it on my own (I’m so proud of myself).

If this happens to any of you reading this.

edit /etc/imapd.conf and add the following lines:

allowplaintext: yes
sasl_mech_list: PLAIN

then restart imap.

It appears allowplaintext: yes is the only real thing that 11.0 needs added since PLAIN is in the other conf files still.

Good luck to everyone!

I’ve changed /etc/imap.conf according to your tip.

Excelent ! Works fine now. :slight_smile:

Excellent! I’m going to be installing a fresh 11.1 copy soon so I too need to remember this info :slight_smile:

Anyone use Dovecot and is this overall better for IMAP than Cyrus?

I did an upgrade from 10.3 to 11.1 an that little tweak applies there too.

Yes, dovecot is much easier to set up and maintain.