SuSE 11.0 cannot connect to the internet

I recently upgraded my SuSE 10.2 to 11.0. Since doing that,and installing the updates, I have not been able to connect to the internet. At first I could connect through an ethernet cable. Then after installing the latest Madwifi packages, the wireless card started working and the ethernet card stopped working. No neither card will work. Both cards are receiving their DHCP addresses through my access point. I can ping the access point from each interface. I can also reboot the same machine into windows and both interfaces will work. YaST ca see both cards and allow configuration. However, when I try to enter routing information, it will not stay resident.

I started kinternet and told it to check the connection. I received an error that said “Invalid Default Route” “Cannot read ‘/proc/net/route’ Resource temporarily available.”

Upon entering the command ‘route’ in konsole, I received the following:

Destination Gateway Genmask flags metric Ref Use Iface
default 192.168.1.1 255.255.255.0 UG 0 0 0 eth0
192.168.1.0 192.168.1.1 255.255.255.0 UG 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 ath0
link-local * 255.255.0.0 U 0 0 0 ath0
loopback * 255.0.0.0 U 0 0 0 lo

iwconfig on int ath0 looked normal except for one entry that said “invalid nwid 6703.”

ifconfig on both interfaces showed that neither interface was transmitting or receiving. It also showed an interface called wifi0. This interface had a mac address of 00:15:E9:89:6C:CB:30:30:00:00:00:00. This interface is transmitting and receiving packets. Shutting down this interface also shuts doen the ath0 interface. YaST also does not see the wifi0 interface.

The first part of this mac address up to the “CB” is identical to the mac address on my ath0 card.

My problem seems to me to be not of connection issues, but of bad configuration files. I don’t know how to further troubleshoot this, or correct the bad files. Does anybody have any ideas?

Just to eliminate multiple error possibilities running concurrently, try shutting down the wireless interface in network manager and focus on getting the internet connected on the wired interface, then vice versa.

You may have to add the gateway and the IP addresses of the Name Servers supplied by the ISP into the configurations.

You may be better off switching Network Manager off and using the “traditional method with ifup”. NM is useful if you have to switch between networks (like take a laptop to work & home and a cafe). “Ifup” is the go for a static one-network environment like a desktop machine in a home or an office.

I tried that. No joy. I tried all of the options through YaST that I could. I am out of ideas in working through YaST.

Can you post the output of the following commands?


/sbin/ifconfig


/sbin/route