Suse 10.3 + sudo + local user + wine app

Hi, everybody!

I have OpenSUSE 10.3 on the workplace. And I need to automate launch of one windows app by local user with root privileges (transparent for user). I know, that wine developers recommends to lunch wine under local user, but my app need some privileges that can’t supply by regular user.
I have tried to use sudo (sudoers file was modified accordingly) “sudo wine …”, but I received “Cannot connect to X server …”. Tried “DISPLAY=:0 sudo wine …” output was the same.

How can I solve it?

P.S. “su root -c ‘wine …’” doesn’t spawn the error, but can’t satisfied my needs, because it asks for root pass.

Solved it. A bit unsecure, I think, but it doesn’t bother me.
How to get Graphical Applications working with sudo in SLE 10 | Novell User Communities

I followed by instructions with some modifications.
“Defaults env_reset” I have changed to “Defaults !env_reset”. And exec “DISPLAY=:0 xhost +” by local user. Now it works fine.

If anybody have another solution, please, post it.