Surround Sound Issues

I finally (I think) have sound working. The issue now is that surround sound is nonexistent. I did change the settings in the PulseAudio configuration for 6 channels (5.1) and made sure mixer levels were turned up. Running ‘speaker-test -c6 -twav’ as root gives me output on the front left and right channels, but nothing else. Running it as a regular user (I am in the audio group) gives me this error:

E: socket-client.c: socket(): Address family not supported by protocol
*** PULSEAUDIO: Unable to connect: Connection refused
Playback open error: -111,Connection refused

I also get that error trying to run alsamixer as a regular user. I do have sound from Banshee, Flash, etc., but the command line stuff gives me that error. I already tried just getting rid of PulseAudio and installing esound, but then I couldn’t get any sound. Any ideas? According to ALSA, my card is an NVidia CK804 Realtek ALC850 rev 0, using the intel8x0 driver.

To start, you could add your regular user to group “audio”. I think there may also be a “pulse” or “pulseaudio” group (you should be able to check which groups you have setup). Also add your regular user to that group.

Note you have to log out and log back in for this to take effect.

This won’t solve your problem completely, but it should hopefully remove the permissions hiccups.

I was already in the audio group and adding me to the pulse* groups had no effect. I finally got PulseAudio successfully uninstalled (there are a lot more than the obvious packages). Now with esound I have (stereo) sound working fine. I still can’t get any surround sound, though.

OK, if I specify -Dsurround51 (Can I change the default device choice?) I get the following (closer to correct) mapping:

Front Left -> Front Left
Center -> Center
Front Right -> Front Right
Rear Left -> ???
Rear Right -> ???
LFE -> Center

I’d imagine there is some file in /etc where I can fix this, but I don’t know which one or the syntax.

A good series of speaker tests (that I like) for surround sound are the following:

7.1 channel surround:
speaker-test -Dplug:surround71 -c8 -l5 -twav

5.1 channel surround:
speaker-test -Dplug:surround51 -c6 -l5 -twav

4 channel surround:
speaker-test -Dplug:surround40 -c4 -l5 -twav

2 channel:
speaker-test -Dplug:front -c2 -l5 -twav

Note, I don’t the speakers to support surround sound, nor have I ever set up surround sound, so any advice you get from me on this will be theoretical.

Having stated that, my understanding is the way to get surround sound, is to implement a custom /home/your-username/.asoundrc file. ie The “.asoundrc” file contents are key.

I’m not at my home PC, and don’t have my links (to various .asoundrc file examples) handy, but you can read up on it here:
.asoundrc - ALSA wiki](
and here
Asoundrc - AlsaProject

If you are looking for 5.1 surround sound (and not 7.1 nor 4 channel) then you need to find a .asoundrc sound that is specifically setup for 5.1 sound.

There is more surround sound reading here:
SurroundSound - ALSA wiki

There is a thread here on this subject (on our forum) that you might find of interest, especially in the later posts.
5.1 sounds on OpenSUSE 11.0 RC - openSUSE Forums

OK, fixed it. My motherboard was mislabeled for the rear speakers; they needed to be plugged into the side jack. To change the default device, I made a /etc/asound.conf file and put in “pcm.!default surround51”.

Turns out I didn’t fix it. speaker-test worked fine, but playback in Banshee was incredibly choppy.

Did you try creating a custom .asoundrc file? Here are some URLs giving you guidance on this:
How To - Playing stereo on surround sound setup

asoundrc file examples

Surround sound in Linux