Surface pro 3

Anybody going to get Surface pro 3 next week and put Opensuse on it? I’m planning on doing it. :smiley:

Be awesome to hear how you do it, and what you think of it!

I saw this article so hopefully no problems with Opensuse, but getting the keyboard to work might be a challenge though.

A USB keyboard should be sufficient, I would think.

It does look pretty easy and straight forward, for Ubuntu at least. I know they have been doing a lot of work on touch and mobile devices but hopefully the parts that make it work are in openSUSE.

Can even try Plasma Active, which I believe is a Qt based interface designed for touch/mobile devices.

I just couldn’t imagine paying good money for it. The waste would upset me. But that’s just me. I’m not opposed to others doing it. So good luck on your exploration. I’ll be watching with interest.

Yeah now have me thinking twice about this.

In a moment of madness I went and parted with good money.
One reason is to force myself to use windows a little bit so that I don’t swear so much using other people’s computers, but as it’s pretty nice hardware and was actually available in New Zealand (unlike a lot of other upper end stuff), I am planning to try and curb my misjudgment by getting openSUSE on it pretty soon.

Will post ensuing tribulations!

Not totally sure of what ‘waste’ swernda is referring to: any piece of hardware rescued from running Windows its whole life seems like a good deed to me…

Okay I “wasted” the money, because the SP3 fits my working process (even only with Windows).
Anyway I got it now running with a dualboot Win8.1 and Opensuse. Whats giving me trouble is:

  • Touchscreen not working yet
  • WLAN unreliable
    and most annoying for me:
  • Digikam crashes when I open certain folders, no clue yet why.


Hi Chris -that’s encouraging news!
Three questions:

  1. Is the type cover working OK for you?
  2. Are you running 13.1 or something fresher?
  3. Is the battery life OK running OpenSuse?

So far I’ve only had the 13.1 LiveUSB running, which I found would not pick up the type cover once in KDE (but had registered it at grub2).

I’ve spend most of my energy trying to make Windows workable for me - it’s been a while!
A note for anyone running across this re. partitioning : I tried to shrink the single C: partition after about a weeks use, and found this impossible to shrink properly/enough using windows or linux tools due to unmoveable files that turned out to be bitlocker keys, even though bitlocker was turned off (weirdly the YAST partitioning tool reported it as linux native).
I ended up doing a system restore after which I was able to repartition to my desired sizes OK. So if you’re thinking about it (and this probably applies to other ultrabooks/win8.1 generally), I suggest to partition shrink very early after purchase if you’re planning to not completely kill off Windows.


  1. I don’t own a type cover yet. Is not yet available in my country… The SP3 is an imported US Version :wink:
  2. running 13.1
  3. as far as I can tell it is OK. Used it yesterday with heavy CPU load and 3 hours took it from 100% to 45%.

The same you experiencing with the type cover I see with the touchscreen, it works with grub2 but not with KDE, but with Ubunut it was working so I’m pretty optimistic there.

About the partitioning, I exactly had the same problems. Tried to shrink the partition after some time working with it. Was not possible under Windows. The shrinking out of Kubuntu Live Version, changed something in Windows so it would not boot anymore and I had to restore Windows and shrink the partition as soon as possible.

BR Chris.

I can verify that the touchscreen, pen, and touchpad on the type cover are working on the latest factory snapshots. I have just built up a kernel and currently installing it to see if I can get the keyboard in the type cover working. I’ll keep you posted.

I have read article about Surface pro 3 but have not played this game.

C’mon keep us posted! Does it really work now? I want to buy it so bad if it actually works with opensuse

No, sorry to disappoint, but a couple of days ago I tried the latest factory KDE live out.
Per the previous post, the touchpad works, but while the keyboard on the type cover works at grub2 menu, it does nothing once in KDE.
Also note that the touchscreen works with pointer events but no multi touch, but is ok provided you don’t plug an external screen in. If you do, the digitiser scaling gets messed up.