Surf Anonymously: Tor, Privoxy, Firefox Problem

I have problem running Privoxy. I installed it using Yast. In Firefox, I set the manual proxy configuration of http to 127.0.0.1 8118 and the SOCKS host to 127.0.0.1 9050.

I copied all the files from /etc/privoxy to my home folder /home/xuser.

I start privoxy by going to terminal and typing:

xuser@linux-w7mn:~> /usr/sbin/privoxy
Jun 20 21:37:27.786 Privoxy(7fc4c89216f0) Info: Privoxy version 3.0.10
Jun 20 21:37:27.786 Privoxy(7fc4c89216f0) Info: Program name: /usr/sbin/privoxy

When I try to connect, I get this message:

Proxy Server Refused Connection

Firefox is configured to use a proxy server that is refusing connections.

The browser is configured to use a proxy server, but the proxy refused a connection.

* Is the browser's proxy configuration correct? Check the settings and try again.
* Does the proxy service allow connections from this network?
* Still having trouble? Consult your network administrator or Internet provider for assistance.

I checked the man page. I checked their Privoxy - Home Page. I found nothing specific to Suse 11.1. I found nothing on Google for Suse 11.1 either.

Any ideas how I can get this to work?

sounds like you have installed the things you need, check in yast2>System>System Services and make sure privoxyd and tor are enabled. Hopefully that will solve your problem. If not you will have to review the privoxy config file.

Note: version of tor prior to 0.2.0.34 need to be updated for security reasons. Torbutton extension from Mozilla facilitates use of tor and automatically makes adjustments to java/javascript rules that can leave you open to revealing your IP (recommended). Consider installing Tork (KDE3) even if you are using KDE4, it can give you control of your tor exit and entry points. Both current tor and Tork rpms are in the Build Service.

suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 04:06 to write:

>
> I have problem running Privoxy. I installed it using Yast. In Firefox,
> I set the manual proxy configuration of http to 127.0.0.1 8118 and the
> SOCKS host to 127.0.0.1 9050.
>
> I copied all the files from /etc/privoxy to my home folder
> /home/xuser.

Now I know nothing about privoxy but why did you have to copy them to your
/home? and if so have they got the right perms to perform correctly?

Just a random thought.


Mark

Nullus in verba
Nil illegitimi carborundum

Privoxy tor squid - openSUSE

My old howto that someone kindly transposed is here. It also looks like someone has updated for it 11.0.

Sorry I can’t assist more but the benefits for me, where out weighed by the loss in speed.

I checked yast/stystem/system services. Neither were enabled. I was only able to at first enable Tor. Privoxy was attempting to start, but exited with an error. So, I went to advanced and set Privoxy to run at Run Levels 3 and 5. I restarted after saving these settings. I opened System Services and Privoxy and Tor were both enabled, but with Asterisks near their names?

I launched Firefox, double checked my proxy settings (http and socks set as mentioned above) and set Firefox to use proxy. I hit the Tor button to enable it.

When I try to load a web page, I get Blank message in Firefox with the option to create an exception, I copied the link location:

link labeled:

Or you can add an exception…

link:

javascript:showSecuritySection();

The button reads: Try Again?

Any link I try brings this message.

An older forum here suggested to do it. I believe I Privoxy wouldn’t launch from terminal until I copied those files.

The Privoxy Installtion how-to reads:

Firstly we setup Privoxy. Using Yast -> Software -> Software Management Search for Privoxy and install. (You need a Yast installation source OSS repo)

Done that fine.

Check if the privoxy is executing:

* Restart your computer and log in as the root user
* Open a terminal window and execute: ps -ef | grep privoxy
* You should get a listing with two lines:
      o The privoxy process
      o The "grep privoxy" process 
* If you only get "grep privoxy", then the proxy is not started! 

Did this, Privoxy is not running.

Now, I go to the last part of the Privoxy how-to.

In my Opensuse 11.0 installation, I had to add the privoxy to the “init” startup. Script “/etc/init.d/privoxy” was installed, but no links were set in the “rc?.d” directories to the script.

How do I know if Privoxy needs to be added to “init” startup? If it does, how do I do that?

How do I know if script “/etc/init.d/privoxy” is installed? How do I do this if it is not?

How do I check to see if links are set to rc.d directories? If they are not set, how do I do that?

If I can get all my questions answered, get Tor and Privoxy up and running with Firefox, I will write out a non-assuming how-to from start to finish.

If you found a rpm it is highly likely you’ll be able to enable via the runlevel editor. Otherwise as suggested you need an init startup script.

My original had a very hackish solution, but I doubt you need that option. But if you do then you should find some doc/skel in init.d sorry that is as much as I can help now. That originally was from around about 10.1 iirc.

wiki http://en.opensuse.org/SDB:How_to_Create_Your_Own_Init_Script

FeatherMonkey

Tor and Privoxy seemd to be enabled by System Services, although they do have asterisks next to the word Yes* (for being enabled).

I’m not sure, but does not System Services write the init scripts for me?

If so, there must be a problem somewhere else, not init scripts. Firefox is not allowing me to bring up web pages.

i did not have to copy any privoxy files to my home directory to make it work. the files it needs to create there will be written when it runs.

the asterisk in yast2 indicates that the service will be started when it is called instead of being loaded all the time and can be changed depending on your needs.

yast2 will make the appropriate init changes depending on your settings, no manual edit is necessary.

your Firefox error message is not really clear to me. it sounds like privoxy is not running…or it is running and passing the connection to tor but is not recieving the SSL certificate verification which prevents Firefox from rendering the webpage(by default Firefox will not render a SSL page unless it verifies the cert, it displays error and presents the opportunity to make an exception).

just to check, review the privoxy config file /var/lib/privoxy/etc/config for the two pertinent uncommented lines that need to exist:

listen-address 127.0.0.1:8118
forward-socks4a / 127.0.0.1:9050 .

the other thing that comes to mind is that your openssl libraries may not be up to date. Type openssl in the Search bar in Yast2 and see if there are updates available.

Ok, I removed those files. Then, I went to Terminal and typed /etc/sbin/privoxy to try to launch Privoxy. It says no such file. Before, it appeared to launch Privoxy. Without those files there, what command can I use?

I verified this in the config file. Even the period at the end is there.

listen-address 127.0.0.1:8118
forward-socks4a / 127.0.0.1:9050 .

I assume you mean Online Updates in Yast? There was one file that showed up under Security Updates. I did the update. I’m restarting now.

Privoxy doesn’t seem to run:

xuser@linux-w7mn:/etc/privoxy> privoxy

Program 'privoxy' is present in package 'privoxy', which is installed on your system.

Absolute path to 'privoxy' is '/usr/sbin/privoxy', so it might be intended to be run only by user with superuser privileges (eg. root).

bash: privoxy: command not found

I copied the files to my home folder:

xuser@linux-w7mn:/etc/privoxy> sudo cp *.* /home/xuser

I tried to start Privoxy:

xuser@linux-w7mn:~> /usr/sbin/privoxy
Jun 21 11:54:18.181 Privoxy(7f87015866f0) Info: Privoxy version 3.0.10
Jun 21 11:54:18.182 Privoxy(7f87015866f0) Info: Program name: /usr/sbin/privoxy
Jun 21 11:54:18.182 Privoxy(7f87015866f0) Fatal error: can't check configuration file '/home/xuser/config':  No such file or directory

For some reason, cp did not copy the config file, so I copied it directly by name:


xuser@linux-w7mn:/etc/privoxy> cp config /home/xuser

Now, now I try to launch Privoxy again:

xuser@linux-w7mn:~> /usr/sbin/privoxy
Jun 21 12:04:53.377 Privoxy(7f8c9868c6f0) Info: Privoxy version 3.0.10
Jun 21 12:04:53.377 Privoxy(7f8c9868c6f0) Info: Program name: /usr/sbin/privoxy

I test to see if it’s working using ps:

xuser@linux-w7mn:~> sudo ps -ef|grep privoxy
root's password:
xuser    10784  5192  0 12:09 pts/1    00:00:00 grep privoxy

Again, it is not working.

Any ideas how to get it working?

suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 15:16 to write:

>
> baskitcaise;2002375 Wrote:
>> Now I know nothing about privoxy but why did you have to copy them to
>> your
>> /home? and if so have they got the right perms to perform correctly?
>>
>> Just a random thought.
>
> An older forum here suggested to do it. I believe I Privoxy wouldn’t
> launch from terminal until I copied those files.
>
>

Another off the wall thought here,

Is pivoxy supposed to be executed as user?

Looking at one of your other posts it suggests that it is root only.

Try opening a root session in a terminal and launching from there

Note: not a sudo session but a full blown root by opening a console and
using

su
(enter root password)

and then try launching.

sudo only works for the first command and then you drop back to user privs.

su

give full control until you either type

exit or close the term session.

HTH


Mark

Nullus in verba
Nil illegitimi carborundum

The official Privoxy site say not to run it as root.

suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 19:06 to write:

>
> baskitcaise;2002508 Wrote:
>>
>> Is pivoxy supposed to be executed as user?
>>
>
> The official Privoxy site say not to run it as root.
>
>

Ah OK, disregard me then

:wink:


Mark

Nullus in verba
Nil illegitimi carborundum

baskitcaise is correct.

You’re reading stuff you don’t need to concern your self with you have to start the service via runlevels or manually with su /etc/init.d/privoxy start.

if you got an rpm it is highly likely that it is configured correctly. The statement is the same as not running a web server as root(Try starting httpd as user without su), you have a dedicated user iirc it will be privoxy.

FeatherMonkey adjusted his/her AFDB on Sunday 21 Jun 2009 21:16 to write:

>
> baskitcaise is correct.
>
> You’re reading stuff you don’t need to concern your self with you have
> to start the service via runlevels or manually with su
> /etc/init.d/privoxy start.
>
> if you got an rpm it is highly likely that it is configured correctly.
> The statement is the same as not running a web server as root(Try
> starting httpd as user without su), you have a dedicated user iirc it
> will be privoxy.
>
>

Ah, I thought these old grey cells where not deceiving me.

It was the fact that he copied the configs from /etc that puzzled me because
unless he changed perms then it was almost certain they would not run as
user.

Also in one of the posts the error message said to run with su or root.

I may not always be right and an old f^rt with it but sometimes the law of
averages do step into my favour ( not very often though )

:slight_smile:


Mark
Cavet emptor
Nullus in verba
Nil illegitimi carborundum

I tried to just run it without any of the fancy terminal stuff. I downloaded them using Yast. I set the Firefox settings. Didn’t work.

Sure could use a comment from someone that has it working, or is guru enough to help me finish getting this from install to up and running.

j_xavier told you what to do here openSUSE Forums - View Single Post - Surf Anonymously: Tor, Privoxy, Firefox Problem

It is no more complicated than that. Install privoxy check that works install tor check that works. Just have 1 line to edit in config, and have to tell your browser to use 127.0.0.1 8118.

Now you can either start them once of with rctor start and rcprivoxy start. Then just go to system runlevels to be fair much about the tut is outdated and so easy now, compared to when I did that howto.

If you’re asking how do I enable it to start automatically via runlevels then ask… you need expert and choose your default runlevel normally 5.

You don’t need to be an expert, just need to work through it methodically.(I’ve just done this in about 4 mins including downloading.)

Its still painfully slow as I remember so my suggestion is to add squid to the equation at least for non-dynamic pages it should help.

Also be aware you might as well give up all your plugins many of them maybe leaking…

recap: the rpms for privoxy (and tor) that i have used from repos or Build Service will start privoxy as root during startup provided that they are enabled in yast2>System>System Services. There is no reason to try to start them as user.

as i mentioned before, the error page that Firefox gives you when you try to use it is not clear to me. since you only gave the link info, the entire error message is unknown, but it seemed to be the standard message that Firefox gives when an SSL connection cannot be verified… this happens often using tor because of latency… the cert server validation lags too far behind the delivery of the webpage and it times out. In addition, you did not mention that your Firefox connection settings included the No Proxy [localhost,127.0.0.1] entry.

Locate and install the Torbutton extension on Mozilla’s website. This will assure that your connection settings will be correct to use Tor with Firefox and provide the added benefit of disabling java/javascript (if you enable javascript you might as well not use tor, your real ip number can be retrieved with a simple script), cookies, etc.

At this point i believe your tor/privoxy install is working correctly and the problem lies elsewhere.