Super weird damaged system

Since a few days, my Tumbleweed has been broken in a way that I can’t understand… It boots up to Plasma, and all applications set up to run at startup are running well at the beginning. Then… it’s broken. Applications all refuse to start (though I can manage to make them start if I wait, try other stuff and come back to it?!). Running them in Konsole made them throw errors as if X11 was not running or broken (see below), though it’s up and running (since I’m, well, using Plasma to run them). Finally, and related to that (?), everything works fine under Wayland…

I tried to reinstall all installed packages containing “xcb”, “xorg”, “x11”, “Qt5”, “KF5” and “plasma”, to fix any possible corrupted files, but to no avail…

If someone can help me make sense of this nonsense? Any help and pointers would be much appreciated!

Some errors. Trying to run dolphin:

Maximum number of clients reachedMaximum number of clients reachedqt.qpa.screen: QXcbConnection: Could not connect to display :0.0
Could not connect to any X display.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Trying to run Firefox:

Maximum number of clients reachedMaximum number of clients reachedUnable to init server: Could not connect: Connexion refusée
Error: cannot open display: :0.0

Trying to run Chromium:

Maximum number of clients reachedMaximum number of clients reached
(chromium:9100): Gtk-WARNING **: 21:05:39.209: cannot open display: :0.0

I have not run into that “maximum number of clients” message. But maybe check what processes are running. Perhaps you have a wild process that is forking and filling up the process table.

ps -fu $USER

should list your processes.

Or maybe

ps -fu $USER | wc -l

which should give a count of how many processes. I’m currently seeing 123 processes with Leap 15.0

Your output shows you seem to run Plasma with Wayland instead of the Xorg. That combo doesn’t work well ( yet ), specially not with NVIDIA graphics hardware.
Another thing that comes to mind ( like always ) is how TW was upgraded. If not through ‘zypper dup’ then run that first, it’s the only supported way for TW.

@nrickert: I had 207 processes running, among which a large number of touchegg (which I use for gestures on my touchscreen) processes. Killing it and unchecking autostart seems to fix my issue, but only for KDE apps. Firefox for example still refuses to run with the following error:

ExceptionHandler::GenerateDump cloned child 6373
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
2018-10-18 07:49:37: ERROR: MinidumpThread has a memory region problem, 0x7fffa59f8fe0+0x0, RVA 0x0x5a8
2018-10-18 07:49:37: ERROR: No memory region for /home/flyos/.mozilla/firefox/e3zxcz18.default/minidumps/4ef7089f-e68a-2699-6c27-684fc17ec254.dmp:0/26 id 0x18a2
2018-10-18 07:49:37: ERROR: Can't get caller frame without memory or stac

Am I having a RAM failure?

@Knurpht: I am positive this is happening on a X11 session (“Plasma” in SDDM) and not on a Wayland session (“Plasma (Wayland)”) session which I’m writing this from and works OK.

EDIT: Also, I always update TW with zypper dup --no-allow-vendor-change

Could be. When I see any kind of memory errors I try four things: 1-different DE (e.g. IceWM); 2-different kernel; 3-different distro; 4-memtest86 (not memtest86+). If you can run Firefox in an IceWM session, likely it’s not a hardware problem. TW did just get a new kernel on the mirrors in recent hours.

EDIT: Also, I always update TW with zypper dup --no-allow-vendor-change
No-allow-vendor-change has been the TW default since I’m sure over a year ago by now.

What’s the output of:


Maybe you are running low on memory.

Please also show output of

zypper lr -d

Found this:
The user reports that reinstalling libxcb solved the issue.

Sorry for the late reply…

@mrmazda: Firefox doesn’t work on IceWM, but does work fine on Plasma Wayland (actually, everything work fine on Plasma Wayland, besides Wayland-specific bugs). Other stuff will require more time to test unfortunately…

@nrickert: Here’s the result of “free -mh”, I don’t think I ever lacked memory on this laptop (nor should I):

              total        used        free      shared  buff/cache   available
Mem:          7,7Gi       1,6Gi       2,0Gi       151Mi       4,1Gi       5,7Gi
Swap:         4,0Gi          0B       4,0Gi

@Knurpht: Here’s the output of zypper lr. Note that although KDE:Extra has a low priority, very few things come from here. “home:illuusio” is to get libinput-gestures. Sorry for the French…

Priorités de dépôt en vigueur : (Consultez 'zypper lr -P' pour plus de détails)
      50 (priorité relevée)    :  1 dépôt 
      89 (priorité relevée)    :  1 dépôt 
      90 (priorité relevée)    :  1 dépôt 
      91 (priorité relevée)    :  1 dépôt 
      95 (priorité relevée)    :  1 dépôt 
      99 (priorité par défaut) : 10 dépôts

#  | Alias                               | Nom                                            | Activé | Vérification GPG | Rafraichir | Priorité | Type   | URI                                                                                                               | Service
 1 | CRAN                                | CRAN                                           | Oui    | (r ) Oui         | Oui        |   90     | rpm-md |                      |        
 2 | KDE:Extra                           | KDE:Extra                                      | Oui    | (r ) Oui         | Non        |   95     | rpm-md |                                        |        
 3 |       | Dépôt principal (NON-OSS)                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                                             |        
 4 |           | Dépôt principal (OSS)                          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                                                 |        
 5 |    | Dépôt principal de mise à jour                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                                                   |        
 6 | google-talkplugin                   | google-talkplugin                              | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                                           |        
 7 | home_leinir_peruse                  | Peruse Comic Book Reader (openSUSE_Tumbleweed) | Oui    | (r ) Oui         | Non        |   99     | rpm-md |                               |        
 8 | | home:flyos:dpluzz                              | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                |        
 9 | | home:flyos:R-packages                          | Oui    | (r ) Oui         | Oui        |   89     | rpm-md | |        
10 | | home:flyos:Zotero                              | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                |        
11 | | Emulators                                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                          |        
12 | | home:illuusio                                  | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                                     |        
13 | | science                                        | Oui    | (r ) Oui         | Oui        |   91     | rpm-md |                                            |        
14 | packman                             | packman                                        | Oui    | (r ) Oui         | Oui        |   50     | rpm-md |                                               |        
15 | repo-debug                          | openSUSE-Tumbleweed-Debug                      | Non    | ----             | ----       |   99     | NONE   |                                                           |        
16 | repo-source                         | openSUSE-Tumbleweed-Source                     | Non    | ----             | ----       |   99     | NONE   |                                                          |        
17 | skype-stable                        | skype (stable)                                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |    

It’s been a long time since I’ve seen this error,

IIRC then, and possibly now you can either try to track down what app isn’t closing down properly or simply increasing (ie doubling to start) MAXCLIENTS in your xorg.conf.

With a quick Google search, I see one result where an alternate file “/usr/include/xorg/misc.h” was suggested for this setting.


I think we can say that Touchegg was the app responsible for the error since deactivating it solved this particular error. It seems the new Firefox error is a different (related or coincidence?).

So, only GTK2/3 applications are crashing now… I get the above error for Firefox (the second one I posted), but also Chromium and Inkscape crash with:

SIGSEGV (erreur de fontrière d'adresse)

(loose translation, “error on address limit”)

I tried to force reinstall all gtk packages with:

zypper install --force --recommends $(rpm -qa *gtk*)

As for above, it didn’t fix anything… All Qt applications seem to work now. This is so weird…

What if you leave out the --recommends part ?
Plus, this may very well need a logout/login, did you do that?

It just installs less packages. Actually, --recommends mostly pulled a bunch of “-lang” packages, but I did it in any case something was missing from my system…

Yes, of course ! :wink:

Actually, I found that using another user, I don’t have those errors. I ended up wiping out my whole home, but to no avail (?!). I’m in a process of creating a whole new user for myself and deleting the old one… I hope I’ll be able to reuse the same login.

I can create a new user, but deleting my old user and re-creating a new one with the same login still makes it buggy… I have no clue what to do of this. At that point I’m wondering whether I shouldn’t reinstall such a corrupted system…