Supend to RAM fails on Toshiba Satellite A200-23W

Supend to RAM does’nt work in neither case described on suse home page.
It goes to sleep normaly, but on resume the computer hangs … nothing shows up and keyboard is non-functional, and after 10 seconds fan gets crazy on maximum speed.

I tried with in Suse 10.3 and 11.0(Live CD) in both cases i get the same error. However suspend to RAM works in Fedora 9 without any problem.

Here is some info:
I run openSuse 10.3 with kernel

s2ram -i:

This machine can be identified by:
    sys_vendor   = "TOSHIBA"
    sys_product  = "Satellite A200"
    sys_version  = "PSAE6E-0DP036G3"
    bios_version = "V1.70"
See for details.

If you report a problem, please include the complete output above.


processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
stepping        : 11
cpu MHz         : 800.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4393.43
clflush size    : 64

Can anyone help me?