Sun Virtual Machine

I have added myself to the vboxusers in yast. I stll cannot access USB.

Suse 11.1 host, XP pro guest.

This is not the OSE version.

USB in VirtualBox on openSuse seems to be a problem.

First, the USB device must be plugged in before starting your VirtualBox machine. Second, the device must be enabled in the settings section of your VirtualBox machine, again before starting the virtual OS.

You will also probably have to modify /etc/fstab. The guide for openSUSE 10.3 and 11.0 is at:

Virtualbox USB Support - openSUSE.

I, and others, had to put the line

mount -a

in the file /etc/init.d/boot.local to make USB work. After the edits have been made, you’ll need to reboot to have the changes take effect.

I use 11.0, and have only mounted different USB flash drives, not hard drives or mp3 players, in VirtualBox. I also am not sure if the edits to fstab would be different for 11.1, but the ones given at the above link won’t harm your system.

How do I get the “gid” number?

Open a terminal

grep vboxuser /etc/group

So I got the gid number. But the directions Virtualbox USB Support - openSUSE are not clear to me.

Can someone hold my hand through this?

This section of the HowTo:

(2) As root, edit /etc/fstab and set the gid and mode for usbfs as follows: /sys/bus/usb/drivers /proc/bus/usb usbfs devmode=664,devgid=113 0 0

The 113 is the number you just found, whatever the number is for you:

Depending on if you use kde or gnome, edit fstab this way:

kdesu kwrite /etc/fstab
gnomesu gedit /etc/fstab

Note the user comments on the Page too.

I’m taking the risk of createing more confusion on this topic. Fact is I’m running 11.1-32bit and since VirtualBox 2.1.4, the latest version from SUN, there’s no need to edit fstab or issue any mount command. Can anyone confirm this? Does it work this way for 64-bit too? The good guys at SUN-VirtualBox are doing a fine job ass I see it!

Hi folks,

/me running OSS 11.0 x86-64 with
VirtualBox 2.1.4 (latest) Took some
headbanging with USB but finally
works 99.9% w/o hickups.
As per instructions you have to add user
to vboxusers (after finding out GID as explained)
Crucial part to working USB was to add in /etc/fstab:

/sys/bus/usb/drivers /proc/bus/usb usbfs devgid=XXX devmode=664 0 0

where XXX should be the vboxusers GID

Not sure about 11.1, but try same and revert

Best Regards

Sorry! missed a comma. The correct entry
(copied from nano)
/sys/bus/usb/drivers /proc/bus/usb usbfs devgid=XXXX,devmode=664 0 0


I have an different situation. First off, my usb works.

I’m using OpenSUSE 11.1 with KDE 4.2.1 “108”

Anyways, I needed usb support because my Sonicstage for my NetMD wouldn’t work with wine and Vista wouldn’t install it correctly or even run it. So I needed support from XP in my virtual machine.

I tried all of the above suggestions, since usb didn’t work in the first place (using the latest Virtualbox), and none worked.

The only way I got it working was to have

none  /proc/bus/usb  usbfs devgid=1000,devmode=XXX 0 0

in my fstab.


/sys/bus/usb/drivers /proc/bus/usb usbfs devgid=XXX devmode=664 0 0

I’m not sure why or if something’s wrong with that, but it’s the only way it’s works for me, so if nothing else works you can try that also.](

Hope this helps!

This obviosly needs to be ironed out, my system is as follows:

Hardware is an ASUS M2A-VM-HDMI an integrated amd motherboard.
System is OpenSUSE 11.1 32 bit.
VirtualBox is 2.1.4 non-OSE from SUN’s virtualbox download.

My fstab is this:

/dev/disk/by-id/ata-ST3320620AS_9QF65ES7-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3320620AS_9QF65ES7-part2 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST3320620AS_9QF65ES7-part3 /home                ext3       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
#none                 /proc/bus/usb        usbfs      devgid=1000,devmode=0666 0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Note the outcommented entry for usb from pre 2.1.4

In VirtualBox I run XP home.

I don’t issue any mount command and all my USB devices work great in my XP guest under VirtualBox. Of course I still have to set them up in VirtualBox settings, but thats not the issue here. So whats going on?

Since VirtualBox (I’m using 2.1.4) is closed source, nobody
can be 100% certain how exactly it cooperates with OSS.
But if you notice the comments on the different varieties in the fstab entries it is obvious that we are not using the same OSS version. The one I described works for 11.0 x86-64 with VB 2.1.4.
The others did not. Using the others, I just got the USB
devices in VB greyed out (unusable). I am sure other users
describing different entries in fstab are also right, since that
works for them. The good thing about having it all in one thread
is that one may choose according to the OSS version he uses.

The only thing that did not work on USB in VB was a USB softmodem (SmartLink) that I installed in WinXP Pro (guest). Installation
is flawless, but the modem cannot dial correctly assigned numbers
and one ends up dialing wrong numbers. Has probably something to do with the “simulated” access to the USB port.

Coincidentally, my attempt to enable a fairly ordinary usb memory stick in a VirtualBox (2.1.4) VM running 11.1/Gnome continues to fail. I have tried the wiki howtos and advice in this thread. This is the first time I tried to enable a usb mount in a VM, but have run a VM many times before over several previous releases.

Host system is OpenSUSE 11.1 32bit, KDE 3.5.10 (installed from DVD .iso), running proprietary Sun VirtualBox 2.1.4

Symptoms: The usb device is recognized by the Host settings, its details are gathered, and it can be selected for adding the filter. However any attempt to display its details at the VM window (top or bottom, also right-clicking) gives “unavailable” with its device name greyed.

As its my first time at enabling virtualbox usb support, I may have overlooked something simple. Any new suggestions or perhaps a different combination of settings, would be most welcome:).

After changing settings in fstab you did reboot, right?


Sensible question, to which the answer is YES - I did reboot. Trying out the various fstab entries involved much SUing and rebooting as you would know. It becomes frustrating and therefore more likely to miss one.

In desperation and with litle logic, I even tried adding various fstab entries and the “mount -a” to the linux guest, but every combination ended in a greyed device name.

I should have added I’m running gnome but that wouldn’t make any difference. Or?

:frowning: I really wish I could offer more help than this. In order
to find this solution took infinite Googling and extensive
trial and error. This is exactly why closed source sucks. >:(
The USB support part of VB is exactly why it is closed source.
If nothing else works try the VB forum

Best of luck

johnroberts, I appreciated your contribution. I had a feeling earlier that I may have yet another permissions problem with VirtualBox 2.1.4, so I started it from Konsole as root and after quickly setting up a new VM for openSUSE/Gnome, and commented-out all fstab additions etc. mentioned in earlier posts, usb support worked flawlessly. There is a somewhat inconclusive post in the VB Forum - see here

However that’s no good and it must be run as normal user. I will return to the problem and try to work out which additional executable needs its permissions fixing next. No more time, so will have to leave it for now:(.

I can add the following information:
I run VirtualBox as an ordinary user, I’ve added the following groups to my user account:
vboxusers,cdrom, floppy,video,wheel and www.
Additionally when I do a new install I routienly add the following items from software patterns:
kernel development tools and console tools.
Somewhere there must be an explanation why my system works without problems.

I am assuming the only significant group is vboxusers and I have it for my normal user, along with: users; video; cdrom; and disk.

This is a problem involving Sun VirtualBox 2.1.4 specifically with openSUSE 11.1 (not 11.0) and I feel I am now close to a solution. It may be something to do with the setup of the VM and settings chosen then. However, I don’t know if my problem is exactly that of the OP.

I will post any solution back here after further tests;).