sudo zypper up not working

Trying to patch system and I get :-
localadmin@linux-4ekq:~> sudo zypper up
Retrieving repository ‘openSUSE-13.1-Non-Oss’ metadata ---------------------------------------------------------------------------------------------------]
Download (curl) error for ‘’:
Error code: Connection failed
Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a): ^Clocaladmin@linux-4ekq:~> ^C

To confirm curl is working, this is not network issue but it appears file is not present on

localadmin@linux-4ekq:~> curl -v

  • Adding handle: conn: 0x173fdc0
  • Adding handle: send: 0
  • Adding handle: recv: 0
  • Curl_addHandleToPipeline: length: 1
    • Conn 0 (0x173fdc0) send_pipe: 1, recv_pipe: 0
  • About to connect() to proxy port 80 (#0)
  • Trying…
  • Connected to ( port 80 (#0)
    > GET HTTP/1.1
    > User-Agent: curl/7.32.0
    > Host:
    > Accept: /
    > Proxy-Connection: Keep-Alive
    < HTTP/1.1 404 Not Found
    < Date: Tue, 30 Sep 2014 14:57:40 GMT
  • Server Apache/2.2.12 (Linux/SUSE) is not blacklisted
    < Server: Apache/2.2.12 (Linux/SUSE)
    < X-Prefix:
    < X-AS: 2856
    < Vary: accept-language,accept-charset
    < Accept-Ranges: bytes
    < Transfer-Encoding: chunked
    < Content-Type: text/html; charset=iso-8859-1
    < Content-Language: en
    < Proxy-Connection: Keep-Alive
    <?xml version=“1.0” encoding=“ISO-8859-1”?>
    <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN””>
    <html xmlns=“” lang=“en” xml:lang=“en”>
    <title>Object not found!</title>
    <link rev=“made” href="" />
    <style type=“text/css”><!–/–><![CDATA[/><!–/
    body { color: #000000; background-color: #FFFFFF; }
    a:link { color: #0000CC; }
    p, address {margin-left: 3em;}
    span {font-size: smaller;}

<h1>Object not found!</h1>

The requested URL was not found on this server.

If you entered the URL manually please check your
spelling and try again.

If you think this is a server error, please contact
the <a href="">webmaster</a>.


<h2>Error 404</h2>
<a href="/"></a><br />

<span>Tue Sep 30 16:57:40 2014<br />
Apache/2.2.12 (Linux/SUSE)</span>

On 2014-09-30 17:06, craigmc35 wrote:
> Trying to patch system and I get :-

A comment: When pasting here computer commands and such, please use a
CODE BLOCK, so that the forum software doesn’t do silly things like
converting URLS to tiny urls or otherwise hide or alter the commands you
entered. You get them by clicking on the ‘#’ button in the forum editor.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

That’s probably a network error.

Normally this works, or there would be a huge number of complaints. I think mirror-brain usually redirects to mirror before you get very far. Apparently a network failure interfered with that.

To the OP,
I guess it’s obvious that you’re getting two separate errors.

Maybe you should consider how far apart you did your tests, if something is changing or different between your tests.


Hello, I am new here the command zypper update is not says
Download (curl) error for “
Error code: connection time out
Error Message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable:(

I used to get those messages. But then my ISP started providing IPv6, and I no longer get those.

If you don’t actually have IPv6, then treat this as a temporary network error. (If you do have IPv6, it is probably still a temporary network error).

Most of the time, connections will work with IPv4. But, occasionally, when a connection fails the software (“curl”) falls back to an IPv6 address. And if you do not have any IPv6 connectivity, you will get “network unreachable”.

What I always did, was wait a while then try again. That usually worked.

I would opt to do either of two things; disable ipv6 (which you can do from YAST / Network Devices / Network Settings / Global Settings, disable IPv6 and reboot) or could try forcing single request in name resolution:

Make a copy of /etc/resolv.conf and edit it with a text editor as root and add;

options single-request-reopen

Had to use this trick on a customer with a broken resolver.


My trick to solve this issue is to put the the ip and name in


the output of the


Not a good solution i know but it works on this side :slight_smile:

I do that, but for a completely different reason.

If I don’t add it to “/etc/hosts”, then my system use IPv6 to connect. And mirror-brain is hopelessly broken for IPv6 addresses. It gives out terrible mirrors (distant and slow). By adding the “/etc/hosts” entry, my initial connect uses IPv4, and mirror-brain works far better with that.

On 2015-01-25 15:46, Anik plexus wrote:
> Hello, I am new here the command zypper update is not says
> Download (curl) error for
> “
> Error code: connection time out
> Error Message: Failed to connect to 2001:67c:2178:8::13: Network is
> unreachable:(

Most times this error is not related to not being able to connect on
IPv6 at all, despite appearances. There is a prior and more important
issue with connection, but zypper tries all the addresses it got. The
last tried are normally the IPv6 ones: it only reports the error with
the last attempt. The important issue is not seen in the error message,
it is lost from sight.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)