suddenly rejects password

I have been running Leap 42.1 fine for a week. Today I logged out, and my password was not accepted to log back in. Several tries. It wasn’t caps-lock on or something like that. I rebooted. Same. Over and over. Tried Failsafe. Tried every combination of choices offered. Ran the Rescue from the DVD, tried this and that, no sign of any progress. By some concatenation of accidents that I could never reproduce, and to my immense amazement, suddenly the login screen accepted my password. Great. I set about documenting this horror. I wanted to do an online upgrade. But YaST, after taking my password, did nothing. So I closed down again for a restart. And… I cannot log in. So if I’m an optimist, an hour of diddling around might get me back in. In something like 6 years with various versions of openSUSE I’ve never had such an experience.

I do notice that if I enter a wrong password , I get “Login failed.” But with my correct password, there is no such message, the screen goes dark, it looks as if it will be a normal login, but then it just pops back out to the login band. So perhaps I am getting logged in, then immediately logged back out again.

Problem solved, thanks to Carlos… I had altered my /etc/passwd substituting /bin/tcsh for /bin/bash. I won’t go into why (apart from being a clutz). John.