Suddenly intermittent wireless with Network Manager

My laptop has worked fine with my wireless network at home for the last year, including for a brief time after we installed a new router.
However, this time after I returned from college, I am unable to connect to my home wireless network unless I am in the same room as the router. The Network Manager plasmoid on my toolbar flickers rapidly between finding available wireless networks, including my home network, and not finding any wireless networks. When I run iwlist scan it detects available wireless networks whether or not Network Manager is flickering. The part of the output from iwlist scan about my home network [FONT=arial]from one time when Network Manager was flickering[/FONT] follows:

wlan0 Scan completed :
Cell 02 - Address: 00:26:F2:9C:BD:84
Encryption key: on
Bit Rates:150 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 11 6 9 12 18 24 36 48 54
Quality:74 Signal level:0 Noise level:149
IE: Unknown: DD270050F204104A000110104400010210470010000000000000100000000026F29CBD84103C000103
Extra: Last beacon: 96ms ago

The wireless works fine in every room with the same network from the Windows side of the same machine (it is a dual-boot system) and with every other (Windows) laptop in the house. The wireless device is a Realtek RTL8191SE 802.11b/g/n WiFi Adapter, with a rtl8192se driver, which has not changed since before this. Does anyone know what the actual problem could be? I did not find any people with similar problems, but this was a hard problem to search for.

Please tell us which OS version, the desktop environment your using, and version. This may be relevant.

I am using OpenSuSE 11.4 with KDE 4.6.00 (4.6.0) “release 6”. You did not ask for this, but I am using version 0.8.2-15.28.1 of Network Manager (from zypper if NetworkManager)

Sorry, I meant to include this in my initial post.

There is a bug report here:

It may be in your best interests to upgrade to a current release.

Thanks. I just followed your advice and smoothly upgraded to 12.2.