Success with HP dv9700z Laptop Athros AR5007 Wireless

I’m talking of an Athros AR5007 802.11 b/g wifi adapter seen by 11.0 as an AR242x 802.11abg. I didn’t want to use ndiswrapper as I need all mad-wifi features for other apps.

I tried most of the guides herein and various 11.0 mad-wifi rpm sets with no joy.

I removed them all in Yast; rebooted to make clean and went to Index of /repositories/home:/schmolle1980/openSUSE_11.0/src and fetched his x86-64 driver source >rebuilt the src rpm to match my running kernel {rpmbuild --rebuild /packagename} > installed > rebooted.

The device was detected with no blacklisting of other modules, etc,. I added my wireless extensions in Yast and Hooray, it’s my best wireless device yet:)

Schmolle1980, you have my many thanks, Well Done! It’s guys & gals like you that make the community a real pleasure. Thanks for all you do:)

Hello there :slight_smile:
Do you mind to write a how to for noobs like me who does not know anything about suse?
I have to set this laptop fully functional in three days before leaving city for 3 weeks (means i will gonna lose wired internet).
I have tried many how-to s but seem like i need more basic knowledge :smiley:

PS : Dont think i am lazy , i just don’t have time and will not have if i cannot get wireless going :slight_smile:

MY SYSTEM : Acer Aspire 5520 laptop 3gb DDR2ram AMD64AthlonX2 TK-57 processor NvidiaGeForce7000m “ATHEROS 5007EG WIRELESS”

opensuse 11.0 64 bit OS

Thank You :slight_smile:

Sure, If you need help in a hurry, please PM us and ask us to respond to your post.

Go to Index of /repositories/home:/schmolle1980/openSUSE_11.0
and look for the src (source) file tree =
Index of /repositories/home:/schmolle1980/openSUSE_11.0/src

download: madwifi-r3725+AR5007EG-2.2.src.rpm

copy/move it to: /usr/src/packages/SRPMS using filemanager-superuser-mode
Kmenu > System > File Manager > filemanager-superuser-mode

In a terminal as root; that’s:

cd /usr/src/packages/SRPMS
now do
rpmbuild --rebuild madwifi-r3725+AR5007EG-2.2.src.rpm
(wait until it compiles your rpms without error; look at the last few lines of code.
that will build the rpms and they will be found in /usr/src/packages/RPMS/x86_64.  The rpms will match your kernel and system).
cd /usr/src/packages/RPMS/x86_64
rpm -ihv madwifi-r3725+AR5007EG-2.2.x86_64.rpm (if this is the 1st go with madwifi; else use)
rpm -Uhv madwifi-r3725+AR5007EG-2.2.x86_64.rpm (for update/upgrade)
then install the kernel module
rpm -ihv madwifi-kmp-default-r3725+AR5007EG_2.6.25.11_0.1-2.2.x86_64.rpm
(Same as above; except here you need to check your running kernel with "uname -a"
mine come up "default" so that's the kernel module rpm I use).

OK, it’s installed, close out of everything & reboot

When you are back up, go to Yast > Network Devices > Network settings
It should have detected you card; click on it and edit it, meaning
fill in all the blanks & all the tabs in that section with your wireless extensions, WEP, etc
they must match throughout including the router.

BTW, there is an rpm Kwifimanager that will put an active wireless icon in the systray that is handy.

Hope this helps; if not, get back & PM me:)

Thanks for the help there it was able give me enough to get my wifi working on my dv6919 with the ath242x wifi

After the steps you had I could just finish it off with the standard install steps for madwifi

and what is with ad-hoc mode?

Also, after each kernel update I need again to patch madwifi

You would have to set ad-hoc, monitor, etc. mode in Yast or with iwconfig from the command line.

Yes, a kernel update will break the kernel module & it will have to be recompiled

So i downloaded it, copied it to the right directory, and ran the buildrpm command and got this

Installing madwifi-r3725+AR5007EG-2.2.src.rpm
warning: InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID 31812260
error: line 28: Unknown tag: %suse_kernel_module_package -n madwifi -p /usr/src/packages/SOURCES/preamble kdump um

Any thoughts?

(Also using Dv9700)

Install kernel-source & kernel-syms that match the running kernel “uname -a”
If they don’t match after the install, do an online update
also install gcc, make & C++

I’d clean up the old try
try again;)

Hi i recently bought a laptop - MSI EX600 and it looks lite it has the same card so i try what you wrote here but when i try to install kmp-default package it gives me an error.

error: Failed dependencies:
        ksym(default:ieee80211_dev_kfree_skb) = bae2c6ce is needed by madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.2.i586
        ksym(default:ieee80211_input) = be4b42cd is needed by madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.2.i586
        ksym(default:ieee80211_note) = 20ad9c80 is needed by madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.2.i586

Can you please give me any advice or tell me what i’m doing wrong?