Subprocess RPM Failed!!!!

OK I have had these in the past but not to the extent that I am at now…

I have tried to update one thing, I have tried to update several things and everytime in YaST I get >>downloading…wait…wait>>Subprocess failed RPM failed on every time.

I am running 10.3 on the laptop where the problem resides with KDE 3.5.10

I have done Zypper refresh several times as well as rpm --rebuilddb several times hoping that it would fix…it has not…The errors don’t point to missing repos or CPIO cuz you don’t get “bad magic” errors…

Anyone think of another command I can run or something to get the system back on track???

Thanks
Rich

Hi
Not sure if a cleanup may help?

Package
Manager Cleanup


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 3:06, 1 user, load average: 0.33, 0.28, 0.30
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Ran this a number of times, no joy

also tried this rm -f /var/lib/rpm/__db* to see if I had any problems in the rpm database with locked files…this did not solve the problem.

After doing the latter, I went to YaST to install an update on a piece of software and of course it errored out…but…I hit retry several times (I am guessing oh 5 times out of frustration) and it looked to have installed…I will need to go back and double check…

Anyone else with a command that I can use to help the RPM situation that I have??? I am totally dead as far as security updates and getting the latest fixes for KDE with the system in the state that it is.

Thanks for the help!
Rich

You are luckier than me, man.

I am using OpenSUSE10.2 and try to update last week with additional repositories. The disaster was I faced the problem of subprocess failed with some of mono packages.

The result was I had to clean up (format) my machine and re-install by dvd package :’(.

That is my first experiment of updating system.

Well I dunno if I am lucky here or not…because everything that I need to update…won’t because of Subprocess RPM Failed…

Found and removed another lock file in the rpm folder after cd’ing to it…from there I did the rm -f /var/lib/rpm/__db* command again and it removed it…from there did a rebuilddb and it reintroduced it but removed it when the rebuild finished…went to YaST to upate another file…no joy failed again…

Is there some sort of force that I can do to it to fix whatever has got it hung??? I want to try to steer clear of a reinstall but it is looking more and more like I am going to have to…RPM guys say the db can be fixed before a reinstall so I want to try and figure that out…

Anyone else have this problem? Share how you fixed it???

Hi,

The error message isn’t specific enough. Maybe you can look into the log files under /var/log/YaST2 to find out what exactly failed.

Maybe you want also look at this bug report: https://bugzilla.novell.com/show_bug.cgi?id=236812

hope this helps

Saw that…have tried at start after reboot to free up memory issues…how do I increase swap size without damaging any other partitions. This system is set up on the full disc not windoze dual boot…