SubPixel hinting Suse 11.0 KDE 3.5.9

Followed the procedure here SubpixelHinting - openSUSE-Community
to get subpixel hinting working. but I get this error during the RPM Build:
RPM build errors:
InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID 58857177
Bad exit status from /var/tmp/rpm-tmp.49298 (%prep)

Can anyone help.
This worked fine in 10.3 maybe things are different in 11.0?:confused:

Thing must be different in 11.0. I too tried both the compilation and pure-RPM install of a pre-compiled freetype2 “fix”, and the compilation bombed, and the RPM thingy had absolutely no effect in 11.0 (KDE 3.5.9 or KDE4, 32-bit).

Fonts in 11.0 are fuzzy, not laser-sharp as in 10.3. Firefox 3 is even worse … reedy. And it’s an absolute slug-on-valium as to scrolling, etc.

I’m staying at 10.3/3.5.9 until these elementary bugs are dealt with.

I’m sure that some skilled packager must rebuilt freetype2 library
with subpixel hinting support… Maybe Packman or former Suse Guru
guys give us this patched library into repos.

Who is taking seriously Microsoft FUD related to this issue anyway? Or it
is Novell’s job that openSUSE has no subpixel hinting?

I really miss this “feature” and if Ubuntu or other distros have fully
enabled hinting in freetype2, openSUSE should not be left behind…

Try this package:-

RepoView: Aualin’s Packages (openSUSE_Factory)

I’ve used the freetype2 packages for 10.3 from this repo and they worked really well…rendered as good as Ubuntu Hardy.

-Anshul

Looks like the Community website page has been updated.
This is working now!

:slight_smile:

The library was updated Jul 10/08, so if you d/l a version shortly after the Jul 5th announcement above , and that didn’t work … give the new one a whirl and post trials/tribulations here. Thnx

The Community subpixel repo still shows 02-Jul build.

If so, then merely use the link set out in #4 above.

I had (!) these problems as well, did the whole freetype2 with subpixel hinting thing etc.
But I also had an issue with terrible scrolling in Firefox and 2D resizing. I had a look at the nVidia site for possible solutions regarding the driver and found a solution that works for me. To me it seems that it is a mix of default settings that is just not working well together.

Here is what I posted there on the nVidia forum.

Hi all,
I had (!) the same problems as most here are describing.

What worked for me does not neccisarily have to work for others.
Reading this forum I decided to try a few of the suggestions.
For me the options added to /etc/X11/xorg.conf;

  1. “RenderAccel” “true”
    and
  2. Option “PixmapCacheSize” “200000”
    work very well.
    I have also tried the: nvidia-settings -a InitialPixmapPlacement=2 -a Gl1phCache=1 does not improve anything.

For comparison, I use;
-openSuse 11.0 KDE 4.0.85 (and 3.5)
-nVidia driver 177.13
-nVidia 8500GT
-SamSung 24" screen on 60Hz and 1920x1200 pixels.

The scaling of a terminal, that has been suggested as a test, goes smoothly ! Quite different from the 20secs to 2min3secs that I had to wait before. Scrolling in Firefox is perfect again.

The same with the complaint about the terrible fonts in openSuse11/KDE4… I gues it is the nVidia driver that complained (OK, gave an error message) that in /usr/share/fonts/TT does not exist, so I had a look and found that the file is called truetype i.s.o. TT, made a TT folder and copied the truetype fonts to it (probably a symbolic link will also do the trick).

Now I have razor sharp fonts !

The one thing I do NOT onderstand is that since the release of KDE4.0 nVidia had been bashed all over the internet on hundreds of forums.
There seems to be an aknowledgement from nVidia mods (here), that they are working on a new driver (without any mention of when it will be ready 1 week - 1 year?) and all the time it is just a matter of default settings that need to be corrected…

Now, If my company was in that situation, I’d have my mods posting answers with (possible) solutions all over the place. It seems a better option than backrupcy

It turns out that the addition of;

  1. “RenderAccel” “true”
    and
  2. Option “PixmapCacheSize” “200000” to my xorg.conf file

Was not solving the resizing issue.

Runnung this does help (maybe icw 1 & 2): nvidia-settings -a InitialPixmapPlacement=2 -a Gl1phCache=1

Some people need to use;
nvidia-settings -a InitialPixmapPlacement=1 -a Gl1phCache=1

@Cinq-Marquis:
Thanks a lot for your tipps, but this thread is about fonts, especially subpixel hinting.

I’m pretty sure this has nothing to do with nvidia driver settings.

Just copy it to where you would like to see it…