su - user2 or KDE >>edit..>app entry>'Run as different user' does not provide any sound

Gentlemen of great knowledge,

I was briefly introduced to (purchased) SUSE Linux 7.2 Professional about two decades ago, but not a daily user of OpenSUSE until 2011 and a first timer on this forum :slight_smile:

Been able to solve most challenges with the previous upgrades, but this has proven to be a challenge for my medium technical level skills;

When either adding a “command” to the KDE menu entry (or run it from terminal) such as

su - user2 -c nohup -c '/home/user2/mozilla/firefox' 2> /dev/null &

or select “Run as different user” in the KDE menu item “advanced” tab, there is no sound (works in Leap 15.2). Have tested both on a fresh 15.3 install and two upgraded 15.2 machines.

Bug or by design ?

That’s probably a feature.

When I have run “firefox” as a different user, there was never sound. As far as I know, the sound system is assigned to the user logged into X.

At one time, I was running the browser as a different user as as security caution. I didn’t worry about the sound. But if I wanted to do that today, I would probably run the browser in a virtual machine, and it would have sound there.

Thanks for the quick reply nrickert. This worked in Leap 15.2 as mentioned - without any modifications/changed settings (also in 15.1 and previous). My setup requires such functionality, and a VM would be a bit ‘heavy’ for running just a few appliccations…

Any idea what have changed in this respect 15.2-15.3 ?