Stuck with slideshow - init, X and KDM/screensavers!

Hi All,

I’ve got into one of those ‘so near and yet so far’ situations, and I’m hoping someone knows the little tweak that’s needed to get through to 100% working…

My requirement is pretty simple - to have my openSuse server run a slideshow of pictures on its second screen, constantly (i.e., regardless of whether or not there’s someone logged in on the console).

I’ve tried two approaches:
(1) use the screensavers. Seemed an easy one to try first.
I got this working ok with both xscreensaver and KDE’s screensaver config, but the problem is it only works when someone’s logged in. Try as I might, I cannot get the screensavers to show over the KDM graphical login (‘greeter’) screen. That seems to sit on top always and also forces DPMS standby of the monitors even when I’ve told KDE config not to use DPMS.

(2) run the viewer (qiv or feh) in the background from an init script at runlevel 3, and set up the system not to go to runlevel 5 so that the KDM greeter doesn’t get in the way.

The weird gremlin here is, it works fine if I manually force the script to run (e.g, by “init 2” then “init 3”) and I can kill the x session with Ctrl+Alt+Backspace as normal when I want to log in on the console. However, when it’s started by init during the boot sequence, it behaves slightly differently and Ctrl+Alt+Backspace doesn’t work to kill the x session! That’s not helpful as it means I can’t get into the console if there’s a problem with the machine.

Soooo **** close!

Does anyone know how to get option (2) working by making the x session respond properly to Ctrl+Alt+Backspace when it’s started during boot; or to make screensavers kick in over the KDM greeter/login screen, please?

Any ideas much appreciated!

Thanks very much,


In case relevant, I should add… openSuse 11.1. KDE 4.2.


do it twice quickly

Thanks caf, but I think you missed the problem. In (2), the problem I quoted is that Ctrl+Alt+Bksp wasn’t working. Ok, I admit I didn’t say “twice”!

Found a solution in the meantime, so I’ll post it for future reference… for some strange reason, the middle button of my mouse does terminate the x session (maybe slightly worryingly!). And the real answer is to stick "setxkbmap -option terminate:ctrl_alt_bksp in the .xinitrc being used by the process. Still none the wiser why it was behaving inconsistently, but that sorted it :o)