Stuck with Amarok - doesn't work at all


my positive surprise in Suse 11.2 was that the scanner of the Canon MP540 worked right away, the negative surprise is that Amarok is f***** up.

I does not play anything at all, I even cannot drag an mp3 to the playlist.

I already did the following:

  • Installed the ffmpeg, windows codecs etc. following a link I found in this forum.
  • Reinstalled Amarok 2.1.1
  • Upgraded to Amarok 2.2

Still nothing.

Any idea ?


PS: I remarked a strange thing: I installed the 32 bit version on a 64 bit machine and when installing other packages with YAST, sometimes it adds 64 bit libraries. Is this normal ?

PPS: The output of zypper lr -d:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Backport | Backport | Yes | Yes | 80 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.2 |
2 | Packman | Packman | Yes | Yes | 90 | rpm-md | Index of /suse/11.2 |
3 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
4 | openSUSE:11.2:NonFree | openSUSE:11.2:NonFree | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
5 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
6 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.2/repo/non-oss |
7 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 120 | yast2 | Index of /distribution/11.2/repo/oss |
8 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
9 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

Dump Backports.
Then use the Package Switcher in Packman
Have you done this: Multi-media and Restricted Format Installation Guide - openSUSE Forums

Yes I followed th instructions under this link

Dump Backports
Update all in Packman just in case
ImageBam - Fast, Free Image Hosting and Photo Sharing

You may need to bring a load of kde4 stuff back on track now you dumped Backports. Filter by system and look for Red and or Blue packages.

OK I switched back to packman. No more red or blue entries. Still amarok doesn’t work.

I cannot drag mp3 to the playlist.
I can drag streams to the playlist but they don’t play.

Playing MP3 works fine both in Xine and MPlayer.

Yes I agree Amarok2 is a mess. So may I recommend VLC? Since you already have the Packman Repos VLC is in there,get Packman’s version.
Now just in case that doesn’t meet your specs, there is also Songbird that too is in the Packman repos.
I use both with no probs.

Same problem here, i’m having problem with the amarok 2 since it’s lauch, that’s terrible

Kaffeine of KDE4 is a similar disaster - all nice featured of the previous release like video adjustments have been removed.

Why would one ruin an excellent product, I am still thinking about.

I coped with by installing kaffeine of KDE3. It is possible to do by adding KDE3 repository, or perhaps in other ways. However, it looks like fonts of the kaffeine and other KDE3 applications are small and unadjustable.

Maybe you can go the same path and install Amarok from KDE3.

You guys must be doing something wrong - it works just fine.
Try adding the kde43 repos see if that’s better.
Index of /repositories/KDE:/43/openSUSE_11.2

Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43

Hi caf4926. Sorry but now I am lost. What do you mean saying it works just fine ?

  • Amarok2 ?
  • Kaffeine ?
  • installing Kaffeine of KDE3 ?

And when adding the repos, should then the applications be re-installed, updated , ???

In the meantime I am using Songbird and VLC as recommended by Sagemta. That works indeed.



I use amarok as music player - It works - That’s what I mean.
I don’t use kaffeine
Songbird does work - True

Adding the kde43 repo I quoted
You then open software management and use the Package switcher on that repo.

But have you tried deleting all your hidden amarok config files, might want to try that first.

This folder: .kde4/share/apps/amarok

These files:


I only installed the libxine1-codecs from Packman to solve this.
This will also update the libxine1 to that of Packman and 3-4 more
packages, but it will work with Amarok 2.1.1 (the default of openSUSE 11.2)

I’m a newb venturing out into Linux and chose openSUSE to get my feet wet. I want a player that will give me Shoutcast and until Winamp is ported to Linux distros, I guess Amarok will have to do.

I cannot get Shoutcast to do anything but sometimes get Magnatune and Cool Streams to play. I tried to play some local files I ripped to a folder and double clicking does nada.

Question 1: How do I get anything to play? I’ve read advice given to others with similar problems and it usually sounds like the program is incomplete: “You need to make sure such-n-such lib files are installed properly” or “You need to make sure the xine engine is installed and doing such-n-such…”

Lord a-mighty, I just want to play some tunes…:open_mouth:

Question 2: Since the good folk at Amarok have issues with submitting a complete piece of work, can anybody tell me what needs to be added to a fresh install of Amarok 2.2.1 on a fresh install of openSUSE 11.2 with KDE 4.3.1 (release 6) so I can play anything?

And if anything has to be installed in any particular order, please let me know.

My hairline and I thank you in advance for any sage wisdom you might provide.:shake:

Follow this carefully
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Well if it was working fine there would not be an reason to start this topic wouldt it ???

I am on gnome desktop and amarok2 seems to be impossible with that desktop WITH opensuse other linux amaraok2 works fine with gnome desktop.

Yes you might wanna EDIT this answer but thats not gonna take anything forward ,your guides sucks just understand that dont cry ower this just understand it same with graphics ATI guides not 1 working seriusly.And THATS not because ATI graphicscard sucks on linux thats just not true.

Only thing you get trying to install amarok2 on gnome desktop on opensuse 11,2 is the awesome ICEauthority bug.

I think you are doing wrong thinking the packman is the solution for every question its just not…rotfl!rotfl!

Maybe opensuse is not the one for you? Why not try a different distribution.

Certainly amarok 2 works fine with kde. As has been posted all you need to add is the codec package from the packman website.

No experience with ATI graphic cards - as I use nvidia cards. Although I have read many posts - over the years - saying that ATI linux drivers are not as advanced as those produced by nvidia.

If you want help, I can help you.?

Please open a terminal and do this, then post the result:

zypper lr -d