Stuck on libostree at 63%. Forced powerbutton reboot

  1. At 3:14 pm EST I ran
zypper dup
  1. Libostree got stuck at 63%
  • Flatpak is installed. Reason why is relevant. I saw something flash by that said it was an error.

  • Waited 15 minutes. During this time, system started to degrade. Firefox will not open. New terminals fail to open. Unable to sudo su - in existing other terminals

  • I was forced to reboot via power button

  1. System rebooted
  • tried to re-run zypper dup, it gave me the flatpak / ostree error and completely bombed.

  • system immediately degraded to unusable again.

  • reboot command failed.

  • powered off with power button.

  1. On Grub, selected readonly snapshot before all this happened.
  • system booted. checked firefox, network, sudo to root. all was fine

  • ran

snapper rollback

as per grub bootloader instructed.

  • rebooted
  1. System came up fine.
  • ran
zypper dup


  • it completed fine. tried firefox, surfing, and regular work tasks. it was good.
  • rebooted to get new kernel
  1. Created opensuse forum account. Posted this message

Some comments from one engineer to another.

I am glad OpenSuse installer format the partitions the way it wants to. I was reluctant to trust btrfs with root partition, however since this is my laptop I do all my work on, I gave it a leap of faith. I am very glad I did.

Hi, welcome to these forums !!

That is some awesome btrfs success story, if I understand correctly :).

Welcome to the Forums, and thanks for the very interesting story to read. Perhaps this will help others.:slight_smile: