Stuck on 'hardware detection' when installing on Vultr VPS

I’m trying to install Leap15.3 on a cloud instance from VPS service Opensuse is not in the default OS options but in their ISO library.
However in their instance console window (VNC) after the machine boot, I choose ‘installation’, then it will get stuck on the ‘hardware detection’ screen.
I also tried to upload a new Leap15.3 media ISO to install, it’s the same problem.
In fact, a few years ago I had similar issues when installing opensuse there, I don’t remember how I managed to install it in the end. Prolly installed a JEOS version of opensuse but I don’t find a JEOS LP15.3 media to download to have a try.

So far I’ve tried using “nomodeset” or “textmode=1” in the boot option line. It is always stuck at “hardware detection”.

p.s. & off topic: Commercial VPS service providers have very poor support for opensuse from my experience, it is rarely provided as an OS option by default. :frowning:

Sorry it has just passed the hardware detection stage (after a long time) with “textmode=1” option. Let me see if it will finally install !:X

With “textmode=1”, it gets stuck at “loading installation media (2/6) 74%”, for about an hour now.

OK so the issue is that 512M ram does not meet the system requirement for Leap 15.3. Possible to find Leap JEOS ISO to install on the small server?

MicroOS? You need to create an ignition iso for config though, else head over to SUSE Studio Express and roll your own image? Install more RAM?

1G ram instance is more than 40% more expensive. Could not figure out how to use suse studio. Will try something else.