Stuck on DHCP/DNS Update on Windows Server

Hello Guys,

in our company we use windows dhcp and dns servers. (win 2012r2)
we have several linux clients on opensuse 13.2 which will be authenticated via active directory. that works fine.
only problem is, the machine gets an ip address from the dhcp server, but won´t update or create a dns entry.

we use the network manager on our linux clients.

i´ve tried the following settings:

send host-name “linuxtest2”;
send fqdn.fqdn = “linuxtest2.domain.tld.”;
send fqdn.encoded on;
send fqdn.server-update off;
also request fqdn, dhcp6.fqdn;
do-forward-updates true ];

after i set “send host-name” i am able to see the hostname in the dhcp overview. but not in the dns section.

i also tried in /etc/sysconfig/network/ifcfg-eno16780032

in the dns options i set, that dynamic updates are allowed from secure and unsecure clients.

do you have any further ideas for me?

thank you… best regards

You should not have a problem if you join your Linux machine to the Active Directory.
Did you do this, or did you only configure Users to login to your Linux hosts with AD credentials?

You can inspect your AD machines using usual admin tools to see if your Linux machines are listed.

You also need to <know> your AD is working properly… I wrote a long time ago elsewhere that a healthy AD requires a “troika” of integrated DNS, DHCP and Domain Controller(s). If any one of them isn’t working properly, then stuff like DHCP leases aren’t passed on and into your DNS automatically, and won’t necessarily show up in your DCs with accurate information (the order of what I described is not necessarily accurate, all three will accept various types of info and pass to the other two). And, shared information between the members of “the troika” aren’t immediate, you will likely have to wait a period of time for updates to happen.


Thx for your reply. We also join the PC to the Windows Domain.
On the AD Server i can see under attributes the so calles “dnsname” for the machine correctly configured.
in the dhcp scope, it is also shown correct since i changed “send-hostname”.
but only in dns it is not registered. i set up the dns server for secure and non secure updates.

which tools do you mean?
on our ad server the dns, dhcp and domain controller tools a installed.
i waited over 3 days. unfortunatelly no domain updates were made.
thanks in advance

Additional Info,
when we join the client to domain, we get the following error:

Using short domain name – DOMAIN
Joined ‘LINUXTEST2’ to dns domain ‘domain.tld’
No DNS domain configured for linuxtest2. Unable to perform DNS Update.

When i set a static dns entry, it works without this error message.

i set the following options in the several config files:

/etc/hosts: linuxtest2.domain.tld linuxtest

special IPv6 addresses

::1 localhost ipv6-localhost ipv6-loopback

fe00::0 ipv6-localnet

ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts linuxtest2.domain.tld linuxtest2



Before posting this, I did a quick search on the Internet for your error, and it should be noted that those solutions do not apply here because all posted solutions I found describe setting up SAMBA Server, so need to point the SAMBA Domain name to itself ( This scenario is a <client machine> connecting to AD Servers, so you need to create your Hosts entries with the network interface address, not the localhost address(shouldn’t hurt if you want to configure both interfaces with the FQDN). On Linux, the two interfaces are <very> different (on Windows, they <can> be different but by default are configured to resolve the same).

Besides the Hosts file entry (which I’ve personally haven’t had to do so YMMV on that), you definitely need to configure your machine’s Host and Hostname variables correctly, set the domain name on the following page and <uncheck> the checkbox that specifies that DHCP should change your hostname

Some closing notes…
I hadn’t invoked the domain name from the command line for ages, but this time when I did this, it’s not resolving properly. I would guess it shouldn’t hinder joining a Domain, though.

The following do not display the domain part of the FQDN or the domain name by itself

hostname --domainname
hostname -f