Stuck on Boot...nothing after [OK] Started Locale Service

Hello all,
I’m a newbie and was trying to get my tensorflow library working in python…
During this i tried installing the nvidia graphics drivers and after a reboot the booting process just stuck at:

[OK] Started locale Service.

All the other things are OK until here except for the NFS server which earlier was also the same.
Need help as its important for me to start it up.

Thank you.

It’s possible at startup for X to fail to start and leave you looking at a screen that should have a login prompt but does not. A failed proprietary NVidia driver would be candidate to produce such failure. Can you Alt-F2 and find a login prompt? Does simply pressing <ENTER> produce a prompt? Or, is the computer actually frozen? Can you ssh into it from another device?

I tried booting it up in failsafe mode using nomodeset and somehow(as the screen is refreshing many times) logged in as root…

Update:I just installed the recommended installs by zypper which included nvidia drivers and nouveua (The screen flickering stopped). The gui showed up just with a pointer and had kdeinit5 failed to load message…I think the nvidia drivers are causing the issue?? any solutions??

If i try to run kdeinit5 using CLI i get something like:

kdeinit5:error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

How do I solve this???

kdeinit5 is not intended to be run directly from the cmdline. Did you try the original default video drivers first only to find them somehow flawed before installing the proprietary driver? There are two, nouveau (xf86-video-nouveau), and modesetting (integral to the Xorg server). If not, you should try uninstalling the NVidia drivers and rebooting. Note these two drivers require that the kernel cmdline not include “nomodeset”.

Other things to try for troubleshooting purposes only, logged in as root:

1: startx
2: WINDOWMANAGER=/usr/bin/startkde startx

What happens?

You can try uninstalling sddm and installing lightdm.

We need more information to be of much more use, including /var/log/Xorg.0.log, /etc/X11/xorg.conf (if it exists) and output from the following:

zypper in inxi
inxi -G -c0
lspci -nnk | grep -A3 VGA
journalctl -b | grep ailed

pasted in here using code tags (the # icon).

Also should mention if this is a Optimus (hybrid graphics ) notebook

I’m having the same issue – boot hangs after {OK} Started Locale Service

Ctl-Alt-Backspace bring up:

502.570001] nouveau 0000:01.0: DRM: GPU lockup - switching to software fbcom

then it continues to hang. I can get a prompt from there.

1: startx
2: WINDOWMANAGER=/usr/bin/startkde startx

both produce the same error messages, ending with xinit failed. /usr/bin/Xorg is not setuid

Suggestions? thanks

  1. The question needs to be asked… Are you running your openSUSE with default English or have you set your system to some other language?
  2. If you are able to boot in Recovery Mode or whatever might be necessary, you should retrieve your system boot log and post to a Pastebin and then post with a link to your Pastebin post. You can extract previous boots using the following example which returns the previous boot (minus one) and writes to a file called “Log” in the current working directory
journalctl -b -1 > Log
  1. I assume you haven’t started to install Tensorflow. A mandatory axiom is that a system must be completely stable before making major changes like installing major applications.
  2. Your graphics problems as you describe it should be a system problem, unrelated to any other application.
  3. If you installed a non-default driver, you need to describe what method you used to install and if possible provide a link to the guide you followed.

TSU

[QUOTE=tsu2;2874372]1. The question needs to be asked… Are you running your openSUSE with default English or have you set your system to some other language?

THis is running with default English. No other languages have ever been on the system. There have been no previous graphics issues with 13.2 or 42.2 on this machine. Problem arose when I upgraded to 43.3. Have not been able to boot to graphics since.

  1. If you are able to boot in Recovery Mode or whatever might be necessary, you should retrieve your system boot log and post to a Pastebin and then post with a link to your Pastebin post. You can extract previous boots using the following example which returns the previous boot (minus one) and writes to a file called “Log” in the current working directory
journalctl -b -1 > Log

I will attempt this.

  1. I assume you haven’t started to install Tensorflow. A mandatory axiom is that a system must be completely stable before making major changes like installing major applications.

Your assumption is correct. I have not attempted any changes other than the system upgrade.

  1. Your graphics problems as you describe it should be a system problem, unrelated to any other application.
  2. If you installed a non-default driver, you need to describe what method you used to install and if possible provide a link to the guide you followed.

I have not installed any drivers. Ever. I believe there is an NVidia driver on the machine, but I think 42.2 was using nouveau. Since it worked fine, I never paid much attention.

Thanks for your help.

Yes its an Optimus notebook…

Not everyone with Optimus knows they have Optimus. I expected inxi/lspci output to answer that issue.

Were you following the instructions on https://en.opensuse.org/SDB:NVIDIA_Bumblebee to install NVidia driver? If not, maybe it would be easiest to start fresh and use them.

snapshot of output:
https://drive.google.com/open?id=0BzU1OYYZMZklWkJHX215UUxkREdXdXNnMThkQ3lWVFgtTjBR

Tried this no changes

https://drive.google.com/open?id=0BzU1OYYZMZklWkJHX215UUxkREdXdXNnMThkQ3lWVFgtTjBR

Some more information…its actually very difficult to post outputs i’ve added link to images of the same:

https://drive.google.com/open?id=1CdD_0KJUf3RkOeKNCISezrqSFZ1igBaR

https://drive.google.com/open?id=0BzU1OYYZMZklZXhEVVRGNWJJZS1rWW1KcEctYUNIeEZnNVpB
https://drive.google.com/open?id=0BzU1OYYZMZklZXhEVVRGNWJJZS1rWW1KcEctYUNIeEZnNVpB
https://drive.google.com/open?id=1CdD_0KJUf3RkOeKNCISezrqSFZ1igBaR

Thanks everyone for taking out time to reply.
Hope i solve this early

On limited functionality boots you can use the cmdline tool

susepaste

to upload the images or information, then provide the URL(s) to the uploads here. They can be friendlier than Google uploads.

I already had installed bumbleebee??
Should i completely reinstall it(Is this what you meant by fresh??) ?

Did you? Did you ensure everything worked as expected before trying to install tensorflow?

Should i completely reinstall it(Is this what you meant by fresh??) ?
Fresh=clean=virgin!=upgrade. Optimus is commonly problematic, so close adherence to special instructions for Optimus may make the difference between continued frustration and success. Few if any of us here trying to help actually have Optimus, which limits our ability to help.

Thanks Everyone for taking time to reply and trying to help solve this issue…
After many attempts to get my system back I understood that i had eventually messed up something really bad:
The events which i think led to a mess
->I had bumblebee Previously installed(installed by me) → then i tried to install CUDA which eventually made changes to X (ofcourse with my consent) ->still tensorflow didn’t work-> so i removed those cuda files directly by deleting them:’((i know please don’t scold me)-> Nvidia proprietary drivers (which i installed to get the tensorflow going but unfortunately it did not flow:() → then i posted the rest on the forum →

I have currently solved the issue by upgrading to openSUSE leap 15 using a bootable disk…

I am not able to understand was it the xorg.conf file causing issues or some lib dependencies which i messed up during installation/re-installation of drivers(which caused libGL.so.1 issues)…
???

I doubt it is easy to get CUDA to work on a Optimus (hybrid graphics machine) Optimus is a special NVIDIA invention to sell more GPUs to the proles. Because you can not turn off the the Intel GPU on most Optimus machines getting CUDA to work could be difficult. I suggest you ask at NVIDIA . Main problem is that NVIDIA does not fully support Optimus on Linux. So you probably need a non-Optimus machine

This is what i realized after i broke up my system :).