Stuck on audio and printing configuration

I decided to try opensuse having started with Kubuntu and spent 2 weeks trying to get the audio to work by reading all the horribly complicated troubleshooting instructions. I figured that the configuration tools in opensuse might resolve the audio problems more easily. Unfortunately this did not happen and I now have no audio nor can I configure my printer.
The audio configuration brings up the message “An error occurred during the installation of 82801H (ICH8 Family) HD Audio Controller. The kernel module snd-hda-intel for sound support could not be loaded.” It also refers to module, IO and IRQ parameters and suggests passing options to the ALSA module - I have no idea what this means.
The printer problem is more straightforward - it recognises my HP Officejet 5610 but tells me that I am using the wrong spooler. Again, I don’t understand what this means. As a matter of interest the printer is automatically detected by the OS, but as a scanner (which it also is).

I’m afraid my initial advice is typically to give the user (in this case you) reference to another “horribly complicated troubleshooting instruction”. :\ …
SDB:AudioTroubleshooting - openSUSE
I tried to keep it simple when writing that guide, but unfortunately, if sound does not work automatically, then this tends NOT to be simple.

If you prefer, we can walk you through this manually, but it make take a few iterative posts. To start with, I need more detailed information on your PC’s hardware and software setup in order to provide an accurate and helpful (hopefully) recommendation. Specifically to provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal or to a konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal or to a konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundAlso, are you using Gnome? KDE4? or KDE3?

I don’t know if this will solve your problem, but many openSUSE users find it necessary to install an updated hplip for HP printers. The 3rd party packman packagers packaged an updated version of the package (as an rpm ) for openSUSE: PackMan :: Package details for hplip

Have a look in the multimedia section and have a read of the stickies
then repost over there :slight_smile:

For HP printers/scanners I’ve normally installed hplip via YaST or
zypper (zypper in hplip) and then as root user run hp-setup. Then use
hp-toolbox to control, never used YaST.

Check here to see if your model is supported and other information;
HP Linux Imaging
and Printing

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 8:58, 2 users, load average: 0.36, 0.15, 0.06
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I tried following the guide but continually get messages like:-

“ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory”

Here is the URL:-

tsalsa.txt - (beta)

(I noticed “Pinnacle” is listed on the web page this leads to as a multi-media controller - this is my TV card which appears not to be detected in configuration.)

Here are the other results:-


No result


Linux linux-6klv #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux

options snd slots=snd-hda-intel

u1Nb.kURRCMIOEo3:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Finally, I am using KDE 3.

Your driver is not recognized here, so minimal information is provided by the script. Out of curiousity, are you using ndiswrapper or madwifi for a wireless (it on occasion will interfere with a users sound)

I do note from a Google search of the Austek P5B (which I believe is your mother board, as identified by the script) that the hardware audio codec for that motherboard is an AD1988.

This is strange. You alsa-firmware version is inconsistent with your other alsa versions. Whether this is the cause of your problem, I do not know. But IMHO having alsa-firmware version inconsistent with your other alsa packages may not be a good practise.

OK, thanks for that, … it may come in handy later.

I am puzzled as to why your audio is not loaded. Your boot logs may provide a hint. Can you reboot your pc, and immediately after the reboot, copy and paste the following into a konsole:
dmesg > dmesg.txt && curl -F file=@dmesg.txt copy and paste here the output url that provides.

While waiting for me to review that, you could also try some other approaches … The ALSA-Configuration.txt file has this for alsa 1.0.16 for the AD1988:

	  6stack	6-jack
	  6stack-dig	ditto with SPDIF
	  3stack	3-jack
	  3stack-dig	ditto with SPDIF
	  laptop	3-jack with hp-jack automute
	  laptop-dig	ditto with SPDIF
	  auto		auto-config reading BIOS (default) 

You could try editing your /etc/modprobe.d/sound file, changing it to this (by adding an extra line at the end):

options snd slots=snd-hda-intel
# u1Nb.kURRCMIOEo3:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel 
options snd-hda-intel model=6stack-dig 

and then restart your pc and test your sound. If that does not work, replace “6stack-dig” with “6stack” and restart and test again. You could also try “auto” and “laptop” and “laptop-dig” restarting and testing after each attempt.

I also note from a search of the alsa site for the AD1988 that there have been some updates in the more recent alsa versions: Search results for AD1988 - AlsaProject

So if the /etc/modprobe.d/sound file edits do not work, you could update your alsa to the latest cutting edge version (incorporating those updates) by opening a konsole, type “su” to get root permissions (enter root password) and with your PC connected to the Internet type:

zypper ar multimedia 
zypper install alsa alsa-utils alsa-tools alsa-plugins alsa-oss alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

then restart your PC and test your sound.

Here is the URL:-

dmesg > dmesg.txt && curl -F file=@dmesg.txt

I have updated all the alsa file but nothing has changed.

I cannot edit text files for some reason - nothing comes out when I type.

… no URL …

Likely because you need to edit the files with root permissions. Do you know how to do that?

Yes I know how to do that. Unfortunately, when I enter my password and press return, the console disappears for some reason. I will have another go using the sudo method. Regarding the URL, when I cut and paste the resulting line from the console into the forum message, unlike last time, there is no link appearing, just what you see there. I will try that again also. I am getting close to giving up on this however. Audio is such a basic function that it needs to work pretty much out of the box or at the very least by some sort of automatic system to obtain a required driver for the man in the street to consider using Linux. At the moment, it seems to me that there is some way to go to get to that level.

This should not happen. IMHO its most likely you are doing something incorrect wrt the syntax.

If you are using kde, simply open a konsole and type: kdesu kwrite and enter root password when prompted and then navigate internal to kwrite to the file you wish to edit. kdesu will open a kde application with root permissions.

If you are using gnome simply open a gnome-terminal and type: gnomesu gedit and enter root password when prompted and then navigate internal to gedit to the file you wish to edit. gnomesu will open a gnome application with root permissions.

There are many ways to type a URL. Type the URL, then highlight it, and select the " # " above so as to put code ] and /code ] on either side of it. That will ensure it shows up here.

Audio “mostly” works out of the box for Linux. BUT with new hardware, and with manufacturers either providing no drivers (or providing poor quality drivers) for Linux, then it is up the Linux community to try and create the audio drivers. This can lead to problems.

I spend a LOT of time on this forum trying to help users with their basic sound. The most difficult cases to solve are often the ones with Linux newbies, where most of my time (and most of their time) is spent teaching (and in their case learning) Linux basics, as opposed to actually fixing their audio problem.

Maybe yes, maybe no. There is a HIGH probability this is simply your unfamiliarity with Linux, and a user with some Linux experience could sort the audio in minutes, if sitting in front of your PC.

Finally got it working after sitting down and going through the procedures properly. I think it was an edit to the file. Thanks for all the time spent on this. I don’t think I mentioned the printing was resolved quite quickly - I had an unconfigured entry I couldn’t delete. As soon as I managed to delete it and add a configured entry, it was fine. Thanks again.

Glad you got it to work … Congratulations … Hopefully with what you have learned, and with Linux improvements as well in alsa, this will be easier if there ever is a next time.