Stuck in Grub Rescue - Help!!

I was in the process of reinstalling SUSE 13.1 when it failed. After doing some detective work, I determined that my USB flash drive was defective. I have now created a new one and verified it but the computer I was working on is stuck in Grub rescue mode. There is no other operating system on the computer. The error message that I receive is ‘/boot/grub2/i386-pc/normal.mod’ not found. When I insert the new flash drive, it does not boot into a new installation but goes to Grub.

How can I either install the missing file OR get a reinstallation of the operating system going?


Well, since your USB flash was defective, it’s not certain that this is the only file that’s missing/damaged.
So I would recommend a fresh installation in any case.

It sounds like your system tries to boot from the hard disk first. As there was no operating system on the hard disk the first time, it continued to boot from the USB.
Enter your BIOS settings and change the boot order. Normally you have to press ‘F10’, ‘F12’, or ‘Del’ (or something like that) on the BIOS boot screen (before the grub menu) for that, but the screen should tell you.

There might also be a BIOS “boot menu”, which should allow you to boot a specific device once. This is normally reached via ‘F8’, but may differ on your system. Again, the screen should tell you.

I have the boot order set as 1) USB-FDD 2)HDD-0 3) CDROM. Set in this manner, I am going to Grub recover each time. The other USB options I have are USB-HDD, USB-CDROM, USB-ZIP.


You should set #1 to USB-HDD I suppose.

USB-FDD is a USB floppy drive.

I tried all of the usb options available. USB-FDD and USB-CDROM take me to grub-rescue and USB-HDD and USB-ZIP just hang after the computer says Verifying DMI Pool Data …


That means that it tries to boot from the USB but it doesn’t work.

You said your USB flash drive was defective. Is this a new one now?
Have you actually written the Installation media ISO to that drive?

This is a new Flash Drive that I reformatted to EXFAT then copied openSUSE-13.1-DVD-i586.iso to. I did a new download of the file before copying it to the flash drive. I ran the checksum utility against the file both after the download and after copying it to the flash drive. Everything check out good.


You copied the file to the drive?
That won’t work.

You have to write the image to the disk directly, with a utility like SUSE Imagewriter:
Please note that although this article talks about the LiveDVD, this applies to the InstallationDVD as well.
You don’t have to download the Live-ISO instead.

On Windows you can also use this, if Imagewriter would give you problems:

Redid my flash drive using and then set the computer to boot from usb-hdd. It is now loading the kernel.

Thanks for all of your help!!

Julie Bunker