Stuck in emergency mode


I was playing Dota2 like a Human, when openSUSE suddenly froze in the middle of the game. I waited for several minutes, then reseted the computer. However, oS refuses to start anymore, stuck in emergency mode. It says I should save a rdsosreport.txt and attach as a bug report, however I can’t reach that file from Windows. Apparently I can’t copy to other partitions from shell (???). I tried starting something from advanced options, but every other choice is doing the same thing. I use the 13.2 version.

In general Windows doe not do Linux after all Windows is the only OS in the world.

You need a live Linux disk to boot from to work on the Linux partition(s).

was that something you tried from advanced options the recovery mode??

You could try booting to the command line. At the grub menu press e to enter edit mode find the line starting linux. Go to the true end of that line (note it wraps). Enter a space and a 3 press F10 to continue boot. You should then get a terminal prompt to log in. Log as root. You would then have to use text commands to to trouble shoot

Another thing is press esc key immediately after selecting the boot option in grub this will list all the processes started and if any fail. Tell us what fails

Not that this could be a corrupted file system which does not let you mount certain partitions and if so probably best to run smartctl as root to check the drive since it may be in the process of failing

I did not see a recovery mode, only earlier versions of Linux kernel.

I tried both thing, nothing changed. Also, there is no smartctl command. But there is no shutdown command either, so the whole thing might just’ve gone full retard.

I haven’t tried anything, and I’m already out of ideas. Maybe I could just run a SUSE image from Windows, and maybe I can start a new installation at boot?

Run a live Linux and use that to test. If the file system is corrupted (which is what it appears) then many things may not be available because the file system is broken.

The reason for any such breakage can be the hardware breaking. In general HD’d don’t just stop working they go bad in stages smartctl will readout the hard driver error list also can test the drive.

In any case fsck need tobe run and may correct the problem if things are not too messed up.

Today I have tried to fix this according my own ideas. This is where I got so far. The loading stops here, and nothing happens, and reacts to nothing.

I made a new bootable USB flash drive, but it still freezes at boot if it’s in.

I ran the DVD installer from Windows, and restarted to boot with it. This is how I got it installed in the first place (completed the installing from net with cable contact to a router).

I chose various options from advanced options on the GRUB screen. The 3.16 ones do a little more than the others, but as you can see on the picture above, not much better.

Still say first check the file system. Second check the hardware.

Starting the installer form Windows is very very not standard. In fact I’m surprised it worked.

Is this an EFI boot or a legacy install??

Down load and try a LIve Linux (any kind) run fsck agenenst each Linux partition and smartctl against the disk

A good choice may be the openSUSE rescue disk build. It has all the tools needed. Also relatively small

And how do I exactly run Live Linux from GRUB?

You don’t burn to a CD/DVD or USB and boot to that

Okay, I’ve have done it, but in a noob way. I simply had my friend to burn a DVD, and put a drive into my computer. Since my /home directory was in a different partition, everything went back as before. Except I had to reinstall the programs, but their settings remained the same.

(On an unrelated note, the SDL_AUDIODRIVER=alsa steam seems to be fixed, as Steam now does have sound if I run it without it.)