Stuck during boot-up (Creating device nodes with udev)

Hi,

I am encountering the below error whenever I selected Desktop in the GRUB menu:

failed to get NUMA memory information from SRAT table
pci 0000:00:09.0: BAR 0: address space collision on of device
doing fast boot
Creating device nodes with udev

But if I select Failsafe, it boots ok.

I execute command dmesg and it does not show any information why it was stuck.

Also, I am not sure if there is a change in the kernel. As far as I remember, I only configure the automatic updates. Can you help me on how to verify if there is a kernel update?

Please let me know if any information is still needed (and how to execute it).

Many thanks.

When you boot the Desktop kernel try adding this to the boot argument

acpi=off

This screen is of an Install menu, but the same principle applies, you can edit how your menu boots too. Just use your down arrow to stop the timer, move back to Desktop and use your keyboard to type the above

http://public.bay.livefilestore.com/y1pImyzVAjlvBaGjfNqehtCDqH-n1TIsPnc7ICLF2HIlEHqYxjygj707ghJ-idkLY884cMi7XP63Q3iwbeQJTfAWQ/acpi%20boot%20arg.png?psid=1

If it works, we can add it permanently - so report back

hello,

i’ve tried your advise but it is still the same…

vintag3 14 wrote:

>
> Hi,
>
> I am encountering the below error whenever I selected Desktop in the
> GRUB menu:
>
> failed to get NUMA memory information from SRAT table
> pci 0000:00:09.0: BAR 0: address space collision on of device
> doing fast boot
> Creating device nodes with udev
>
> But if I select Failsafe, it boots ok.

Booting in failsafe typically means with these arguments:

showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off
nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe

I would try adding ‘maxcpus=0’ when you boot normally and see if that
helps.


Per Jessen, Zürich (20.8°C)
http://en.opensuse.org/User:Pjessen

hi,

thanks for your advise, it now boot normally.

however, i have just one question, how come previously, my laptop boots without using the maxcpus=0 using the normal boot? and what is the purpose of maxcpus? how come if i do not add that, it wont boot up normally?

thanks again for the help… really appreciate it. :slight_smile:

Maybe our genius @Per Jessen
Will have a better idea than me. Well done @Per Jessen!

We have not had a kernel update for some time. I’m not sure what else will influence the change. Unless you changed kernel type:
Eg; from kernel-desktop to kernel-default

vintag3 14 wrote:

>
> Per Jessen;2182926 Wrote:
>> vintag3 14 wrote:
>>
>> >
>> > Hi,
>> >
>> > I am encountering the below error whenever I selected Desktop in
>> > the GRUB menu:
>> >
>> > failed to get NUMA memory information from SRAT table
>> > pci 0000:00:09.0: BAR 0: address space collision on of device
>> > doing fast boot
>> > Creating device nodes with udev
>> >
>> > But if I select Failsafe, it boots ok.
>>
>> Booting in failsafe typically means with these arguments:
>>
>> showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off
>> nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
>>
>> I would try adding ‘maxcpus=0’ when you boot normally and see if that
>> helps.
>>
>>
>> –
>> Per Jessen, Zürich (20.8°C)
>> ‘User:Pjessen - openSUSE’ (http://en.opensuse.org/User:Pjessen)
>
> hi,
>
> thanks for your advise, it now boot normally.

Great! However, it’s not a normal situation, I suggest you open a
bugreport. http://bugzilla.novell.com/.

> however, i have just one question, how come previously, my laptop
> boots without using the maxcpus=0 using the normal boot? and what is
> the purpose of maxcpus? how come if i do not add that, it wont boot up
> normally?

maxcpus=0 is often used to disable SMP mode when a multi-core/processor
box has a setup/BIOS problem. In my experience, maxcpus=0 has
occasionally been necessary during installation, but never afterwards.


Per Jessen, Zürich (27.2°C)
http://en.opensuse.org/User:Pjessen

caf4926 wrote:

>
> Maybe our genius @Per Jessen
> Will have a better idea than me. Well done @Per Jessen!
>

Nah, no genius here - only experience. If vintag314 had opened a
bugreport, it would have been one of the first suggestions too.


Per Jessen, Zürich (27.0°C)
http://en.opensuse.org/User:Pjessen

Hi, Sorry if this is not the right place to post this, but I just wanna ask, my box is working fine until today when I boot it up this morning it wont load it is just stuck at

“doing fast boot
Creating device nodes with ndev”

its been there for a while and its not continuing, is there anything I can do to it? Thanks.

Hi googol. Welcome to the forums. This is a very old thread that you have tacked on to. Although the title probably describes your issue, the cause may be entriely different. Ideally, you should start your own new thread in this subforum, and tell us which version of openSUSE you are using. More questions will probably follow.

im sorry I just searched for an issue the same as mine since im having a hard time posting my own. anyway thanks and ill try to post again thanks