stuck @ 640 x 480

Hey all,

Everything was working great until this morning.

Anyways, My 64bit 11.0 setup with my 8600GT is stuck at 640x480 resolution.

I have gone into Yast->Hardware->Graphics Card & Monitor and it says that I am at 1680 x 1050. (What I was at until this morning)

I also tried updating my nvidia driver through yast. Still no luck.

All the desktop icons and all the open applications are at 640x480.

What else can I try to restore my resolution to 1680x1050?

Thanks

Heeter

Changing settings in Yast only works when you change them while out of the GUI. Don’t ask me why.

GO to terminal and type su

Enter root password

type

init 3

Log in as root

type

sax2 -r

(this will start Yast)

Yast may select the correct resolution, but you may want to check it. When you exit back to the terminal type

reboot

Once you start back up the problem should be fixed.

If you have no desktop upon reboot, log in as root and type

sax2 -r -m 0=vesa

This will at least give you a desktop so you can try other things.

(Sorry if you already knew all of this)

I too am stuck at 640x480 with the nvidia driver enabled.

This is a fresh install on the following:

AMD X2 4200+
GeFroce 8600GT
2gig RAM

If you need my xorg.conf I can post it here tomorrow.

I have searched and searched for a solution to this problem. It seems that for now my only solution is to use the VESA driver with no 3d support.

Oddly enough I remember trying an early RC of 11.0, I think the nvidia version driver at that time was 160* or 169*, and I do not remember having any problems with my resolution being stuck at 640x480. It is probably worth noting that I had installed Sabayon on this same PC with the same problem. Hence why I think it is an nvidia problem.

I can open the Nvidia Server Settings Control, and the highest resolution option I have is 604x480 there. I think it is possible that the newer nvidia driver is not properly detecting displays connected to DVI rather than an analog signal. I will test this very theory tomorrow night when I get home from work, but stitching out my DVI cable for the analog one.

Any other information anyone else has on this subject in the meantime is greatly appreciated.

  • Heeter,

login as root.

init 3
sax2 -r -m 0=nvidia

to force the NVidia driver into the configuration. If that doesn’t help, please post your xorg.conf content here.

Uwe

Did you get 640X480@16 colours or did you get far more colours? The 640X480@16 colours is DOS or Windows9X compatibility that is terrible.

My suspicions about the DVI vs Analog connection are now confirmed.

Last night I setup for a completely fresh install of openSUSE 11.0 with my Viewsonic LCD monitor connected via an analog cable.

This morning I installed the latest nvidia driver, and upon reboot of the machine everything is working fine with the nvidia drivers installed. The thing I now notice is that in the Nvidia Configuration manager it is now properly detecting my Monitor as a Viewsonic VX2035. All attempts prior to this install had the monitor listed as generic. It did not matter what I set my monitor to in Sax.

Now the question is how to get this to work while connected to DVI.

My current xorg.conf looks like:

# /.../
# SaX generated X11 config file
# Created on: 2008-09-16T01:15:53-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "type1"
  Load         "extmod"
  Load         "dbe"
  Load         "freetype"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "11"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Microsoft Wireless Intellimouse Explorer 2.0"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  340 270
  HorizSync    30-66
  Identifier   "Monitor[0]"
  ModelName    "1680X1050@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1680x1050"
  VendorName   "--> LCD"
  VertRefresh  50-61
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "GeForce 8600 GT"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option "Composite" "on"
EndSection

I am scared to simply try to switch to the DVI cable as I am afraid it will blow up. Last night I tried switching to the analog cable, and after editing my xorg.conf file to change the driver to nvidia from VESA, upon reboot I was greeted with my monitor shutting down saying No Signal Analog.

Sorry if it seems I am hijacking Heeter’s thread, it just seems that he and I have similar problems.

What resolution do you need for your monitor?

You are not going to blow anything up switching back to the digital output, provided you do it when the computer is powered down.

You get nothing when you use the digital output? See what you get and take it from there.

Hi guys,

Here is the xorg.conf. For all it’s worth, my monitor is an ACER AL2216W


# /.../
# SaX generated X11 config file
# Created on: 2008-09-16T18:28:12-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "12"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Logitech USB Receiver"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  HorizSync    31-48
  Identifier   "Monitor[0]"
  ModelName    "1024X768@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Device"
  BoardName    "GeForce 8600 GT"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVIDIA"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Thanks

Heeter

Heeter. Is your Acer connected via a DVI cable, or the VGA analog cable? If it is connected via a DVI cable if you have one try connecting with an analog cable.

The above is what fixed my resolution issues, and for the time being is the only thing that worked. What worked for me:

Connected my Viewsonic with a DVI to VGA converter to my 8600GT then to the VGA analog connection on the monitor

Fresh install of openSUSE 11.0

Install the latest nvidia drivers using the One Click install from opensuse.org website.

Reboot and I was fine, currently running at my monitors native 1680x1050 resolution. Note the NVIDIA X server settings control panel lists my monitor as: Viewsonic VX2035wm (which is correct). What is not correct is the rest of that line: (CRT-0 on GPU-0). Take note the CRT… This is an LCD monitor.

To humor myself and to find out what would happen… I shutdown the computer, then I reconnected my monitor with the DVI cable. After powerup… back to 640x480 with no option to change to a higher resolution. As far as I can tell this is a problem with the nvidia driver itself.

Hope the above works for you, it is the only thing that has worked for me with the exception of using the VESA driver which is not an option for me.

Have either of you guys tried going in to the terminal and typing nvidia-settings and seeing what options are in there for changing the resolution of the DVI output?

Just a thought . . . .

Hi Foresthill,

I have been in there already.

Maybe it was a OpenSuse update that did this?

Could it be?

I have taken a few updates in the last few days.

Gonna try the vga cable in a bit.

Heeter

FYI, your kernel version has to match the version of your Nvidia driver.

So if you the correct install one-click Nvidia drivers they will be fine. But then if you update your kernel there will be a mismatch between the Nvidia driver and your kernel version. This causes untold misery and people need to be aware of it.

I don’t know if this is your problem, but look into it, and if so, use the Nvidia installer next time (just be sure to install the dependencies forst and uninstall your old driver) because it will build a correct custom driver for you no matter what kernel version you are using.

However you do need to run the installer again after kernel updates, but it’s a good thing to know how to do.

Well I tried the VGA cable it is now 1024 x 728, still nowhere near where I was at.

These resolutions are giving me a headache looking at this monitor.

Heeter

Thanks Foresthill

How can I compare the kernel and nvidia driver version? What am I looking for?

I will run a nvidia update through Yast and see if that helps.

Thanks

Heeter

Your kernel version is listed in the My Computer window in KDE. There is probably a terminal command to find your kernel version, but I don’t know it.

The Nvidia driver version should be listed in Yast if you search for “nvidia” and look at the driver details. There is probably a terminal command for that too, but I don’t know it.

I would strongly suggest using the Nvidia installer rather than Yast. Sometimes you can get the wrong version if you trust Yast and the repos to figure out which version is correct. At least, I have heard of these mixups happening, so I stick with the installer.

Great Thanks will use the 1 click installer, if available.

Will go looking for it now.

Hopefully this helps.

This blurry screen is so annoying.

Thanks

Heeter

Not the one-click installer, that’s even more unreliable. This is the installer I’m referring to:

Unix Drivers Portal Page

Okay Thanks Foresthill,

Heeter

Hey Guys,

Anyone have any other ideas with my problem, I still cannot get it to the resolution that I need. Tried everything noted above.

Looks like I might have to reinstall the os.

Thanks

Heeter

Hi
I always use the proprietary nvidia drivers (the hard way). Have you
loaded the inf file of the cd that came with your monitor when running
sax2?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 9 days 3:41, 1 user, load average: 0.65, 0.18, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12