STUCK!!! 10.3 Gnome throwing me off- missing

I’ve installed Opensuse 10.3 Gnome version using the install CD download.
Things were fine until I tried to play audios and videos. The videos would not run no matter what updates were performed. The audio was noisy and grainy. I went to the control center and checked up the device configs and it showed some xxxx driver. My sound card is a realtek HD audio. I pulled down the list and it showed an RTL driver also,so I chose it and tried to run the audio, no luck again. So I goto the Realtek site and download the drivers for linux and run the install scripts. This shitty software, uninstalls all the drivers and then builds the realtek thing and tells me that it cannot find a compatible soundcard (which is BS) and simply disappears. So now, there’s no sound driver available. I think it’s no big deal and shutdown. Later when I start openSuse, it logs me off and tells me that it was unable to load the object or whatever.
I’m a linux beginner and have no clue what it’s talking about but guessing around and a little bit of reading tells me it’s complaining because of the missing libasound libraries that the gnome-session uses. I try to find the configuration files used by gnome-session but don’t find any reference to this. Probably loads from a default setting.

Now I’m stuck, it won’t let me log on except in a failsafe terminal mode and in this case, no external drives are recognized and my PPP connection cannot be started because I don’t know if u can, and if so, how?

So what can I do now? How do I reinstall the sound drivers? What should be my course of action? When I boot up from the CD, there’s a rescue operation that can be attempted, but it only gives me a command line. How can I use this? There’s no repair installation option available!


Hi! I had a problem with sound device on SuSE10.3.

ASUS P5GC-MX/1333 CD came with linux drivers as well… I’ve installed LAN driver, but it took me 7 days to install audio.

My problem was with driver that is supplied on manufacturer’s CD. It was no good, so after 7 days, I have downloaded the latest stabile version of ALSA Project driver. Compiled, installed… it’s all good now ::smiley:

My recommendation is to remove the realtek drivers, and stick with the alsa drivers.

There is an audio troubleshooting guide you follow, but it is on the basis there are no realtek drivers “messing up the works”. So remove those drivers!
SDB:AudioTroubleshooting - openSUSE

Reference your video not working, this could be because:
a. you don’t have the codecs, or
b. you have your video player set to the wrong video output module, or
c. the file you are trying to play is corrupted, or
d. you have mixed multimedia libraries / applications from different sites that are not compatible with each other.

Thread moved to Install/Boot/Login