Struggling with Samba

I want to be able to share files with a Mac machine on my home network and decided to try Samba since that’s one of the standards on the Mac. I ran jdmcdaniel3’s script and it seemed to run to completion. When I run SMB, Dolphin starts and asks for login credentials. I tried my user login which didn’t work, so then tried root’s login which also didn’t work. I then added my login via smbpasswd but still can’t login. What am I missing? I’m on release 13.1.

What version of Samba do you have installed? J C McDaniel’s script relates to 3.6.3 which has been superseded by 4. Also the script relates to Windows which cannot handle Unix permissions.

In order to help you, we some information/clarification:

  1. Which computer is the SMB server? I guess that it’s the one with openSUSE, but this is only a guess.
  2. What do you mean by “When I run SMB …]”, are you talking about Samba deamons (nmb and smb)?
  3. Next, what do you mean by “Dophin starts”, does it pop-ups?
  4. What is the content of the file /etc/samba/smb.conf?

As a side note, have you checked that you firewall is configured correctly? You can do it easely using YaST. It shouldn’t be the cause of the problem according to your description, but we never know.

Thank you all for replying. I have decided to abandon Samba because I don’t know enough to configure it, I don’t have the time to work through the learning curve and can accomplish what I want to do through my Windows virtual machine. It’s a whole lot easier. Eventually, I’ll get back to Samba simply because it’s something I’d like to get a handle on, but not now.