Streaming Audio Doesn't Work

I have just switched to openSUSE 11.0 with Firefox 3.0. I can no longer listen to my favourite radio stations. Is there some plug-in that I need?

Depends what website or audio / video is being streamed.

Try installing from Yast 2 (you probably need the packman repositories enable)
& the mplayer plugin

or easier

and search for


this is an mplayer browser plugin and will install everything else it needs - including mplayer

I got the gecko-mediaplayer. This only had Mplayer. I got the plug-in through yast. It still doesn’t work. It looks like totem is running interference. Should I get rid of the totem plug-in?

either remove totem or go through firefox configuration and set which plugin to use from there.

The things you need to make it work

Mplayer (packman in yast)
Gnome-mplayer (in yast - not 100% sure that name is correct as not at my Opensuse com at the moment)

Thank you, I did get this to work. I had two copies of Firefox open and therefore when I first tried it didn’t work.