Strange Unresponsivnes

I am having a strange problem with applications randomly becoming unresponsive in openSuse Leap. The symptoms are as follows:

Window buttons don’t work (minimize, Maximize and Close)
Can not move window
Sometimes I can move the window and in that case, buttons become responsive again.
Toolbar is not working.
Dragging the cursor over buttons on the toolbar and window will highlight the button but it does not register clicks on the button.

When it happened to me while running Firefox, browser window (inside of the browser) works and I can scroll and type inside the web page but I can not interact with the toolbar, start button or the application window.
Keyboard shortcuts for the browser work. After a while, it randomly started working again.

When it happened in YaST I was able to click on items inside the program. I could start things like software management but those would not react to my mouse. I could TAB through items and tab to the “Close” button to get out. Sometimes, clicking on one of the module windows would just bring YaST to the font.

I experienced the same issues in both GNOME and KDE. I reinstalled a few times and tried installing with GNOME only but had the same issue.

System Specifications:
Intel Core i7-3770
32 GB DDR 3 (Corsair)
Asus Maximus V Formula motherboard with onboard network adapter
nVidia GForce 770
Edirol UA-25EX audio interface
240 GB SSD with Windows 8.1
240 GB SSD with OpenSuse Leap 42.1
1 TB HD for Data
1 TB HD for Backup

I installed the same version in a virtual machine running under Windows 8.1 and did not experience the same problems.

I’m new to Linux and don’t know much about it beyond what can be figured out by interacting with the GUI.

Any ideas on how to correct this would be appreciated.

Seem like possible you have a Optimus based Notebook. You need to NOT install the NVIDIA driver and install bumblbee. Also be sure you are fully up to date

It’s a desktop.

You fully up to date?. Since ther was a fumble in the updates today I’d wait until tomorrow to get any you may not have

Nothing got updated as far as I know. I downloaded the image about 2 weeks ago and have been using that version since. I installed and reinstalled a bunch of times trying to get it to work. Last time I installed was this Sunday.

Normally you are notified do you have a working internet connection??

You can do as root

zypper up

to get the latest fixes

I have a working internet connection. I do not understand the part about the root. Am I supposed to go to the console and type in “Zypper up”?

I just spoke to a colleague of mine to whom I have given an openSuse Leap CD to install on his home computer and he is having the exact same problem with the mouse clicks not working at random times.

2 things
#1 there is a known bug with nouveau and plasma 5 so you need to install the nvidia propitiatory drivers or use a different desktop like lxqt or lxde or pick one

sudo zypper ar -f nvidia
sudo zypper in x11-video-nvidiaG04

#2 there have been a ton of updates since the original opensuse iso was made so do update, and yes you need to be root to install updates, you can become root by executing su - or using sudo, so do

sudo zypper up

I did not install Plasma 5 and I was having the problem with GNOME installed. I tried the things you suggested but none of them worked. I tried adding KDE since I didn’t like GNOME and that wrecked the system. After trying to log in into KDE I was greeted by a black screen with a mouse cursor and I couldn’t do a thing. Restarting didn’t help.
I’ll try installing tumbleweed tomorrow before moving on to another distribution, if tumbleweed is as unstable as Leap.

don’t do that, on a side note what cpu do you have, some intel chips have build in gpu’s using nvidia drivers on i3/i5/i7 breaks the system unless you set your preferred card as the external one, it’s done in bios, so if you have en i-processor go in bios and set nvidia as the preferred card (check your manufacturers info)

It’s Intel Core i7-3770 and it does have built in graphics, but I also have a GTX 770 that I am using. I’m not connected the the video out on the motherboard.

I already wiped the HD and will try tumbleweed when I get home from work.

that’s the reason for most of your problems, it doesn’t matter where your monitor is connected if the intel card is set as the preferred one in bios it’s the one that will be used, and I really wouldn’t recommend tw for a stable machine or a new user specially when there are no prebuild video drivers for it and you’ll have to build and install the nvidia drivers manually, it doesn’t matter what distro you try the Linux video stack is the same for all of them, go in bios check what is your preffered video adapter if it’s not set the external one as the preferred.
How did you install plasma 5 did you use the DVD as that iso is way too old you could have mixed packages.
when in grub there is an advanced options to select, does it have multiple kernel options, maybe an update broke something can you boot an older kernel, if not can you get to text mode ie run level 3, if you can post the output of

zypper lr -d

if you can get in text mode try and execute

zypper dup

here’s an older youtube video about setting your preferred video adapter in bios

if you can get to the login window I’d suggest installing lxqt as it is a small light desktop which you can use to fix plasma 5 and/or gnome

zypper in patterns-openSUSE-lxqt

the black screen suggests a video driver issue and the gnome unresponsivnes is to be expected when using intel’s gpu chip or novou as gnome uses a lot of graphic processing and needs better hardware acceleration

The last attempt at installing was with GNOME as default. I added KDE through YaST Software management by adding the KDE package. That worked fine for adding other desktop environments on previous installs where I selected KDE as default.
I’ll check the BIOS settings before reinstalling (I have to do that since I wiped the HD last night).

Thank you for all the suggestions.

I’ve never done this as I use ext4 and that’s why I just thought of it, if you installed with the default btrfs file system you should have an option in grub to boot to an older snapshot, if your system does not boot use an older snapshot (it’s kind of like system restore on windows except it’s not software but file system kind of hardware based) before formating and reinstalling try snapper
this isn’t my snapshot I found it on the web

after you boot in your previous state please give us your repo list

zypper lr -d

I did try that, and I was logged back in under GNOME. But when I restarted normally, I was back at the black screen. I ended up wiping the hard drive later.
I just re-installed Leap again with KDE as default. It started freezing right away. I managed to log out and log in under IceWM and this has been working without problems so far but it is hardly the best GUI to work with.

I’ll try a few other Desktop Environments to see which ones work. So far I know for sure that GNOME and KDE don’t work properly. Buy now that I know that I have at least one option where I can work in and try to fix things without random freezes, I’m more inclined to work on sorting things out.

To go back to your previous post, Bios setting was on AUTO and changing it to external graphics card did not resolve the issue.

after setting it to auto you need to install the nvidia drivers as novoau has issues with plasma 5, in the mean time you can install lxqt it’s small and imo prettier then IceWM

zypper in patterns-openSUSE-lxqt

edit as a new user you might be better off using yast
start yast, select software sources, click add, select community repo’s, check nvidia and packman (packman is needed for multimedia)
then start software management yast will select the proper nvidia driver so now just click next and nvidia will be downloaded and installed.
ps the driver needs gcc and a few other development tools

ps ps I don’t know if nvidia keeps old drivers as they are kernel related so when the kernel is updated the driver is also updated and LEAP had 3-4 kernel updates so it might be a good idea to first update your system before installing the driver as that might have been an issue if you installed a newer driver and had the old kernel.
the easiest way to update is by using zypper

sudo zypper up

after updating do what I typed above and install the driver

2nd edit
to be clear there have been a lot of changes in LEAP since the iso was published so
1st update your system
2nd install nvidia drivers
3rd switch to packman to get full multimedia support (but that’s for another thread)

This did not work from the Console but I found the nVidia driver using the YaST Software Manager. Am I supposed to remove the nouveau before or after I install the other one?

Just saw your post while I was installing the nVidia drivers.
The drivers are installed now. I’ll log out and test KDE now.

FYI do not remove or mess with the nouveau The NVIDIA install will deal with it.