Strange Repository update behavior

(I am adding dates (USA-EST) in case this is known-in-timeframe related)
On Friday Dec 3 I decided to try the new Digikam 1.6, downloading and installing from SuSE Factory repo. This dragged along some KDE4.5.80 (aka 4.6 beta1) dependencies. My system ran for a while, then would not reboot kde. After some helpful dialog here in the forum, I executed

zypper dist-upgrade --from #SuSE_Factory_repo

and was able to get a usable KDE4.5.80 session.

While Digikam 1.6 ran, there were too many other flaky aspects of this beta build so on Saturday Dec 4 I decided to downgrade back to KDE4.5.4.
I ran

zypper dist-upgrade --from #SuSE_kde45_repo

and the fun began.

The first time it ran, some 20+ of the 170+ packages that needed update(downgrade) reported checksum errors and corrupted files, which I skipped over.
On Sunday Dec 5, I ran the upgrade again. The first time, 6 of the 20+ files failed with similar checksum issues, but on a second execution all downloaded and installed.

The download speeds reported were good(or better, some at 8MBps).

I have not seen this behavior before - usually if a Repository is on-line, the process works flawlessly.

Any thoughts or ideas?

cmcgrath5035 wrote:
> Any thoughts or ideas?

since all code in factory is unreleased 11.4 software, you should ask
in the forum where the other beta testers hang out, here:

they are the ones most likely to have encountered problems with beta
software and they can help you log the bug you found while testing…

btw, you do know not to put factory code on your everyday user
machine/system, right?

last week there was a version of kmail there that ate all your
email…so, backup and move slowly around the factory floor… :wink:

CAVEAT: [posted via NNTP w/openSUSE 10.3]

Thanks; yes I am aware of the perils of Factory.
I am not so concerned about the 4.6beata issues, I just don’t have the time at the moment to deal with them.

I am most curious about the flaky (error prone) download from the stable KDE45 repo.

cmcgrath5035 wrote:
> I am most curious about the flaky (error prone) download from the
> stable KDE45 repo.

still curious?

i can’t imagine why since KDE4 has been both flaky and error prone
since before first release right though to tomorrow (yep, the
unreleased is also flaky and error prone)…

CAVEAT: [posted via NNTP w/openSUSE 10.3]

Thanks to the OpenSUSE team for the excellent implementation of IceWM!

< Haven’t been able to load KDE since yesterdays run at -up

In my case down grading from NVIDIA 260.19.21 to NVIDIA 256.53 got KDE 4.5.80 (4.6 Beta1) loading again. Seriously not fond of the 260.19 driver gave a lot of artifacts besides corking KDE.