Strange problem with Powerdevil


I’ve migrated (finally) to 11.2 and since few days I’m observing a strange problem with powerdevil:

  1. on the battery icon there is an empty profile appeared and powerdevil claims all the time about… (and I don’t have any empty profile if I edit them)

  2. any profile I choose - it changes absolutely nothing! - the only brightness bar is active and really changes screen brightness…

  3. if I click on “Hibernate” nothing happens either… But there is no problem to hibernate from the shell with “powersave -U”

Any idea how to fix it?..


Did you start with a New formatted /home user account? If not it may be some crud from the past.

Anyway - you could try deleting these hidden files


Logout and back in

The /home was recreated by 11.2 and then I migrated application by application all data…

Why need to delete powerdevil rc files? they looks correctly as well they recreated every time if I edit them via power save interface - is there a way to restart powerdevil without log out? (I have many active windows for the moment and prefer to not stop them)


I probably don’t know why I suggested that:) so:
Advice given, take it or leave it.

Don’t take it bad :slight_smile:
I just want to understand what’s going wrong :slight_smile:

(as well I don’t like to reboot and logout - only hibernate :slight_smile: my 11.0 laptop worked over 2+ years without any reboot nor logout :-))

So all those kernel updates never applied.

Those files are just config files, but deleting them will force them to be re-created, without any possible crud in them.
If this didn’t work, I would tell you next to create a New User and login there and see if it is the same.

So far,

  • logout, rm .kde/share/config/powerdev*
  • login…

after login no profile in battery widget

then, clicking on “more” brings to the profile editor

there is only one profile available - “Performance”

trying to change anything on it and “Apply” pop-up error notifications about empty profile!

still no profile shown on the battery widget…


  • logout again
  • login

there are 2 profiles on the battery widget:

  • empty
  • performance

any idea?..

now will try with a new user…

Post result of

zypper lr -d


rpm -qi kdebase4-workspace

With a new user the problem is the same…

# zypper lr -d
#  | Alias                                                                  | Name                                                                   | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service       
1  |                                        | openSUSE BuildService - KDE:Backports                                  | Yes     | No      |   99     | rpm-md | [Index of /repositories/KDE:/Backports/openSUSE_11.2](             |               
2  |                                        | openSUSE BuildService - KDE:KDE4:Community                             | Yes     | No      |   99     | rpm-md | [Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2](       |               
3  |                                           | openSUSE BuildService -                                 | Yes     | No      |   99     | rpm-md | [Index of /repositories/](     |               
4  |                                       | openSUSE BuildService - Virtualization (VirtualBox)                    | Yes     | No      |   99     | rpm-md | [Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.2]( |               
5  |                                            | openSUSE BuildService - Games                                          | Yes     | No      |   99     | rpm-md | [Index of /repositories/games/openSUSE_11.2](                      |               
6  |                                           | openSUSE BuildService - Drivers for webcams                            | Yes     | No      |   99     | rpm-md | [Index of /repositories/drivers:/webcam/openSUSE_11.2](            |
7  |                                                     | Packman Repository                                                     | Yes     | No      |   99     | rpm-md | [Index of /pub/packman/suse/11.2](                                         |
8  | [Index of /repositories/KDE:/43/openSUSE_11.2](        | [Index of /repositories/KDE:/43/openSUSE_11.2](        | Yes     | No      |   99     | rpm-md | [Index of /repositories/KDE:/43/openSUSE_11.2](                     |
9  | [Index of /repositories/home:/illuusio/openSUSE_11.2]( | [Index of /repositories/home:/illuusio/openSUSE_11.2]( | No      | No      |   99     | rpm-md | [Index of /repositories/home:/illuusio/openSUSE_11.2](              |
10 | repo-debug                                                             | openSUSE-11.2-Debug                                                    | No      | No      |   99     | NONE   | [Index of /debug/distribution/11.2/repo/oss](                      |
11 | repo-non-oss                                                           | openSUSE-11.2-Non-Oss                                                  | Yes     | No      |   99     | yast2  | [Index of /distribution/11.2/repo/non-oss](                        |
12 | repo-oss                                                               | openSUSE-11.2-Oss                                                      | Yes     | No      |   99     | yast2  | [Index of /distribution/11.2/repo/oss](                            |
13 | repo-source                                                            | openSUSE-11.2-Source                                                   | No      | No      |   99     | NONE   | [Index of /source/distribution/11.2/repo/oss](                     |
14 | repo-update                                                            | openSUSE-11.2-Update                                                   | Yes     | No      |   99     | rpm-md | [Index of /update/11.2]( 


# rpm -qi kdebase4-workspace
Name        : kdebase4-workspace           Relocations: (not relocatable)
Version     : 4.3.1                             Vendor: openSUSE
Release     : 7.5                           Build Date: Mon Nov  2 17:52:39 2009
Install Date: Tue Nov  3 01:59:37 2009         Build Host: build20
Group       : System/GUI/KDE                Source RPM: kdebase4-workspace-4.3.1-7.5.src.rpm
Size        : 31576329                         License: GPL v2 or later
Signature   : RSA/8, Mon Nov  2 17:55:54 2009, Key ID b88b2fd43dbdc284
Packager    :
URL         :
Summary     : The KDE Workspace Components
Description :
This package contains the basic packages for a K Desktop Environment

    The KDE Team <>
Distribution: openSUSE 11.2

I did not upgrade yet to the KDE 4.3.4

These are the repo’s I recommend for now:


kde4 stable desktop
Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2

kde4 stable community
Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2

Make sure they are all enabled and have Refresh ON!

Now first run Updates, there will be a few!

Next do this for the new kde desktop and community:](

When that’s done do this in Packman:](
This assumes you have followed this too
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Last question before I’ve started upgrade:

what is the difference between
Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2
Index of /repositories/KDE:/43/openSUSE_11.2
repositories?.. does one or other have a more “official” status?

And also does upgrading from zypper

# zypper dup -r "kde4_stable_desktop"

will apply the same actions as if I switch system repo via Yast? (I ask it because seems there are many post about problems during KDE upgrade from the live KDE session, so upgrade from the system console will be more safe probably…)

Thank you!

There is no huge difference between the repo’s - I just gave you the ones that will be officially supported long term, I am unsure about kde43.

There are no issues using Yast as I demonstrated, and that is what I suggest you use. But, yes the zypper code looks correct assuming that is the correct alias. I think you can use the # also
Eg: zypper dup -r 6 (where 6 is the repo number of the repo in question)

I gave you the instructions in an order too, doing Packman last. As this will switch packages like k3b back to packman which is what you want. You can actually sort this in different ways, I was just trying to make it simple. I think I know what I’m on about so you should be ok.

So far, I’m running KDE 4.3.4 now,
but the problem is still the same! :slight_smile:

  1. Battery widget still finding an empty profile from don’t know where
  2. Any action in battery widget doing nothing - even profile is not changing from selected… Only “more” button brings you into the profile editing :slight_smile:
  3. While editing profiles Powerdevil claims there is an empty profile selected and it has no idea how to manage it…

Any idea now?..

Are we talking here or in the main sys setting side or both](

The feeling I have here is that Battery widget has some problems to communicate with Powerdevil…
I think the main problem is that choosing profiles from the widget is changing nothing! - it’s likely it sent nothing or Powerdevil did not receive any order…

Finally, what I’ve done - I’ve reedited manually my .kde4/share/config/powerdevilprofilesrc file and duplicated an existing profile and gave it the empty name (just ]) - after restarting KDE I don’t see any empty profile anymore within a battery widget, but it doesn’t choose any other profile either (I mean, you see there is one profile selected, but it changes nothing :-))

Is there any other widget/etc able to communicate with Powerdevil?..

The feeling I have here is that Battery widget has some problems to communicate with Powerdevil…

I’m not aware of any issues. But you could check bugzilla:

Is it the same in System Settings - Advanced - Power management

Have you tried removing the Battery Widget then adding a new one?

As you remember, I’ve removed all profiles before…

Then I’ve created 2 new one, just for testing - both are appearing within a Setting-> Advanced-> Power management (as well via Battery-> more…)

Removing and re-adding battery widget did not help.

As well an “empty” profile came back again :slight_smile:

But again, the most important it doesn’t produce any action via Battery widget, so I may only remove it and seek for something else :slight_smile:

I’ve found “cpufreq-set” to manage CPU powersaving modes and “kosd” to manage screen brightness. Then for hibernate a simple shortcut to “powersave -U”.

If you know any other tools/widgets which may help here - please, let me know! :slight_smile:

Thank you!


On my Laptop I had to switch from the Desktop Kernel which is what SUSE installed by default, to the Default Kernel. This was due to powersave issues, though not quite like yours.
It could be worth a try, if you are on desktop kernel why not remove it and try default.

You could try the kde4 livecd, it has a few different settings than the DVD. If it works you just have to check it’s config.