Strange message at boot

When I boot my computer I get this message straight after post. This appears on a black screen with white print nothing else:

Press t to show menu content

I have not pressed the button, because if I wait about 20 seconds the blue screen pops up as usual.

What menu is this message referring too, is there something wrong?

There are no errors showing in the boot log

Thank you, for your help

There’s a line in “/boot/grub2/grub.cfg”

echo "Please press t to show the boot menu on this console"

Is it possible that is what you are seeing?

For me, that line disappears in less than 1 second (except in one case, which I will describe later).

I never noticed that message until recently, because it disappears so quickly. However, I was debugging a problem in a KVM virtual machine. And it was suggest that I attach a console. A console is just a terminal window where I run a command to attach it as a console to the virtual machine:

virsh console virtual-machine-name

So I booted up my virtual machine. And then, moments later, I ran that command to attach a console. So I’m looking at the main virtual machine viewer, and I’m looking also at a emulated serial console in an xterm.

The grub menu shows up on the main viewer screen. And that serial console in the xterm gets that “Please press t …” line.

So I presume that if I press t in that xterm window, I will also get a grub menu there, and I can do everything at a serial console.

That’s when I first noticed the “Please press t …” message. I’m now more aware of it.

So I think it is just grub2 giving you alternative options on where to see the boot menu.

Now that one case with a long delay – that was also in a virtual machine. And it took several minutes before that “Please press t …” line showed up. That’s the only virtual machine where I am using “btrfs”. My guess is that there was something strange about the state of the “btrfs” file system, such that grub2 had to do many I/O operations to get to the menu. And that took a while. It has not happened since then on that virtual machine.

Thank you, nricket

Judging from what you say, it is not something I have to concern myself with. However, I am not using any virtual machines.

Yes, that’s right – there no reason for concern about this. I’m just a bit surprised that it takes 20 seconds.

However, “grub” uses BIOS services, and your BIOS might be slow for reading disks.