Strange kmix behaviour

kmix appears to be running all the time, even when there is no other sound application running, and taking 100% of the processor. This can’t be correct as other running applications don’t seem to slow down.

Any suggestions? Thanks.

:~> top
top - 06:40:53 up 54 min,  3 users,  load average: 1.00, 1.03, 1.01
Tasks: 131 total,   2 running, 127 sleeping,   0 stopped,   2 zombie
Cpu(s): 51.9%us,  2.3%sy,  0.0%ni, 45.1%id,  0.0%wa,  0.0%hi,  0.7%si,  0.0%st
Mem:   4055648k total,  2379948k used,  1675700k free,    42600k buffers
Swap:  2111484k total,        0k used,  2111484k free,  1677496k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                              
 3859 ion       20   0  816m 191m  18m R  100  4.8  53:24.64 kmix                                                 
 3861 ion       20   0  726m  90m  63m S    6  2.3   2:42.40 ktorrent                                             
 3828 ion       20   0  654m  42m  27m S    2  1.1   0:55.93 knotify4                                             
    1 root      20   0 12460  784  644 S    0  0.0   0:00.61 init                                                 
 4416 ion       20   0  456m 112m  28m S    0  2.9   0:32.22 opera                                                
 4572 ion       20   0  421m  33m  18m S    0  0.9   0:01.88 konsole   

In an older version of KDE this was discussed … whether this is applicable to you is not possible for me to tell from your post given no mention of the openSUSE nor KDE version (we need to find a way to force users to post that information - else some of us just waste our time posting on a thread where we know nothing because our information is relevant to a different openSUSE/KDE version).

Anyway, take a look here: Kmix eating up all available CPU time on one core • KDE Community Forums Where in that thread they noted every time reboot, need to kill kmix as it is using 50% of the available processing power. This usually translate to an app using 100% on one core.

The work around they adopted was to send in a terminal:

killall -9 kmix
rm -rf $(kde4-config --localprefix)/share/apps/kmix/
rm -f $(kde4-config --localprefix)/share/config/kmix*
kmix &

whether this is relevant to you, I don’t know. I hope thou that my having taken the time to research and post this was not wasted. …

Good luck.

My apologies. I have added the information to my signature, something I avoided in the past due to having used different versions on several different computers.

Thanks again. I rebooted and this seems to have solved the problem. Since I use pavucontrol to adjust my volume is kmix even necessary?

I have the same problem, on 11.4 64b KDE .
Removing the config files and directories solved the problem…