Strange Issue

Well, i have a double boot, Windows XP and OpenSuse 11.1 64 bits. Everything was working fine until yesterday when i changed from windows to opensuse, on the loading screen oh suse, the screen started flickering, after that, on the desktop, the flickering continued, but bisides that, suse just got stuck, i could move my mouse around but no thing else worked, couldn open any folders, or even start menu.

Any help would be greatly apprecitated.

PD: if its of any use, i use an AMD Phenom 9500 and an ATI HD2600xt, also, windows works perfectly and i dont think the video card is failling, since games work perfectly on XP

Did you already boot openSUSE before ? Was it ok ?

I’m far from a Linux wizard, but to me, it seems Xorg is badly configured. (Someone with better knowledge can correct me.)
Have you tried to boot in Failsafe mode ? Run Sax2 ?

yup, opensuse was working perfectly, already have ati graphics drivers installed, etc.
It worked maybe… 5 days since a fresh install.
And no i havent tried failsafe. Should i ?

So no, I was probably wrong. It’s not a Xorg configuration problem, but maybe a driver one.
Have you done (or did you accept) an update after that ?

Browse the forum for driver / kernel updates. It seems there are some issues recently about updates for 11.1 (Sorry I can’t help here.)

nope i didnt do any updates

what should i do ? :S

and no, failsafe wont loud either, i just end up with a black screen.

Let’s try switching your video back to vesa, at least for the moment, and then we’ll look at making sure your system is updated and re-install your graphics driver.

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=.
Remove all text and now type just the number:
and hit enter
at the login type your user name and then password
now type:
then the root password
now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)
now reboot
if you don’t get a gui login
login as user and try this at the cli

If this does not work, we have other options.

ill try this, thanks

ok, did what u told me and got this:

SaX: initializing please wait
SaX: Your current configuration will not be read in

SaX: no X-Server is running.
SaX: will start own server if needed
SPP: prepare device [0] profile: FireGL.addon

Didnt know how to reboot so i just pressed the reboot button. It didnt work, still was getting flickering and the desktop was freezed

It should of given you a configuration screen did it?

After accepting, it will take you back to where you started from, then type reboot.

no i didnt see any configuration screen, last thing i recieved was


Did you do an update last time you where in Suse?

If unsure perhaps have a look at at

rpm -qa --last | less

The other place would be a look in the

cat /var/log/SaX.log


grep EE /var/log/Xorg.0.log

The the other is to perhaps post up your xorg.conf

As only command line, hopefully you’ll have the network even though you haven’t got X.

cat /etc/X11/xorg.conf | curl -F 'sprunge=<-'

Note the url and post a link to it, it will be something like if no network try rcnetwork start

where should i write all those things? repeating the steps , deleting VGA=… ?

You haven’t done any steps if you haven’t got to the configuration screen.

The commands should work as user from the command line.Either get to a tty with ctrl alt f1 before it gets stuck or as before and use the 3.

But just to suddenly stop working normally has a cause.

Thinking about it, if 3 think you will need rcnetwork got a feeling runlevel 3 doesn’t start the network. This command will need su first.

Wait wait, that was too fast hehe. I did all the steps listed on the post, trying to get VESA working, but i didnt get any configuration screen, what did i do wrong? I ended up with (1) SaX:
Nothing more than that.
I use a dial-up DSL connection so i think it will be harder to get net

Not sure you have done anything wrong I agree if dialup maybe a little more problematic.

If you haven’t give the install media and repair system a try.

iirc start install but several steps into you’ll get install or repair choose repair. READ CAREFULLY

Still intrigued what caused it? If your not aware of an update and the monitor/Graphics Card works with another distro.

graphic card works perfectly so i would say it was probably an update, i usually update suse each time i use it.

Ill give that repair DVD option a try.

If the repair doesn’t work right of that bat, use as the repo and using the output from…

rpm -qa --last | less 

To replace the last few though would be easier and could give more specific advice if this could be viewed…

But anything related to x, kernel or graphics card.

yast will work from the command line after doing the 3 trick.

Ok, did the reapair and chose automic, only erros that it found were from the Boot GRUB i think.
The reapair sugested a 2 item reapair,

  1. Default Opensuse startup
    2)Failsafe Opensuse startup

There was no Windows option so i clicked on reread configuration from hard disk, which gave me the regular 3 item selection, Default, Failsafe and Windows.

So ir repaired and after i clicked on finish, i got a red error message saying installation went wrong and gave me the option to reboot, i rebooted and logged in Opensuse, same flickering and freezing.

Maybe i did wrong by choosing reread configuration from hard disk, but i didnt know how to add a Windows option to the GRUB