Strange Frame Artifacts with Gnome / Wayland / Nvidia On Tumbleweed


this is bugging me for a long time now and I can’t seem to find a cure. I hope for some tips on how to resolve this:

Some windows don’t show latest content or flip between two frames. Videos stutter and other strange frame effects. Some Applications don’t show up at all without QT_QPA_PLATFORM=wayland (e.g. NextCloud) some show up sometimes (e.g. Ardour, Chrome, …)

If I use the kernel command line parameter nosimplefb=1 that was automatically added, I only see a black screen, so I removed it. Other than that I’m not aware I do something special, just latest Tumbleweed with native Nvidia drivers from the community repos. I also tried nvidia-xconfig, but no change. Nvidia-settings just crashes on start.

I use Gnome with Wayland but that is not really my choice, for some reason Xorg sessions just gives me a terminal and some session types just silently return to the login screen.

I read somewhere xorg.conf Option “FlatPanelProperties” “Dithering=Disabled” might help: it didn’t.

In case it matters: Nvidia card is a 1650 Super.

@joba1 nvidia and GNOME with Wayland is still Work In Progress… I run on Xorg without issues.

This is a system with just the Nvidia card? I suspect you have created an xorg.conf at some point lurking in /etc/X11? Have you tried nvidia_drm.modeset=1 in the grub options which is what I use.

Thanks for the suggestion. I tried it and get only a text console, no session manager. Maybe it needs other settings that I don’t have.

I removed it again and get the xdm with many session types, among them 2 x Gnome, 1 Gnome on Xorg and 1 Gnome on Wayland. I dont know where they come from - I didn’t deliberately create them.

Gnome on Xorg and one Gnome start a single xterm without window manager.
Gnome on Wayland and Gnome sometimes return to the session manager, sometimes freeze on login (ctrl-backspace helps) and sometimes work (but with the described frame problems)

Yes I have several renamed copies of xorg.conf (earlier attempts to get a working setup). Currently one created by nvidia-xconfig works best.

@joba1 if you create a test user and login as that test user with GNOME on Xorg, what happens?

If that doesn’t work, can you paste your Xorg log;

susepaste ~/.local/share/xorg/Xorg.0.log

Paste back the… middle link

1 Like

Good idea! Seems to work fine!

Now what to clean up in my home directory without throwing away too much customization…

@joba1 so are you using shell extensions? If so could be an issue…

At some point I installed one extension that promised to undo the Gnome UI design BS to place activity corner and dash with max distance.
Not sure it is still there, it doesn’t work, so probably not. Will check later…

Hi Malcolm,

your second hint lead to the solution. Removed an old .xinitrc that somehow got incompatible to the current installation.

I also got rid of the hotedge extension - but only because it didn’t work anyways. It did not change the frame problem.