Strange Firefox Behavior in Opensuse

This is something I’ve noticed for a long time, but so far I haven’t seen any automatic fixes, so I come to ask. What happens to the Firefox version of Opensuse? Some pages do not load properly and appear to be broken.

Here an example using the forum login page. First we have the page loaded using Firefox on Linux Mint. Notice that i have tested the same page at Kubuntu, Manjaro, Fedora and Windows 10 and in all of them the results are the same below.

And here is the same page in Opensuse’s Firefox

Another example. Some sports blog at Windows 10

And the same page using Firefox on Opensuse:

Just 2 examples, but this happens with others sites too. Using Chromium or Opera this error does not happen, it is a problem of the Opensuse version of Firefox only.

Is there a way to fix this or is it a problem that only devs can solve?

One browser has uBlock running the other doesn’t…

If you notice well, the only one with problems is precisely the one without Ublock.

But, unfortunately, Ublock isn’t the problem, as I’ve used Firefox with Ublock on Opensuse and the issues persisted. I wondered if it was going to be something with KDE, but I did a test on a TW VM running under Gnome and the problem persisted.

Some sort of theming issue perhaps, I see it here on Tumbleweed, SLED 15 SP1 and Leap 15.1…

Notice the shield icon next to the pad lock (left of the websites URL), this is related to Firefox content blocking.
It’s only there on your problem cases.

Interestingly, I have content blocking set to “strict” and yet I do not have this problem on either page, and the shield is not there.
I also use uBlock Origin.

Firefox 68.0.1

I tried to disable all block contents, but no luck, all remains the same. But you post make me think of another test. I download the last Tor Browser who is based on FF 68.0 to see if the same problem happen. And, for my surprise, everything runs fine.


Did you try openSUSE’s FF with a virgin FF profile or a virgin user? How old is the openSUSE profile?

The pictures above are form a fresh install on a VM, but I notice this problem since June, at first time that I installed TW on my PC.

After poking around a bit at this…

I couldn’t find anything that’s certain.
But, I did notice that the openSUSE Firefox is several minor versions older than what I’m running on other platforms, so there could be substantial improvements to the Quantum rendering engine in later FF compared to what is in openSUSE. Here is the FF Quantum announcement

Not directly related but could be co-incidentally related and probably of interest to Users…
I noticed a few months ago on my other systems that Firefox now has its own ad-blocking installed by default,
But that’s not implemented in openSUSE… yet.
I suspect that simply upgrading the Firefox base version should resolve that and might fix the rendering issue as well.
On the other hand, this could be intentional(?) since google analytics is used by the SUSE web properties to analyze traffic and would be blocked by this new feature (possibly better solution is to enable ad blocking but create an exception for SUSE web properties, and include that in the installation licensing. Or, would this violate an openSUSE FOSS policy in some unknown way? Or, should SUSE finally use something other than Google Analytics?)


When you installed TW, did you reuse a /home filesystem used with some other distro? IOW, was the Firefox profile a virgin in June, or previously used with some Firefox other than TW’s Firefox?

Another test. At left the Opensuse default Firefox, updated today via zypper. At right, the newest stable bundle that can be downloaded and running out of box.

It’s definitely something with the standard version of Opensuse. One thing I noticed is that the Opensuse version uses the KDE filepicker, while all the others use the GTK standard. Maybe this modification made by Opensuse devs was the cause of rendering problems?

Fresh install.

If you switch to the upstream branding it should solve the issue

Probably a problem with style sheets and branding I’d guess

I see the same here on 15.1

Try removing the openSUSE branding package

I does not bother me so I’ll not try that here.

I was personally speculating

  • Possibly a rendering engine issue
  • A mistaken or accidentally removed tag that allows the footer background to spill beyond the intended object on the page.

Took a quick look using common browser Developer tools and didn’t find anything in the CSS or the object on the page approximately where the spillage happens.


And how I do that or what package should I remove? I’m new at this :shame:

su -

zypper in MozillaFirefox-branding-upstream

Accept the removal of

And… WORKS! Great.

And the best thing is the KDE Filepicker still works. Now is perfect.

Thanks so much, everyone. Just one more question. The removed branding will come back if I made a snapshot update?

Package locks serve the purpose of preventing changes to the set of installed packages on the system. The locks are stored in form of a query in /etc/zypp/locks file (see also locks(5)). Packages matching this query are then forbidden to change their installed status; an installed package can’t be removed, not installed package can’t be installed.

addlock (al) [options] package−name…

Add a package lock. Specify packages to lock by exact name or by a glob pattern using * and ? wildcard characters.

Locks can be added in Yast or zypper also

McCloud, it would be interesting to know if the problem recurs if you change either of the following settings via about:config in your Firefox urlbar:

layout.word_select.stop_at_punctuation (is false in upstream branding?)
browser.display.use_system_colors (is true in upstream branding?)

I would try it myself, but I only use ESR, and upstream branding.