strange error amule


then install and configure amule, when it starts to download a file get the following error:

Logger.cpp (275): Error: Impossible to set permissions for the file ‘/ windows/E/aMule/temp/008.part.met.backup’ (error 1: Operation not permitted)
Logger.cpp (275): Error: Impossible to set permissions for the file ‘/ windows/E/aMule/temp/008.part.met.bak’ (error 1: Operation not permitted)

The incoming and temp folder as shown are in a Windows partition and write permissions are the same.

Well, this is the line that corresponds to that partition:

/ dev/disk/by-id/ata-WDC_WD3200AAKS-00B3A0_WD-WMAT10501563-part3 / windows / E ntfs-3g users, gid = users, fmask = 133, dmask = 022, umask = 0, locale = en_US.UTF-8 0 0

I do not know what else to change.

Since I do not work with Windows, this is just guessing, okay?

aMule obviously tries to set unixoid file-permissions on a NTFS-partition, and in my opinion this can not work out since NTFS can not manage unixoid permissions at all.

There might be workarounds, but I am pretty sure you should set the download-path to your /home.

I do not understand, before using mandriva and amule had it configured and working well without any problem.

Opensuse why not, what is the difference?

Do not want to use my home for downloads of amule because I have well organized records and never before had problems

Opensuse why not, what is the difference?

Frankly: I totally have no idea. As I said, I am only guessing, and since the CLI-output is the only information we have so far, this is all I can refer to - and actually it all seems crystal clear to me: aMule needs to set permissions → those permissions (I am quite sure I am correct here) can not be set in a Windows filesystem → Bazinga¹. I might still be totally wrong of course, so I suggest backing up your ~/.aMule and try setting it up from scratch, once with the download-folder on NTFS, once with it being in /home, then compare the outputs.

One idea: have you imported your part.met.bak-files from Mandriva? Or your /home?