Strange effect when switching virtual deskops

I am running KDE Plasma on TW on a desktop PC with AMD integrated graphics. Just recently after an issue of my own making (managed to mount two disks with same label but not any system ones and PC crashed) it messed up my settings. Now I have got it 99% back as I want I am still left with a strange effect when switching virtual desktops by manually clicking on the one I want. As it switches between seeing the old and new desktop programs (which are in full screen on both virtual desktops) the desktop background flashes up noticeably and is rather annoying, now this did not happen before my self inflicted screw up and does not happen on my Laptop which also runs TW KDE Plasma and has Intel integrated graphics.

Any suggestions on what might have happened I thought I had all settings back as I wanted but maybe I’ve missed something?


Was emptying ~/.cache/ while logged out of Plasma part of your reconstruction? Strange things can happen when cache gets out of sync with settings.

No it rebooted OK just with some things messed up.


Next time, do it. Plasma easily gets confused by a cache that doesn’t match up with restored settings.

Toggle the compositor off using Alt-Shift-F12 and see if it still does it.

If it doesn’t:Then take a look at the desktop effects “System Settings -> Workspace Behaviour -> Desktop Effects” to see if anything in there has been enabled for the Virtual Desktops. (I tend to avoid “Desktop Effects” like the plague, but occasionally KDE developers add a new effect and tend to enable it by default.)

If it does still do it with compositing off:I’m afraid suggestions are very thin on the ground…

Either way, you can switch compositing back on again using Alt-Shift-F12

By emptying ~/.cache do you mean the whole directory or just those parts referring to plasma?


If you can tell which are only about KDE/Plasma, then do those. It’s just a cache. Its contents will be regenerated automatically if and when needed.

I have been trying to get back to the way my desktops switched before and the way they do on my laptop. So far no luck. I tested on my laptop turning on Slide as a desktop switching effect and saw how it work but when I do this on my desktop PC it has zero effect, it does not work as it should in fact no effect at all. So desktop effects seem to be broken or at least some. I tried turning off all effects but nothing I do changes anything on that series of settings! Anyone any ideas as to how to restore this functionality?


Check (KDE) “Settings -> Display and Monitor -> Compositor” to see that “Compositing: Enable on startup” is checked.

If there has previously been a graphics driver crash KDE automatically and silently disables compositing, (which is needed for all Desktop Effects).

I’m guessing this could be fallout from work on an upstream bug mainly affecting users of multiple displays. IIRC, virtual desktops exist in “containments”.

Well the strange thing is that following my zypper dup this morning for some 170+ fixes and a reboot my desktop is now behaving as it should with no flashing desktop picture appearing when I manually switch virtual desktops. So something resolved it but I have no idea what :dont-know: Message to self - Don’t mess things up to start with!