strange Canon CAPT problem

Got this strange situation with dependances…

Generic office PC machine (nothing specific to tell ECS MB with p35 chipset Intel Celeron 2.0, 20 gigs HDD, Combo drive)
Default OpenSUSE 11.1 32-bit instalation (updated from online repositories) fresh instalation from yesterday. Added development packages for kernel & C/C++ (for headers needed). Ghostscript included.

Downloaded Canon Capt drivers from Canon site (ver 1.8) needed for LBP 3100 laser printer.
Installed common package without problems.

CUPS-CAPT package has dependences issue: is missing is missing (GLIBCPP3.2.2)

Checked packages with YAST, installed …-devel package, installed …-obsolete package (for compatibility). GCC was 4.<something> i have even added 3.5 and 3.2 from official repositories. still dependencies issue remains.

I’m very frustrated…

Any ideas?

Ok if that was not enough here is more:

Unpacked packages to /usr/src/packages/SOURCE
manualy compiled common package without problems
(rpmbuild --bb <package>.spec)
manualy installed:
rpm -ivh <package>

Now compiling CAPT driver reports error with inconsistent function calls on several places (too big to place it here) and refuses to compile it.

Am i just doing something wrong or is it CANON making me go nuts.

Have a look at:
OpenPrinting database - Printer: Canon LBP3100
Canon LBB5100 Capt Driver x86_64 - openSUSE Forums
They may help. (Look at post 6 in the thread)
I should imagine something has changed and it’s not you but canon creating the problem.

Thanks for reply, i checked it, but still no solution.
I have a general idea about the problem that might be related to newer KERNEL and different headers (function prototype calls are stored there), or it might be related to newer GCC compiler reference calls. Missing dependances that it keeps refering, is part of GCC libraries (or kernel modules). I will try to install OpenSUSE 11.0 instead to see the difference. As i can see most of successifull installations were done on release 11.0 , nobody mentioned 11.1 release.
Thanks again.

Perhaps try using the 11.0 live cd first and if it works, then install 11.0
If you are intent on doing a fresh install, try forcing the .rpm install - as root in a terminal type rpm -ivf filename.rpm
If it works , fine and you saved a fresh install, if not you were going to reinstall anyway.
Meantime complain to canon.
From a couple of bad experiences with printers, the last with samsung, I now rather pay the extra and get hp or other supported gear. Some manufacturers like samsung say they include linux drivers, but these are usually old and don’t work on newer versions. When pressed, they come up with all kinds of reasons why they never mis-sold the printer by putting ‘Linux drivers included’ on the box!

Thanks all for participation, i solved the problem, it was a c++ shared lib that caused the problem, added a propper package and instaled driver,

Now i have other problem, printer detected and driver assigned in CUPS, but print job waits endlessly with infinite ‘Processing…’.

I’m frustrated.

a key thing in the LBP seems to be the final bit:

sudo /etc/init.d/ccpd restart

we did this manually on our OpenSuse for a while;

can you try the above as a once-off command:

if it works, you either use it each time, or

Set ccpd to start when you startup your computer:

gnomesu gedit /etc/rc.local

and add at the end :

/etc/init.d/ccpd start

save and close

the links I found helpful were:

Unixmen- Linux Howtos and Tutorials - Howto : Install Canon LBP2900 printer on Linux