Strange boot messages

I spotted the following messages while booting (pressing the Esc key as soon as booting starts). These appeared within the first 10-15 lines.

FATAL Module AHCI not found
FATAL Module ATA_Piix not found
FATAL Error running install command for ATA_Piix
I looked in the start-up logs and dmesg but they don’t show these messages so I guess they are appearing before logging starts.

Any clues why this is happening or how to fix it?

I also found this in the dmesg logs which I thought didn’t look right. That BUG note below appear 24 times.

0.016083] BUG: scheduling while atomic: swapper/0/0x10000002               
0.016094] Modules linked in:                                               
0.016100] Pid: 0, comm: swapper Not tainted #1        
0.016104] Call Trace:                                                      
0.016125]  <c020845a>] try_stack_unwind+0x17a/0x1a0                       
0.016134]  <c020708c>] dump_trace+0x6c/0x130                              
0.016141]  <c0208008>] show_trace_log_lvl+0x58/0x80                       
0.016148]  <c0208056>] show_trace+0x26/0x40                               
0.016156]  <c0692e53>] dump_stack+0x79/0x91                               
0.016164]  <c023f137>] __schedule_bug+0x87/0x90                           
0.016171]  <c0693b88>] schedule+0x688/0x7a0                               
0.016179]  <c02480eb>] __cond_resched+0x2b/0x60                           
0.016185]  <c0693dfd>] _cond_resched+0x3d/0x50                            
0.016193]  <c02d3adc>] generic_perform_write+0x13c/0x1e0                  
0.016200]  <c02d3bfb>] generic_file_buffered_write+0x7b/0x150             
0.016207]  <c02d55c3>] __generic_file_aio_write_nolock+0x213/0x530        
0.016214]  <c02d5a15>] generic_file_aio_write+0x65/0xe0                   
0.016221]  <c031538c>] do_sync_write+0xdc/0x130                           
0.016228]  <c03156ba>] vfs_write+0xba/0x1b0                               
0.016235]  <c03160c3>] sys_write+0x53/0xa0                                
0.016243]  <c0981627>] do_copy+0xa1/0xe6                                  
0.016249]  <c0980f6b>] flush_buffer+0x81/0xb8                             
0.016257]  <c09a770d>] gunzip+0x374/0x428                                 
0.016264]  <c098147b>] unpack_to_rootfs+0x29f/0x3aa                       
0.016271]  <c0981ef9>] populate_rootfs+0x59/0x87                          
0.016277]  <c097fcd3>] start_kernel+0x38d/0x3ae                           
0.016284]  <c097f087>] i386_start_kernel+0x87/0x9f                        
0.025277] BUG: scheduling while atomic: swapper/0/0x10000002               
0.025287] Modules linked in:                                               
0.025292] Pid: 0, comm: swapper Not tainted #1        
0.025296] Call Trace:                                                      
0.025309]  <c020845a>] try_stack_unwind+0x17a/0x1a0                       
0.025316]  <c020708c>] dump_trace+0x6c/0x130                              
0.025323]  <c0208008>] show_trace_log_lvl+0x58/0x80                       
0.025330]  <c0208056>] show_trace+0x26/0x40                               
0.025337]  <c0692e53>] dump_stack+0x79/0x91                               
0.025344]  <c023f137>] __schedule_bug+0x87/0x90                           
0.025351]  <c0693b88>] schedule+0x688/0x7a0                               
0.025358]  <c02480eb>] __cond_resched+0x2b/0x60                           
0.025365]  <c0693dfd>] _cond_resched+0x3d/0x50                            
0.025372]  <c02d3adc>] generic_perform_write+0x13c/0x1e0                  
0.025379]  <c02d3bfb>] generic_file_buffered_write+0x7b/0x150             
0.025386]  <c02d55c3>] __generic_file_aio_write_nolock+0x213/0x530        
0.025393]  <c02d5a15>] generic_file_aio_write+0x65/0xe0                   
0.025400]  <c031538c>] do_sync_write+0xdc/0x130                           
0.025406]  <c03156ba>] vfs_write+0xba/0x1b0                               
0.025412]  <c03160c3>] sys_write+0x53/0xa0                                
0.025419]  <c0981627>] do_copy+0xa1/0xe6                                  
0.025425]  <c0980f6b>] flush_buffer+0x81/0xb8                             
0.025432]  <c09a770d>] gunzip+0x374/0x428                                 
0.025439]  <c098147b>] unpack_to_rootfs+0x29f/0x3aa                       
0.025446]  <c0981ef9>] populate_rootfs+0x59/0x87                          
0.025452]  <c097fcd3>] start_kernel+0x38d/0x3ae                           
0.025459]  <c097f087>] i386_start_kernel+0x87/0x9f                        
0.034259] BUG: scheduling while atomic: swapper/0/0x10000002               
0.034270] Modules linked in:                                               
0.034274] Pid: 0, comm: swapper Not tainted #1        


0.238416] Call Trace:                                                      
0.238442]  <c020845a>] try_stack_unwind+0x17a/0x1a0                       
0.238450]  <c020708c>] dump_trace+0x6c/0x130                              
0.238457]  <c0208008>] show_trace_log_lvl+0x58/0x80                       
0.238464]  <c0208056>] show_trace+0x26/0x40                               
0.238473]  <c0692e53>] dump_stack+0x79/0x91                               
0.238482]  <c023f137>] __schedule_bug+0x87/0x90                           
0.238489]  <c0693b88>] schedule+0x688/0x7a0                               
0.238497]  <c02480eb>] __cond_resched+0x2b/0x60                           
0.238504]  <c0693dfd>] _cond_resched+0x3d/0x50                            
0.238514]  <c048c574>] acpi_ps_complete_op+0x229/0x249                    
0.238523]  <c048c9bb>] acpi_ps_parse_loop+0x2e4/0x331                     
0.238531]  <c048b9d8>] acpi_ps_parse_aml+0xdd/0x33e                       
0.238539]  <c048a890>] acpi_ns_one_complete_parse+0x11c/0x149             
0.238547]  <c048a8ff>] acpi_ns_parse_table+0x42/0x8f                      
0.238554]  <c0487059>] acpi_ns_load_table+0x69/0xf8                       
0.238562]  <c048ef1c>] acpi_tb_load_namespace+0x6e/0x136                  
0.238569]  <c048effa>] acpi_load_tables+0x16/0x4b                         
0.238578]  <c09abfe7>] acpi_early_init+0x7e/0x11d                         
0.238586]  <c097fcd8>] start_kernel+0x392/0x3ae                           
0.238593]  <c097f087>] i386_start_kernel+0x87/0x9f                        
0.246971] BUG: scheduling while atomic: swapper/0/0x10000002               
0.246982] Modules linked in:                                               
0.246987] Pid: 0, comm: swapper Not tainted #1        
0.246990] Call Trace:                                                      
0.246999]  <c020845a>] try_stack_unwind+0x17a/0x1a0                       
0.247006]  <c020708c>] dump_trace+0x6c/0x130                              
0.247013]  <c0208008>] show_trace_log_lvl+0x58/0x80                       
0.247020]  <c0208056>] show_trace+0x26/0x40                               
0.247027]  <c0692e53>] dump_stack+0x79/0x91                               
0.247033]  <c023f137>] __schedule_bug+0x87/0x90                           
0.247040]  <c0693b88>] schedule+0x688/0x7a0                               
0.247046]  <c02480eb>] __cond_resched+0x2b/0x60                           
0.247053]  <c0693dfd>] _cond_resched+0x3d/0x50                            
0.247060]  <c048c574>] acpi_ps_complete_op+0x229/0x249                    
0.247068]  <c048c9bb>] acpi_ps_parse_loop+0x2e4/0x331                     
0.247076]  <c048b9d8>] acpi_ps_parse_aml+0xdd/0x33e                       
0.247083]  <c048a890>] acpi_ns_one_complete_parse+0x11c/0x149             
0.247091]  <c048a931>] acpi_ns_parse_table+0x74/0x8f                      
0.247098]  <c0487059>] acpi_ns_load_table+0x69/0xf8                       
0.247105]  <c048ef1c>] acpi_tb_load_namespace+0x6e/0x136                  
0.247111]  <c048effa>] acpi_load_tables+0x16/0x4b                         
0.247118]  <c09abfe7>] acpi_early_init+0x7e/0x11d                         
0.247125]  <c097fcd8>] start_kernel+0x392/0x3ae                           
0.247131]  <c097f087>] i386_start_kernel+0x87/0x9f                        
0.257254] Mapping cpu 0 to node 0                   

The above repeats 24 times. As far as I can see each call trace looks identical. Surely this isn’t normal is it? Any clues?

I also have these "Failed resume from disk messages intersperse in the dmseg.

1.280074] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/input/input1                                                                      
1.283770] PM: Resume from disk failed.                                     
1.283788] registered taskstats version 1                                   
2.223641] PM: Starting manual resume from disk                             
2.223646] PM: Resume from partition 8:6                                    
2.223649] PM: Checking hibernation image.                                  
2.223900] PM: Resume from disk failed.                                     
2.295854] usb 1-6.1: New USB device found, idVendor=046d, idProduct=c50e   

There was no resume from disk. It was a cold boot so why do these show up?

[EDIT] These are on my Thinkpad laptop - details in the sig below.

FATAL: Module ata_piix not found - openSUSE Forums

There is a AHCI setting in the BIOS of Lenovo’s
I think mine is on Compatibility mode

Thanks caf. I’ll look for that setting in the bios the next time I boot up. Is setting the bios a preferable method than removing the module in initrd or is that module not required anyway?

Any idea why I’m getting 24 instances of the that bug in the dmesg? Is it normal?

Strange how we may on face value seem to have similar Laptops, yet mine works flawlessly.
Anyway. In short, I really have no idea on all this, I just Googled ATA_piix
and informed you of the AHCI from experience. IIRC, when I tried XP on this, it was no go with AHCI. Having it on doesn’t make any difference to Linux though.
You’ll just have to experiment. It may be that even though you have those errors, it doesn’t affect the overall usability of your machine or impede the boot process.

Yes, I’m surprised I’m experiencing these problems when 11.1 basically worked very well. I was hoping the upgrade to 11.2 with new kernel and drivers would improve things, and some things have, but I found many things regressed too.

That resume from disk error is a bit misleading. The way the kernel discovers whether it was a resume is simply to try to find a resume image in the swap partition and if there is one, then resume it, otherwise proceed as a cold boot. A good argument for not reading too much into this boot system message.

OK, I’ll ignore the resume from disk. The other stuff still bugs me though. Googling BUG: scheduling while atomic: swapper/0/0x10000002 came up with quite a few hits. However they discussions going on are way above my head.

This seems to be a comprehensive discussion but I don’t really understand what’s going on.

I’m also seeing BUG: scheduling while atomic: swapper/0/0x10000002 at boot, after installing latest kernel patch.

In addition, since kernel patching, GKrellM no longer reports actual HDD temp. It was running fine prior to this. CPU temp reporting is OK.

Reverting system back to pre-patch state.

Hmmm, I can’t say if this appeared after the kernel patch or not as I didn’t look at the boot messages very closely before.

ok ive got same error in BUT :frowning:

not in de former kernel :slight_smile:

with the same PC offcourse :sarcastic:

Ps AHCI is buildin the kernel ie its not a module
else u had no Sata-HDD to control ie kernel doesnt know how
to deal with it

FATAL Error running install command for ATA_Piix < thought this was for intel


SRY didt saw Thinkpad was powered by Intel

ATA_Piix is needed for Pata-HDD

I’ve seen other references that these errors appeared with kernel but haven’t bothered rolling back to check.

I’ve tried setting the SATA controller to AHCI and Compatibility mode and they both throw the AHCI error on boot so don’t know what’s going on there.

My Intel Thinkpad has a SATA drive so why would the kernel even attempt to load ATA_Piix?

I’m not seeing any adverse effects from these errors so am just leaving things for now.

ata-piix gets Probed/loaded even no drives are attached , during setup
coz its buildin the kernel ie it aint a module , so its ok

< I’ve tried setting the SATA controller to AHCI and Compatibility mode and they both throw the AHCI error on boot so don’t know what’s going on there. >

I get the idea u set some in the bios for AHCI , not needed.

It cant load Module AHCI coz its build in the kernel itself
But /boot/initrd gets configured with AHCI as a module
( SuSE fix this 1 plz )

look for it in the file /boot/config-

Here is a snippet off it



CONFIG_SATA_AHCI=y < build in
CONFIG_ATA_PIIX=y < build in also

CONFIG_PATA_ATIIXP=m < for me this gets loaded but not used
all devices get probed , for me the PATA_ATIIXP module gets loaded with suse kernel while its not used at all

So all remarks over AHCI can be ignored , else u had no HDD