Strange behavior when suspending to ram/disk on 11.1

Then, take a loot at Suspend to RAM - openSUSE
There are important hints to make suspend to ram work with specific graphics
cards, in special the ATI ones.

Good luck!


Hey guys,

I have got suspend to both RAM and disk working. Searching in Bugzilla of
Novell ( I realized that the
module ehci_hcd was making my laptop wake up immediately after
suspending to RAM or to disk. I made a test:

  1. I run “lsmod | grep ehci” and saw that ehci_hcd was loaded.
  2. Then I unloaded the module with “rmmod ehci_hcd”.
  3. I tested s2ram with “s2ram -f” (my laptop is not in white list of s2ram).

So, my laptop suspended to RAM wonderfully!
The only problem is that with the module ehci_hcd unloaded, my USB
webcam does not work and data tranference for my pen drive was too slow.
Loading the module again only solve my pen drive problem, but my webcam
still does not work. After wasting a lot of time, I relized that unloding
the module uhci_hcd before unloading ehci_hcd, and loading these modules
again did not cause problems to my webcam neither pen drive.

So, the trick is to edit the pm-utils so that the modules ehci_hcd and uhci_hcd
are unloaded before suspending and loaded after resuming. To do this,
I used the hints from Pm-utils - openSUSE .
Then, with these hints, I created the file “config” in the folder
“/etc/pm/config.d/”. So now, cat /etc/pm/config.d/config give me:

SUSPEND_MODULES="uhci_hcd ehci_hcd"
S2RAM_OPTS="-f -p"

Let me explain:

  1. SUSPEND_MODULES=“uhci_hcd ehci_hcd” says to pm-utils which
    modules will be unloaded before suspending and loaded after resuming.

2.S2RAM_OPTS="-f -p" are the options of s2ram to make my laptop
suspend to RAM. For me, “-f” is because my machine is not in the white list
of s2ram (see Suspend to RAM - openSUSE for information about s2ram
options). The “-p” case is because I realized that my laptop only suspended
in the lid close once. After that, the lid close seemed not to cause any effect.
Adding “-p” to the S2RAM_OPTS= fixed this. Now, I can suspend to ram
when the lid is closed whenever I want. :wink:

Now, suspend to RAM and suspending disk works fine when called from
Kpowersave or from the K menu. There is still a problem: I cannot suspending
when connected to internet via USB 3G modem. So, every time when I
will suspend, I have to finish my internet 3G conection (I use kppp for
3G conection). For me, this is not a serious problem.

If any one has any criticism about what I did, please, let me know.
I hope have helped someone.


OK guys, after a long while I got the problem solved (somehow). I disabled KWin and suspending worked fine.
I am using intel driver for x3100 onboard graphic btw.

The ednso’s solution for suspend work for me.

After search for few days in google and at suse forum and an fellow countryman give the solution.