Strange "audio" or maybe "video" problem.

Hi everyone!

I’m not sure who to turn to. I’m a bit of a newbie (not so much).

For the last few days (maybe after an update, but I’m not sure), there is a strange problem with audio playback. I thought at first it was audio, but now I’m not sure. Let me explain.

If I try playing a video file (smplayer) from a fresh boot, it works perfectly, for a while. Then audio starts getting corrupted. Noise here and there, video stops, and so on, until the stream just fails, mplayer crashes and I get this terrible noise (with a much higher volume than the video had, sounds like a-a-a-a-a…).

Tried with kaffeine and it’s the same. Tried changing audio output to alsa, oss, jack… it’s the same.

Also, sometimes when I’m typing, it suddenly stops updating and the last letter keeps repeatttttttttttttttttttttttttttttttttttttting.

The same problems when playing games in wine. Suddenly sound starts going bad until it crashes.

Same for youtube videos and so on. I thought it was an audio problem, but I put mplayer ao to null and I still get the freeze-ups.

It’s also not a KDE specific problem, same happens with Ice.

And finally, it’s not a hardware problem, because windows works perfectly (as well as windows can work, that is).

The last piece of the puzzle is that mythTV works surprisingly well. While it does have noise and slowdowns here and there, it doesn’t crash.

This are my specs:
Running: opensuse 11, KDE 4.1, everything updated. Using packman repo.
Processor: Intel duo 2.1Ghz
GPU: nvidia 8800 GT
Audio: ALC882
Memory: 2G

Anything else I need to say?

Well, any help is much appreciated.

Things working well with Wndows doesn’t really help you in narrowing down your problems - Win tends to be more tolerant with hardware-failures, esp. RAM-wise; Linux uses RAM much more intense than Win.

I would check the RAM for two or three couple of hours with memtest.

Also check the running processes when the problem occurs - it will be helpful to isolate a single process in case it still is a problem of your system.

I agree with the recommendation of gropiuskalle.

Note when testing for running processes, while your sound is working good, I recommend you run in a gnome-terminal or konsole:lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*to get a flavour as to what a good setup looks like (the above will tell you what devices are using your sound). Also to monitor your running processes you can open a second gnome-terminal or konsole and type “top” and let that run.

When your problem reappears, re-run lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*and compare the earlier output with this current output.

Also check what is showing in “top”

Thanks guys!

The last update (from today) actually fixed it. So I guess we’ll never know what it was :slight_smile:

I had similar issue. one of the last weeks update should have caused it.
i was watching TV on Hauppauge 150, it started fine, but then the voice started crackling. initially it was for short duration and then i couldnt even understand a single word.

The last update fixed the issue. i thought my fooling around in the system had caused the problem. well atleast i know i was not at fault. :wink: