story of suse and nvidia with a happy end

I like openSUSE but installing nvidia drivers on my box was very difficult, almost dropped the whole thing. One click install was not doing it 4me so i manually compiled the newest driver from nvidia web site. Everything worked ok untill i’ve tried to start compiz. By reading the fusion-icon error report i saw that it cant read xgl vendor and glx-gears wont start either because of missing xgl extension… I’ve decided to give drivers from nvidia repo one more try but i’ve first backed up nvidia module that i previously compiled (/lib/modules/kernel-default/kernel/drivers/video/nvidia.ko). As expected gdm wont start because nvidia driver wont load (no devices found error). If xgl was the problem before i’ve installed nvidiaG01 driver now it was certainly fixed (installed x11-nvidia as a dep) and i’ve just copied backed up nvidia.ko from previous compiled driver and voilla, gdm started upon reboot, compiz works, everything works. I am not the only one with this sort of a problem with nvidia drivers and it seems to affect mostly computers with nvidia chipset based mainboards (regardless if its AGP or PCI-E, nFORCE 2 or 3). I have Epox 8RDA3+ nFORCE2 mainboard and nVIDIA 7300GT AGP card. Tried to follow instructions on opensuse site with sax2 -r -m 0=nvidia, nvagp 2, never worked… I think that the precompiled driver (both legacy and new) is not compiled correctly (not to work on all hardware configurations at least).